Contribute
Register

High Sierra 10.3.4 update - does printf work??

Status
Not open for further replies.

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,876
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I deleted NullCPU Kext. No change.
It was just an observation and I would not expect it to have any impact on your booting problem but it should help with your power management once you are able to boot.

Tried some of those combinations...still getting error loading kernel cache.
Which version of Clover are you using ?
 
Joined
Jun 14, 2015
Messages
5
Mac
Classic Mac
Mobile Phone
I'm getting same error does printf work?? I have MSI Z170A M7 6700K
Any solution for this?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,379
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@HatNet, please update your profile (personal details) with your Motherboard, CPU and Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Oct 14, 2011
Messages
13
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K
Graphics
Radeon Pro W6800
I've ran into the same issue although I'm typically able to boot after a second attempt; it never makes it to 10.13.4.

Initially I noticed that attempting to boot in safe mode/verbose would lead to a successful reboot.

I did try using OsxAptioFixDrv, but that left me in a state where nothing would boot at all; I couldn't get a shell no matter how hard I tried. To fix it I got a PCIe card for the nvme drive, put it in my eGPU case and used a mac laptop top to mount the EFI partition and reverted to OsxAptioFix2Drv... now I can boot again, but still working on getting the upgrade to work. Thought I would mention this stuff in case you get stuck in the same way I did.
 
Joined
Dec 19, 2010
Messages
85
Motherboard
Asus Hero X AC WiFi
CPU
i7-8086K
Graphics
Sapphire NITRO+ RX VEGA64 8G HBM2
Mac
  1. iMac
Mobile Phone
  1. iOS
I was finally able to boot into macOS. Here's how:

1. I was desperate and thought maybe because I had 2 drives with clover, there was some kind of collision. So I erased them both and tried to boot from USB installer. Didn't work.
2. I re-flashed my BIOS because I read that it was the only way to clear memory mapping that might interfere. Didn't work.
3. Finally, I messed with a couple of boot args. Apparently, it was a combination of dart=0 slide=0 -v nv_disable=1 and choosing to inject kexts that did the trick.
4. I was able to load the installer. I then restored from Time Machine.

All this while I was using OsxAptioFix3Drv.efi + I didn't have APFS.efi on the USB installer.

Hope this will help someone.

Thank you to everyone who helped!
 
Joined
Jul 19, 2016
Messages
196
Motherboard
Asus X79 Deluxe
CPU
E5-1680 V2
Graphics
RX 580
Mac
  1. Mac Pro
Mobile Phone
  1. iOS
glad you made it! did you manage to update as well?
in my case i updated to 10.13.4 and the next day i remembered to update the apfs.efi. so i still do not understand what caused all this mess.
As a side note, everybody suggests Carboncopy or super duper, but Timemachine does a great job as well.
also it is always good to have a working copy of your EFI partition in a USB before updating so you can use it in such cases.
 
Joined
Mar 6, 2011
Messages
267
Motherboard
Asus TUF Z690 Plus D4
CPU
i9-12900K
Graphics
RX 6900 XT (spoofed)
Mobile Phone
  1. Android
  2. iOS
I kept getting does printf work?? error as soon as I enabled thunderbolt 3 card and using
AptioMemoryFix.efi.i fixed by enabling Above 4G Decoding in Bios Boot Menu.might be worth a try for others with same prob
 
Status
Not open for further replies.
Top