Contribute
Register

High Sierra 10.13.6 fresh install can't detect Ethernet - Gigabyte z270p-d3

Status
Not open for further replies.
Joined
Nov 1, 2017
Messages
4
Motherboard
Gigabyte z270p-d3
CPU
i7-6700
Graphics
GTX 1070
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
I'm having trouble getting my Hackintosh to detect and connect to Ethernet. I had the Hackintosh working flawlessly for a couple years, and as of the last update was running High Sierra 10.13.4. However the OS became corrupt and needed to be reinstalled. I formatted everything, downloaded the most recent High Sierra from the app store, and did a fresh install (I have NVidia graphics which is why I'm staying on High Sierra, due to lack of kext support). Got everything working great except for the ethernet, which is needed (USB WiFi can't seem to get a strong/solid signal). Ethernet worked fine before.

I have tried multiple fixes, different versions of IntelMausiEthernet.kext, and am not having luck. I also tried using AtherosL1cEthernet.kext as I saw in other threads.

I'm at a loss as to why it can't detect an ethernet card. And before when it could detect the ethernet card, it was offline. The ethernet is good and works on the Windows side.

Any ideas?? More info & screenshots below.

---------

When I go to add a new network connection (screenshot below), I don't see Ethernet as an option. In System Information under Ethernet Cards, it says: "This computer does not appear to have any PCI Ethernet cards installed."

417224



Screenshot below, this is in HDD> EFI Mount>EFI> CLOVER > kexts>other
417219



Screenshot below, this is HDD>Library>Extensions folder
(Red: installed after fresh with Multibeast, Purple: Cuda for Nvidia graphics, Orange: Installed with NVidia web drivers, Green: Updated manually with newest version by overwriting kext, SiLabsUSB is for the USB WiFi receiver, also have WacomTablet, and I'm not sure about FTDIKext.)
417217



- Chipset: Intel z270 Intel i7
- Graphics: MSI Aero GeForce GTX 1070
- Motherboard Gigabyte z270p-d3
- Processor: Intel Quad Core™ i7-6700 Processor
- Memory 2400MHz Xidax Extreme DDR4 16GB
- 256GB SSD Drive
- 2nd HDD Western Digital Blue 1TB - 7200RPM 3.5" HDD
(SKYLAKE)


config.plist attached

-----

One more thing... As I was searching for an answer, I found that a handful of kexts are labeled "Kext with invalid signatured"
When I type into terminal:
sudo kextcache -i /
(see screenshot - I have not found a fix for this yet, not sure if it matters since everything is working fine except Ethernet)
417226
 

Attachments

  • config.plist
    8 KB · Views: 61
Last edited:
Status
Not open for further replies.
Top