Contribute
Register

Help with Realtek ALC294

Status
Not open for further replies.
Joined
Aug 18, 2014
Messages
19
Motherboard
ASUS X542UQ-DM011T
CPU
i5-7200U
Graphics
HD 620, GTX 940MX
I have a unique Realtek laptop codec that is identified as ALC294 by linux dump. After getting an Audio ID of 3 by patching the DSDT and using the native AppleHDA.kext, devices are detected in System Report but Sound Pane in System Preferences shows no audio output and input.
Specs:
OS X Version: Mac OS Sierra 10.12.6
Laptop Model: ASUS X542U
Processor: Intel i5-7200U
Graphics: Intel HD 620

At first, I tried using the updated FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext to no avail. I also tried cloverALC and AppleALC+Lilu methods even though my codec is not yet supported. I tried using AppleHDA Patcher as well hoping that other types of laptop codecs close to mine (290,292, & 295) might give a solution. I have never tried doing a manual patch myself. Using the latest VoodooHDA.kext lets the internal speaker and mic work sometimes.

Attached is a zip of all files required for problem reporting. I hope you can help me out on this. Thanks!
 

Attachments

  • Problem Reporting.zip
    2.6 MB · Views: 146

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have a unique Realtek laptop codec that is identified as ALC294 by linux dump. After getting an Audio ID of 3 by patching the DSDT and using the native AppleHDA.kext, devices are detected in System Report but Sound Pane in System Preferences shows no audio output and input.
Specs:
OS X Version: Mac OS Sierra 10.12.6
Laptop Model: ASUS X542U
Processor: Intel i5-7200U
Graphics: Intel HD 620

At first, I tried using the updated FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext to no avail. I also tried cloverALC and AppleALC+Lilu methods even though my codec is not yet supported. I tried using AppleHDA Patcher as well hoping that other types of laptop codecs close to mine (290,292, & 295) might give a solution. I have never tried doing a manual patch myself. Using the latest VoodooHDA.kext lets the internal speaker and mic work sometimes.

Attached is a zip of all files required for problem reporting. I hope you can help me out on this. Thanks!

Attach Linux audio codec dump.
 
Joined
Aug 18, 2014
Messages
19
Motherboard
ASUS X542UQ-DM011T
CPU
i5-7200U
Graphics
HD 620, GTX 940MX
Attach Linux audio codec dump.

linux codec dump is already included in the folder "misc linux dumps" inside the zip file. I'll attach it here anyway.
 

Attachments

  • codec_dump.txt
    10.8 KB · Views: 535

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Aug 18, 2014
Messages
19
Motherboard
ASUS X542UQ-DM011T
CPU
i5-7200U
Graphics
HD 620, GTX 940MX
It is Realtek ALC294 (0x10ec0294)
Use Mirone's AppleHDA patcher, then patch ACPI according the ACPI patching guide (layout-id, IRQ Fix).

Mirone's latest AppleHDA patcher has no codec option for ALC294 yet.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Mirone's latest AppleHDA patcher has no codec option for ALC294 yet.

Create your own XML (pathmaps, layout, pinconfigs) from your Linux audio codec dump.
You can use a similar codec as a template.
 
Joined
Aug 18, 2014
Messages
19
Motherboard
ASUS X542UQ-DM011T
CPU
i5-7200U
Graphics
HD 620, GTX 940MX
Create your own XML (pathmaps, layout, pinconfigs) from your Linux audio codec dump.
You can use a similar codec as a template.
I tried making my own XML files and used them in ALC295 from Mirone's patched AppleHDA.kext but it didn't work. I made sure that I extracted the correct pinconfigs from both codegraph and windows utility. When I tried to use edited aDummyHDA.kext with the appropriate clover patch, it showed something under the Audio Devices from System Information. Audio Devices.png

Output and Input tabs from System Information aren't greyed out anymore but there's still no sound coming out.
Output.png Input.png

I've attached the XML files as well.
 

Attachments

  • Audio.png
    Audio.png
    123.5 KB · Views: 549
  • ALC294.gif
    ALC294.gif
    18.9 KB · Views: 636
  • layout3.xml.txt
    40.7 KB · Views: 302
  • Platforms.xml.txt
    88.9 KB · Views: 315
  • aDummy info.plist
    19.3 KB · Views: 291

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,014
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I tried making my own XML files and used them in ALC295 from Mirone's patched AppleHDA.kext but it didn't work. I made sure that I extracted the correct pinconfigs from both codegraph and windows utility. When I tried to use edited aDummyHDA.kext with the appropriate clover patch, it showed something under the Audio Devices from System Information.View attachment 297346

Output and Input tabs from System Information aren't greyed out anymore but there's still no sound coming out.
View attachment 297347 View attachment 297348

I've attached the XML files as well.

Compare your XML to a working set of XML to find potential mistakes.
 
Joined
Feb 20, 2016
Messages
75
Motherboard
Dell XPS 9560 non-touch FHD
CPU
Intel Core i7-7700HQ
Graphics
Intel HD 630 | NVIDIA® GeForce® GTX 1050 | 1920x1080
Any Progress with this? I have alc294 but HDApatcher not working to give e sound?
 
Joined
Aug 18, 2014
Messages
19
Motherboard
ASUS X542UQ-DM011T
CPU
i5-7200U
Graphics
HD 620, GTX 940MX
None yet, use VoodooHDA at the moment for the workaround.
 
Status
Not open for further replies.
Top