Contribute
Register

Help with DSDT patching - battery status

Joined
Dec 10, 2012
Messages
6
Motherboard
hp dv7 4295us
CPU
i7-2630QM/HM65
Graphics
HD 5730/6570M – 2560x1080
Mac
MacBook Pro
Mobile Phone
Android
Hey, Rehabman. I Think at this point you are the only person in the world that can help me. I managed to get High Sierra installed and almost everything working on my HP dv7-4295US notebook, including ATI vídeo acceleration and SD card reader.

But I cant’t get the battery indicator working. It shows battery charge = 0, wich is not true, i have triple boot and Windows 10 shows the right battery charge percentage). And it shuts down as soon as i unplug it from the ac adaptor.

Specs: (i7-2630QM – HM65 – cougar point B3 - sandy bridge -Intel(R) 6 Series/C200 Series Chipset Family - ATI/AMD Mobility Radeon HD 5730/6570M (MADISON XT/Capilano XT) – HDMI 2560x1080@57Hz .

See my full hardware info attached. See my config.plist attached. See my original DSDT.aml attached. Ioreg copy attached

I boot with Clover 5.2.0.1 legacy. Bios Insyde F.0F. Have triple boot High Sierra, Windows 10 and Linux Mint

What i have tried already:

Have installed the last version of ACPIBatterymanager.kext - 1.82, and rebuilt kext cache

Patched DSDT extracted with clover F4 (disassembled with iasl)

Tried using those of your patches:

DV7-6xxx (there’s reports of this one working on machines with i7-2630qm (wich is exactly my processor)

DV6-t 6b00 (this one doesn’t modify anything, but doesn’work either)

HP Envy 14 (Sandy bridge too, but no success)

Tried combination of two of them too, tried even apply the three patches a the same time.

Tried with Windows 7 check OS, with mutex patch

Tried with refs.txt too.


It took me a lot of time to get video aceleraton , áudio and card reader working, but the battery, no matter how much i tried, Always failed. It’s beyond my capacity.

Could you, or someone else here help me?
Thanks.
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,929
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey, Rehabman. I Think at this point you are the only person in the world that can help me. I managed to get High Sierra installed and almost everything working on my HP dv7-4295US notebook, including ATI vídeo acceleration and SD card reader.

But I cant’t get the battery indicator working. It shows battery charge = 0, wich is not true, i have triple boot and Windows 10 shows the right battery charge percentage). And it shuts down as soon as i unplug it from the ac adaptor.

Specs: (i7-2630QM – HM65 – cougar point B3 - sandy bridge -Intel(R) 6 Series/C200 Series Chipset Family - ATI/AMD Mobility Radeon HD 5730/6570M (MADISON XT/Capilano XT) – HDMI 2560x1080@57Hz .

See my full hardware info attached. See my config.plist attached.

I boot with Clover 5.2.0.1 legacy. Bios Insyde F.0F. Have triple boot High Sierra, Windows 10 and Linux Mint

What i have tried already:

Have installed the last version of ACPIBatterymanager.kext - 1.82, and rebuilt kext cache

Patched DSDT extracted with clover F4 (disassembled with iasl)

Tried using those of your patches:

DV7-6xxx (there’s reports of this one working on machines with i7-2630qm (wich is exactly my processor)

DV6-t 6b00 (this one doesn’t modify anything, but doesn’work either)

HP Envy 14 (Sandy bridge too, but no success)

Tried combination of two of them too, tried even apply the three patches a the same time.

Tried with Windows 7 check OS, with mutex patch

Tried with refs.txt too.


It took me a lot of time to get video aceleraton , áudio and card reader working, but the battery, no matter how much i tried, Always failed. It’s beyond my capacity.

Could you, or someone else here help me?
Thanks.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Top