Contribute
Register

Help with Clover: GTX 750Ti & i7 4790K's HD 4600 Graphics to use two monitors.

Status
Not open for further replies.
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
Help with GTX 750Ti & i7 4790K's HD 4600 Graphics to use dual monitors.

Hi, I have just got up and running with a basically bang perfect OS X El Captain install on my MSI z97 PC MATE, i7 4790k, GTX 750Ti system. First time I have managed to get anywhere as I knew exactly what to do this time yippee. I am trying to get my i7's HD 4600 graphics working in OS X so I can get using my two displays (main in the 750Ti HDMI, second in onboard HDMI).

From what I can see in the Clover Configurator, I need to do ig-platform-id along with inject Intel. What will be the ID I put in for my specific config though as I see that it is different depending on your CPU and Mobo.

Took a while to work out what I did wrong at first as I followed what someone else said but my screen was going black after booting meaning the ID I obviously used was the wrong one. I have in my UEFI settings both graphics devices enabled for dual displays just for a note.

Also for reference my boot args are 'npci=0x2000 nvda_drv=1'. I took out dart=0 as it's working flawlessly with VT-d enabled.

Am I able to have fast boot enabled or is that a no no?
edit: Fast boot works flawlessly ;D

Thanks in advance
Jase
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
Does anyone have any ideas? This is the only thing I need to do along with getting onboard audio working (not much of a rush as got an external sound card) and then I am done.

After playing around with the UEFI settings, finally managed to get MSI fast boot going directly to clover and then for Windows turned off the fast boot so it doesn't lock me out of OS X each time I turn off. Then just got to get some more sata connector/power cables so I can get it onto my ssd that's currently in my Mac so everything on my mac will go onto a hdd again and the hdd and ssd in the mac both in the computer :p So rewarding how well this is working, just a couple things left and am done :D
 
Joined
Jun 26, 2012
Messages
4,096
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  2. Other
IGPlatform ID for HD4600 use OD220003. Your current IGP detection in "About This Mac" will probably be Intel Iris Pro. As for onboard audio, your motherboard codec is ALC887. SeeAudio - Realtek ALC AppleHDA [Guide] Section 3 relates to CloverALC.
 
Joined
Jun 15, 2015
Messages
59
Motherboard
Z97-A
CPU
i5 4690k@4.4GHz
Graphics
GTX970/HD4600
Mac
Classic Mac
Mobile Phone
I used the ALC892 patch for my Z97, and to get integrated gfx working alongside pci gfx I have to set in BIOS the default graphics option as CPU instead of PCI
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
If I change that setting, will it play any effect with which you have as the main display? As obviously the one in the 750 I want as the main display and it's a touchscreen too that I use as my main display which doesn't work correctly on Windows if the other screen is the main display. I am guessing this just changes what display it posts on and nothing else?
 
Joined
Jun 15, 2015
Messages
59
Motherboard
Z97-A
CPU
i5 4690k@4.4GHz
Graphics
GTX970/HD4600
Mac
Classic Mac
Mobile Phone
Yeah it posts on the integrated but main display is pci. Main display being whatever the whitebar is set to in your display preferences under arrangement tab
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
Ok and a quick question regarding Clover. It's showing also the Recovery partition. Is this worth keeping or is it pointless? If it is worth keeping how do I hide it?
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
OS X sees both now but when I set the intergrated graphics as the primary boot device in the UEFI settings, the IGD Multi-Monitor option is disabled. When I set the GPU (shown as PEG) as the primary device, both displays have no signel (not simply the screens are black, they can't see a signel from the HDMI).

Really wish the 750 itself had two HDMIs then this wouldn't be an issue. That's the only thing I hate about the 750 (at least the MSI version)
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
Right I am sorted. Decided to use a DVI to HDMI cable for the secondary monitor so I am not using the integrated graphics at all now. At least I know the integrated graphics are working when I change the boot device over to integrated but as it doesn't look like there's a way around it on the z97 PC MATE, just a lot easier using the DVI port on the GPU. Wish it was HDMI but there again, I see zero difference and I use the one that the HDMI is in for all the graphics stuff. Glad it is working and so glad ASUS gave me a DVI to HDMI cable with the monitor haha. Thanks for the help, audio is working perfectly. Only thing that isn't working is sleep as it crashes when it wakes but I always turn that off anyway as computers only decide to go to sleep when they're supposed to be working XD. Would be brilliant to find the solution as I am sure not everyone can or wants this solution but I seriously can see no difference lol.

I worked out what was messing up when I was changing it back to the GPU in settings after changing it. I was doing the magic wand on the smbios to the iMac with the 4790k but it might of been because that iMac has an AMD card not a Nvidia card. So put it back so it just shows what it was by default.
 
Joined
Aug 25, 2013
Messages
33
Motherboard
MSI Z97 PC MATE
CPU
Intel i7 4790K Quad Core 4.0GHZ
Graphics
XFX GTR AMD RX 480
Mac
  1. Mac mini
Mobile Phone
  1. Android
Quick question regarding power management? How can I tell if power management is working 100%? Guess it wouldn't be stable? Transferred OS X onto the same SSD as Windows and put clover into the EFI partition and just needed to use EasyUEFI on Windows to add clover as a boot option. Love how easy moving everything is with UEFI. Now that know it works flawlessly just got to move my os x on my mini onto the hdd and then clone the computer's 250gb ssd onto the 500gb ssd and then put os x from the hdd onto the 250gb ssd. Have a clear idea what I need to do with updates, just clone the os x install onto a hdd, update it on the hdd, get it all working and put it back onto the ssd. Safer doing it that way than possibly messing up Windows.
 
Status
Not open for further replies.
Top