Contribute
Register

help with clover bootloader and imac

Joined
Dec 7, 2018
Messages
5
CPU
i5
Graphics
HD 6770M
can someone help me please?
has previously said in another thread i have a genuine iMac mid 2011 27" born with snow leopard; right now im on high sierra 10.13.6
I have installed clover bootloader and the configurator but im unable to boot from its bootloader, the system integrity protection is (obviously) disabled and also all the updates(including security ones).
when i boot from the mac partition all goes well but i assume the kext files are not loaded. instead some days ago i tried to boot with definition of an imac late 2012 profile (13,2) with fakecpuid of its model as well and all it was showing is the apple logo and 3 sound beep, probably of some devices not detected. i had also these kext installed: FakeSMC, Lilu, what ever green, hibernationfixup and USBInjectAll.
now i delete some of them, i only have fakesmc and lilu. i delete the cpu and computer model id that were conflicting;
after resetting nvram/pram and kext cache, i booted my partition with clover (in the option i deactivate the intel graphic injection because i have only the intel cpu+amd 6770m) i used the verbose mode: it was loading all correctly until it stopped at these lines very very slowly (up to 1 minute of waiting):
kektd stall[0], (60s): 'ACPI_SMC_PlatformPlugin', 'MCHC', 'IGPU'

then another minute with the same line but with the number 1 in the brackets
kektd stall[1], (60s): 'ACPI_SMC_PlatformPlugin', 'MCHC', 'IGPU'

then the number 2
kektd stall[2], (60s): 'ACPI_SMC_PlatformPlugin', 'MCHC', 'IGPU'

after that it showed me these:
IO80211Controller::dataLinkLayerAttachComplete(): adding AppleEF INVRAM notification
IO80211Interface::efiNVRAMPublished():
initting Scan Manager controller 0xoeaff67bd894183bd ioservice 0xeaff67bcaac9613d interface (and other strings dont captured in the camera)
bpfAttach len 60 dlt 12
kektd stall[3], (60s): 'ACPI_SMC_PlatformPlugin', 'MCHC', 'IGPU'

here stopped definitely and after 7 minutes i turned off.
so whats the problem?
my bet on this imac is to get back boot time and disk speed i have on snow leopard. 2 weeks ago i tried to replace the IO kext of HS with the lion ones,the imac botted up just fine but in terms of performance nothing has changed:(:(:oops::oops:
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
15,615
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
iMac, Mac mini
Mobile Phone
Android
Have you installed the Clover bootloader onto your real 2011 Apple iMac ? If so, why ? There is no need for it on an iMac. FakeSMC is only for use on a hackintosh, not a real Mac. Lilu is also not needed on an iMac. etc. etc. etc.

The most effective way to speed up an old iMac is to clone the system drive to an SSD and then replace the original HDD with that SSD and boot from that. What you've attempted will never speed up boot times.

https://www.tonymacx86.com/threads/warning-report-booting-clover-on-a-real-mac-can-be-dangerous.229629/

You can try to remove Clover from the EFI partition on your iMac and see if that works first.
https://www.tonymacx86.com/threads/how-to-uninstall-clover-from-a-real-mac.268531/#post-1883057

Also delete any other hackintosh specific kexts like FakeSMC from wherever those have been installed.
 
Last edited:
Top