Contribute
Register

[Help] Thinkpad T540p lock screen and sleep problem

Joined
Nov 21, 2017
Messages
88
Motherboard
thinkpad t540p
CPU
i5-4300M
Graphics
Intel HD 4600
Mobile Phone
Android, iOS
deleted message
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I follow this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
I installed High Sierra to HDD successful.
Then follow this guide https://www.tonymacx86.com/threads/guide-native-power-management-for-laptops.175801/
(to have native power management)

then follow this guide
https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222
(to patch backlight control)

after patch backlight, I can adjust backlight bar in system preference


1) I tried to lock screen (from Apple Menu)
few seconds later, screen switch to black ( backlight still available)
I move the mouse or press any key, there is no change, sometime screen flash light ( check the video attached)
Cannot go back to login screen => have to hard reset machine.

2) when I sleep from system menu, system go to sleep, led power blinking, but cannot wakeup back again, I have to hard reset
Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

I didn't check anything else.
 
Joined
Nov 21, 2017
Messages
88
Motherboard
thinkpad t540p
CPU
i5-4300M
Graphics
Intel HD 4600
Mobile Phone
Android, iOS
I follow this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
I installed High Sierra to HDD successful.
Then follow this guide https://www.tonymacx86.com/threads/guide-native-power-management-for-laptops.175801/
(to have native power management)

then follow this guide
https://www.tonymacx86.com/threads/...trol-using-applebacklightinjector-kext.218222
(to patch backlight control)

after patch backlight, I can adjust backlight bar in system preference


1) I tried to lock screen (from Apple Menu)
few seconds later, screen switch to black ( backlight still available)
I move the mouse or press any key, there is no change, sometime screen flash light ( check the video attached)
Cannot go back to login screen => have to hard reset machine.

2) when I sleep from system menu, system go to sleep, led power blinking, but cannot wakeup back again, I have to hard reset


Your kextcache output proves kexts are not installed correctly.
All kexts you need must be installed to the system volume.
Read post #2 of the Clover guide for details:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

I didn't check anything else.
Thanks for your fast reply
I install all kexts to
/L/E/
then rebuild kexts

but there is no changes,
after lock screen few second, monitor go off, and never wake up, sometimes flash (and dim darker then brighter).
it does not appear in logout mode.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks for your fast reply
I install all kexts to
/L/E/
then rebuild kexts

but there is no changes,
after lock screen few second, monitor go off, and never wake up, sometimes flash (and dim darker then brighter).
it does not appear in logout mode.
It probably has something to do with your use of a desktop ig-platform-id (0x0d220003).
Typically, we use 0xa260006 or 0xa260005 (or other laptop oriented ig-platform-id).
 
Joined
Nov 21, 2017
Messages
88
Motherboard
thinkpad t540p
CPU
i5-4300M
Graphics
Intel HD 4600
Mobile Phone
Android, iOS
It probably has something to do with your use of a desktop ig-platform-id (0x0d220003).
Typically, we use 0xa260006 or 0xa260005 (or other laptop oriented ig-platform-id).
I have a trouble after copy all kext to /L/E then rebuild kext
my analog speaker not work
I think cause is rebuild kext in /L/E
I tried to remove all kext that I copied to it.( to make similar with before I copy)
Now, after boot, go to login screen, I cannot use my keyboard ( only USB mouse)
Do you have any suggestions for me?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I have a trouble after copy all kext to /L/E then rebuild kext
my analog speaker not work
I think cause is rebuild kext in /L/E
I tried to remove all kext that I copied to it.( to make similar with before I copy)
Now, after boot, go to login screen, I cannot use my keyboard ( only USB mouse)
Do you have any suggestions for me?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Nov 21, 2017
Messages
88
Motherboard
thinkpad t540p
CPU
i5-4300M
Graphics
Intel HD 4600
Mobile Phone
Android, iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I ask you because I can not login without keyboard.
Use a USB keyboard if needed to collect problem reporting files.

I also want to ask how to remove built kext ( those kexts were built by rebuild command ) ( in folder /L/E)
No idea what you mean by "built by rebuild command".
 
Joined
Nov 21, 2017
Messages
88
Motherboard
thinkpad t540p
CPU
i5-4300M
Graphics
Intel HD 4600
Mobile Phone
Android, iOS
Use a USB keyboard if needed to collect problem reporting files.



No idea what you mean by "built by rebuild command".
I mean how to undo this step:
Code:
sudo cp -r /EFI/EFI/CLOVER/kexts/Other/*.kext /System/Library/Extensions
sudo touch /System/Library/Extensions && sudo kextcache -u /
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I mean how to undo this step:
Code:
sudo cp -r /EFI/EFI/CLOVER/kexts/Other/*.kext /System/Library/Extensions
sudo touch /System/Library/Extensions && sudo kextcache -u /
You would need to delete all the kexts you copied to /S/L/E.
Then rebuild cache again.

Note: Kexts should be installed to /L/E, not /S/L/E.
 
Top