Contribute
Register

HELP! Restart doesnt work on Haswell with Opencore

Joined
Dec 8, 2020
Messages
22
Motherboard
Asus G771JW(OC)
CPU
i7-4720HQ / HM87
Graphics
Intel HD4600, 1080p
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello there,

my laptop doesnt wanna Restart beside that Shutdown and Sleep(is working but after i turn on my laptop, its freeze after OpenCore boot) are working so when i wanna restart it its just close everything, display goes off and its staying in that state.

I wanna mention that i didnt had this problem on Clover and since Clover doesnt work on latest BigSur im using OpenCore.
Also on BigSur beta5 i used Clover and everithing worked perfectly, so i gues that must be a quirk that was on Clover and i'm missing it on OpenCore.

Quick Specs: Haswell i7 4720HQ, 16GB RAM, intelHD4600.

If someone can please help me find a solution.

Thank you.
 

Attachments

  • Send me CoLnEs-MacBook-Pro.zip
    6.1 MB · Views: 28
Joined
Nov 25, 2010
Messages
41
Motherboard
Asus G771JM-DH71-CA
CPU
i7-4710HQ
Graphics
GTX 860M - HD4600
I'm having the same issue -- did you ever manage to resolve it?
 
Joined
Dec 8, 2020
Messages
22
Motherboard
Asus G771JW(OC)
CPU
i7-4720HQ / HM87
Graphics
Intel HD4600, 1080p
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I'm having the same issue -- did you ever manage to resolve it?
Yes. I’ m using the latest Clover and everything is working perfectly even on macOS Monterey
 
Joined
Nov 25, 2010
Messages
41
Motherboard
Asus G771JM-DH71-CA
CPU
i7-4710HQ
Graphics
GTX 860M - HD4600
Yes. I’ m using the latest Clover and everything is working perfectly even on macOS Monterey
I too have no restart issues when using Clover, however, since upgrading to Big Sur, the backlight/brightness slider is gone and screen brightness keys no longer work with Clover, but they do with OpenCore -- but, as described in original subject/thread, restart does NOT work with OpenCore, regardless of what I've tried.

I'd like to try to make a permanent switch to OpenCore since it's pretty much the standard bootloader of choice now for most hackintosh developers, but if reboot doesn't work, I'd prefer to stick with Clover (and deal with brightness controls not working instead!). We only got a couple years left to be able to hackintosh as it is, so making the switch isn't a huge concern in the long run.

I've now upgraded this machine to Monterey and using Clover, but still have issues with no brigntess controls appearing in display preferences or the keyboard brightness keys working, regardless of what I try to enable it (Intel HD4600); I *did*, however, come across improved properties for the Intel HD4600, which fixed an issue when using Clover and CSM/High Resolution on boot which caused kernel panic/reboot when external display connected, and fixed VRAM to use all 2048 MB of memory that the video card is capable of (instead of only 1536 MB).
 
Last edited:
Top