Contribute
Register

[Help] Razer Blade 15 2019 No Trackpad or GFX Acceleration

Status
Not open for further replies.
Joined
Feb 29, 2020
Messages
9
Motherboard
STOCK Blade 15 Advanced 2019
CPU
i7-9750H
Graphics
RTX 2070 Max-Q & Intel UHD 630
Mac
  1. MacBook Pro
So, after a while of trial and error I am now getting stuck at the Verbose script screen rather than loosing graphics output like before.

I have followed the advice from previous post and also got a config.plist suited to my Intel UHD630 graphics but am not sure what the problem is.

I suspect it might still be improper smbios configuration but have included a photo of the stuck Verbose screen as well as my current clover folder.

Any further information would be greatly apreciated!
 

Attachments

  • CLOVER 5:3:20.zip
    3.9 MB · Views: 41
  • Verbose.jpg
    Verbose.jpg
    2.6 MB · Views: 56
Joined
Mar 13, 2020
Messages
3
Motherboard
Razer Blade 15 Advanced (Mid 2019)
CPU
Intel i7-9750H
Graphics
NVIDIA GeForce RTX 2070 Max-Q & Intel UHD 630
Did you end up finding a solution to this issue? I have the same laptop and was able to boot into my macOS installation, however, I'm unable to get my graphic acceleration working.
 
Joined
Feb 29, 2020
Messages
9
Motherboard
STOCK Blade 15 Advanced 2019
CPU
i7-9750H
Graphics
RTX 2070 Max-Q & Intel UHD 630
Mac
  1. MacBook Pro
Did you end up finding a solution to this issue? I have the same laptop and was able to boot into my macOS installation, however, I'm unable to get my graphic acceleration working.

I managed to get the laptop to install Mojave eventually, I believe by removing fakeSMC and the fake sensor kexts in my old clover folder. For what its worth though I'm using the Intel IGPU (nv_disable=1 boot flag) as the Nvidia DGPU is unsupported. Currently I have black lines around every window (Voice Over is disabled) and am struggling with the dsdt patching (so sound, battery percentage and track pad are non functional) so its not currently 100% but is semi functional. For reference, this is the guide I'm following: https://github.com/stonevil/Razer_Blade_Advanced_early_2019_Hackintosh hope this helps.
 
Joined
Feb 29, 2020
Messages
9
Motherboard
STOCK Blade 15 Advanced 2019
CPU
i7-9750H
Graphics
RTX 2070 Max-Q & Intel UHD 630
Mac
  1. MacBook Pro
Did you end up finding a solution to this issue? I have the same laptop and was able to boot into my macOS installation, however, I'm unable to get my graphic acceleration working.

After trying to fix the remaining issues on my blade I can confirm that everything appears to be working besides the trackpad and the graphics acceleration. (reported as Intel UHD Graphics 630 7 MB in About This Mac). Did you have any further luck with this at all?

Equally, if anyone is able to shed light on the issues here it would be greatly appreciated.
 

Attachments

  • :L:E - Extensions.png
    :L:E - Extensions.png
    34.6 KB · Views: 34
  • CLOVER 14-4-20.zip
    6.2 MB · Views: 51
Joined
Mar 28, 2020
Messages
2
Motherboard
Razer Blade 15 Mid 2019 - Base
CPU
i7-9750H, Chipset: HM370
Graphics
Intel UHD Graphics 630, 1920x1080
Mac
  1. MacBook Pro
Joined
Oct 19, 2017
Messages
15
Motherboard
Razer Blade 15 Advanced
CPU
i7-8750H
Graphics
GTX 2080, UHD 630
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. PowerBook
Mobile Phone
  1. iOS
Go through this guide. There are some great pieces of info in their for the Rb 15". I have a fully function Hack using this guide. I'm currently in the process of moving to Open Core. There is great info on how to get the Track pad and other components working. I upgrade the NVME and Wifi card. As those gave me issues. The newer system may use a NVME driver that works and also there has been progress on getting Intel WIfi working. Let me know if you still need help after going trough the guide, it's extremely useful.
 
Status
Not open for further replies.
Top