Contribute
Register

Help on how to enable all 4 speakers of my hp envy 15t-j100 on big sur?

Joined
Oct 29, 2016
Messages
66
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
Hi everyone!
I have HP Envy 15t-J100 and a working mac os big sur with clover bootloader but I want to enable all the 4 speakers plus 2 subwoofers so how can i do that? However only front 2 speakers are working.
Thank you
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,021
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi everyone!
I have HP Envy 15t-J100 and a working mac os big sur with clover bootloader but I want to enable all the 4 speakers plus 2 subwoofers so how can i do that? However only front 2 speakers are working.
Thank you
little guide here that may help:
 
Joined
Oct 29, 2016
Messages
66
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
Joined
Oct 29, 2016
Messages
66
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
unless someone has already done the hard work for you:
then probably not
I checked it with different layout ids and on 2 layout ids the front speakers sounded and on 2 other layout ids the rear speakers sounded so is it possible to add two layout ids so i can hear through all 4 speakers?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,021
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I checked it with different layout ids and on 2 layout ids the front speakers sounded and on 2 other layout ids the rear speakers sounded so is it possible to add two layout ids so i can hear through all 4 speakers?
only way would be the guide I linked above
 
Joined
Oct 29, 2016
Messages
66
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
only way would be the guide I linked above
Okay, I found an another solution that would enable all 4 speakers plus subwoofer by IDT92HD91BXXInject.kext but with this no sound even.
Can you help me regarding this?
 

Attachments

  • OC.zip
    7.3 MB · Views: 3

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,021
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Okay, I found an another solution that would enable all 4 speakers plus subwoofer by IDT92HD91BXXInject.kext but with this no sound even.
Can you help me regarding this?
not really, patching AppleHDA seems like a very old way of getting audio to work:

Code:
<key>Patch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (1 of 4)</string>
                <key>Find</key>
                <data>
                PYsZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PeB2HRE=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (2 of 4)</string>
                <key>Find</key>
                <data>
                PYQZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (3 of 4)</string>
                <key>Find</key>
                <data>
                PYMZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (4 of 4)</string>
                <key>Find</key>
                <data>
                PYoZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA anti-pop patch (AppleALC)</string>
                <key>Find</key>
                <data>
                QcYGAEiLu2g=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                QcYGAUiLu2g=
                </data>
            </dict>

also is this the correct layout ID for your audio:
0C000000 ?

also what is your audio codec?

on another note, you need to remove USBports.kext and replace with USBInjectAll.kext (you are already using your aml file for your USB ports but need USBInjectAll.kext to activate those) also you need to disable XhciPortLimit in your config.plist
 
Joined
Oct 29, 2016
Messages
66
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
not really, patching AppleHDA seems like a very old way of getting audio to work:

Code:
<key>Patch</key>
        <array>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (1 of 4)</string>
                <key>Find</key>
                <data>
                PYsZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PeB2HRE=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (2 of 4)</string>
                <key>Find</key>
                <data>
                PYQZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (3 of 4)</string>
                <key>Find</key>
                <data>
                PYMZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA IDT 76e0 (4 of 4)</string>
                <key>Find</key>
                <data>
                PYoZ1BE=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                PQAAAAA=
                </data>
            </dict>
            <dict>
                <key>Comment</key>
                <string>AppleHDA anti-pop patch (AppleALC)</string>
                <key>Find</key>
                <data>
                QcYGAEiLu2g=
                </data>
                <key>Identifier</key>
                <string>AppleHDA</string>
                <key>Replace</key>
                <data>
                QcYGAUiLu2g=
                </data>
            </dict>

also is this the correct layout ID for your audio:
0C000000 ?

also what is your audio codec?

on another note, you need to remove USBports.kext and replace with USBInjectAll.kext (you are already using your aml file for your USB ports but need USBInjectAll.kext to activate those) also you need to disable XhciPortLimit in your config.plist
I thought patching AppleHDA would make the all speakers and subwoofer to work and my layout id is correct which is 12 that works with AppleALC.kext. As per your instructions i replaced USBMap.kext/USBPorts.kext with USBInjectAll.kext and disabled XhciPortLimit in config.plist but still no luck even with different layout ids that works with AppleALC.kext.
With audio codec if you mean this then it is my dev and ven id...
111d76e0
8c208086
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,021
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I thought patching AppleHDA would make the all speakers and subwoofer to work and my layout id is correct which is 12 that works with AppleALC.kext. As per your instructions i replaced USBMap.kext/USBPorts.kext with USBInjectAll.kext and disabled XhciPortLimit in config.plist but still no luck even with different layout ids that works with AppleALC.kext.
With audio codec if you mean this then it is my dev and ven id...
111d76e0
8c208086
what did you use to patch AppleHDA? as AppleALC will only work on a clean AppleHDA
 
Top