Contribute
Register

Help: No audio after restarting from MultiBeast 5.0.2 installation

Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
I don't have dsdt :(
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
I don't have dsdt :(
You mentioned a dsdt in post #35. If you have the enabler, install that. Otherwise backup the native AppleHDA.kext. Run MultiBeast/Without dsdt/ALC892. Install the native AppeHDA.kext with KextBeast. Run the two tests and reply with IORegs.
 
Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
You mentioned a dsdt in post #35. If you have the enabler, install that. Otherwise backup the native AppleHDA.kext. Run MultiBeast/Without dsdt/ALC892. Install the native AppeHDA.kext with KextBeast. Run the two tests and reply with IORegs.

That was the DSDT extracted before the latest fresh install, I suppose we are not using that since it was broken?

Sorry, what enabler are you referring to?
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
That was the DSDT extracted before the latest fresh install, I suppose we are not using that since it was broken?

Sorry, what enabler are you referring to?
Why is the dsdt broken? Attach what you have. The Without DSDT enabler; HDAEnabler892.kext. It sits in S/L/E. If you don't have it, install with MultiBeast as mentioned earlier.
 
Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Why is the dsdt broken? Attach what you have. The Without DSDT enabler; HDAEnabler892.kext. It sits in S/L/E. If you don't have it, install with MultiBeast as mentioned earlier.

Sorry for my confusion as I don't really understand what DSDT does exactly and you told me to do a fresh install due to some conflict in the system, so I thought all this (including the extracted DSDT) are related. Please ignore what I said if they are irrelevant.

Here's what I did:
1. backup the native AppleHDA.kext
2. install audio driver from MultiBeast (/without DSDT/ALC892), which will install HDAEnabler892.kext
3. replace installed AppleHDA.kext with the native one via KextBeast

Attached with IORegs
 

Attachments

  • IORegs.zip
    1.1 MB · Views: 44

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Sorry for my confusion as I don't really understand what DSDT does exactly and you told me to do a fresh install due to some conflict in the system, so I thought all this (including the extracted DSDT) are related. Please ignore what I said if they are irrelevant.

Attached with IORegs
Thanks, UKCNo; AppleHDA.kext loads properly, UKCYes; AppleHDA.kext does not load. Install the 892 edited AppleHDA.kext. Run the two tests. You should see audio with UKCNo. Attach your dsdt and the IORegs.
 
Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Thanks, UKCNo; AppleHDA.kext loads properly, UKCYes; AppleHDA.kext does not load. Install the 892 edited AppleHDA.kext. Run the two tests. You should see audio with UKCNo. Attach your dsdt and the IORegs.

Attached with IORegs and extracted DSDT, audio working with UKC=No as usual. Cheers
 

Attachments

  • IORegs n DSDT extract.zip
    1.2 MB · Views: 47

toleda

Moderator
Joined
May 20, 2010
Messages
24,258
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Result as expected. At this point, the only working solution is UKC=No. If you are interested, the next set of experiments involve the dsdt. See ML: Optimized Realtek AppleHDA - Preview/Alpha. You would have to edit your dsdt as described. Questions?

Does UKC=Yes really speeds up the booting time? Or there will be more tweaks to do to get the final result? I can only see a tiny improvement in my system so I can live with UKC=No with audio for now.

I will then take my time to understand optimising AppleHDA, might need hand-holding guide from you again. Thanks a lot for your time, toleda. Really appreciate it and you made huge contribution to tonymacx86 community!
 
Joined
Jun 20, 2012
Messages
69
Motherboard
Zotac H77-ITX WiFi
CPU
i5 3550
Graphics
MSI R6670 GDDR5
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
  2. iOS
Hi Toleda, here's what I did with Alpha HDA

EDIT:
Did a clean install and followed these steps:
1. Edit and install HDEF/DSDT (realised I was missing method DTGP and added that to the DefinitionBlock, no more errors)
2. Ran MultiBeast, installing only EasyBeast
3. Backup and deleted native AppleHDA from S/L/E
4. Move alpha AppleHDA and HDAEnabler1 to desktop, ran KextBeast

Audio ID does show up as 1 in System Information but no other audio information and no audio
 

Attachments

  • Archive.zip
    585.1 KB · Views: 46
Top