Contribute
Register

Help needed Shilohh - Rampage IV Gene + 4930k

Joined
May 30, 2011
Messages
72
Motherboard
ASUS ROG Strix Z390-i Gaming
CPU
i9 9900KF
Graphics
5700XT
Mac
MacBook Air, Mac Pro
Mobile Phone
Android, iOS
I'm guessing Shilohh could probably help me the most but I would really appreciate some help from anyone on the forum.

It's been a while since I dealt with Hackintoshes and I had many good builds so I'm familiar with everything however I'm having troubles so I'm not sure what I"m missing and what the current state of things is.

For reference this is the config:

- ASUS Rampage Gene IV x79
- 4930k
- Nvidia GTX 780
- SupremeFX III audio (not sure what realtek chip is in there)
- AMI Bios

I saw your guide Shilohh about Rampage IV Black/Extreme and I followed it in creating the boot disk and everything with your files but I'm unable to get to the OSX Installer.

I've used Unibeast with Sierra option first, I was getting Still waiting for Root device.. so I switched to your Clover boot USB config and it's kernel panicking now on me.

Any new considerations and issues to consider. Is it even possible to install on this config. It's been a while so some guidance is definitely appreciated.

Thanks.
 
Last edited:
Joined
May 30, 2011
Messages
72
Motherboard
ASUS ROG Strix Z390-i Gaming
CPU
i9 9900KF
Graphics
5700XT
Mac
MacBook Air, Mac Pro
Mobile Phone
Android, iOS
Another note I'm not getting kernel panic when I add cpus=1 option to your boot config options but I get Still waiting for root device again there too.

I'm stumped, can't get to the installer screen no matter what.

I only have 2 SSD drives connected to USB 6g ports the onboard one not the external controller ones and nothing else plugged in.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,593
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I get Still waiting for root device
"Still waiting for root device".
When installing this means that your USB flash drive cannot be found.
This is usually because the flash drive is in a USB3 port.
If this is the case move it to a USB2 port, if it is already in a USB2 port move it to another and try again.
Repeat until you have tried all USB ports.
If it still doesn't work you could try another flash drive.
You might also try enabling Legacy on your USB3 ports in your BIOS settings.
 
Joined
May 30, 2011
Messages
72
Motherboard
ASUS ROG Strix Z390-i Gaming
CPU
i9 9900KF
Graphics
5700XT
Mac
MacBook Air, Mac Pro
Mobile Phone
Android, iOS
"Still waiting for root device".
When installing this means that your USB flash drive cannot be found.
This is usually because the flash drive is in a USB3 port.
If this is the case move it to a USB2 port, if it is already in a USB2 port move it to another and try again.
Repeat until you have tried all USB ports.
If it still doesn't work you could try another flash drive.
You might also try enabling Legacy on your USB3 ports in your BIOS settings.
I have tried 3 different USB sticks (a USB 2.0 one and the other 2 are USB 3.0 sticks).

I have tried every port including the USB 2.0 and USB 3.0 ports with always the same results.

I can see all kexts being loaded, it doesn't really crash and I'm not getting kernel panic, up until the moment when it loads almost everything from kexts and initial boot, and then gets stuck on "stick waiting for the root device" and screen will garble up sometimes.

So you are saying it's definitely USB? Should I just maybe try to install everything directly on SSD drive and try that way?
 
Top