Contribute
Register

Help needed: reboot after "Attempting system restart"

Status
Not open for further replies.
Joined
Jan 14, 2018
Messages
20
Motherboard
ASUS STRIX Z270G GAMING
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi

Trying to Install High Sierra on my first build:

Asus Z270G
i7-7700k
Samsung 960 Evo NVMe M.2 500GB SSD
Gigabyte GeForce GTX 1070 G1 Gaming
Dell 24" 4k monitor

My config is very similar to the Buyer's Guide, except the NVMe.

I pass the installer (but only with the DP cable connected to the GeForce, not to the integrated graphic card. Why?).
I see the NVMe and I am able to install the OS.
Then I boot from the NVMe, but I cannot pass the first "Attempting system restart". It just reboots... (I disconnected the graphic card, connected the DP to the integrated graphic card, but the same happens).

Here a screenshot of what happens (had to take a video bc it is too fast).

The USB is created with UniBeast. I made no changes.

Thanks for any help you can provide
 

Attachments

  • Screenshot_20180123-194434.jpg
    Screenshot_20180123-194434.jpg
    695.8 KB · Views: 551
Joined
Jan 14, 2018
Messages
20
Motherboard
ASUS STRIX Z270G GAMING
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi again

I am really stuck here. Tried all possible booting options and config.plist but I cannot pass this step. There must be something fundamentally wrong in my setup... I have seen from other people's screenshots that the next line after this "corecrypto" should be my computer configuration (CPU, RAM, etc.). Somehow this creates the problem, I believe. I have read that some people solved the same issue by changing the SMBIOS, but mine already says iMac18,3 which should be correct (i7-7700k).

Can someone help me here? I am running out of options...

Thanks!!!
 
Joined
Jan 14, 2018
Messages
20
Motherboard
ASUS STRIX Z270G GAMING
CPU
i7-7700K
Graphics
GTX 1070
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
I gave up and tried following this tutorial on how to install Sierra. First time did not work (no entry sign), then I changed the SMBIOS from iMac17,1 to iMac18,3 and it worked! No issues at all. Sierra installed. First Hackintosh up and running! :)))

Not happy, I gave High Sierra a second chance. I went through the installer as usual, but on the first reboot, I removed the High Sierra USB and booted with the Sierra USB which worked fine with the Sierra installation... but... but again the System reboots right after the "@kec.corecrypto 1.0" exactly as above :(

Why is that????

Thanks
 
Joined
Sep 13, 2015
Messages
51
Motherboard
Asus ROG Z270G
CPU
Intel Core i7-7700K
Graphics
Sapphire RX 580 Nitro+
Mac
  1. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
@Corma77

I NEVER used UniBeast :thumbdown

Since couple of years of my hackintoshing I ALWAYS made and will ALWAYS do the VANILLA Installation.
Only on this way (imho) the Hackintosh will work problem less as a real Mackintosh.
All Apple services iCloud, iMessage, FaceTime, iTunes work properly :thumbup:

U need:

1. USB bootable stick. The best solution is to use one USB 2.0 stick.
1a. erase Yo stick as a GUID and name it USB. Than run following terminal command:

sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction

When the usb stick is ready:

2. Open Clover bootloader, choose Yo stick and install:
2a. for UEFI mainboards
2b. EmuVariableUefi-64
2c. OsxAptioFix2Drv-64

3. Place the following kexts in folder "Other"
3a. FakeSMC.kext
3b. USBInjectAll.kext
3c. XHCI-200-series-injector.kext
3d. IntelMausiEthernet.kext
3e. AppleALC.kext
3f. Lilu.kext
3g. FakePCIID_Intel_HD_Graphics.kext
3h. IntelGraphicsFixup.kext

4. Of course U need a properly config.plist

5. Install with IGPU. First after success installation of macOS U can install Nvidia WebDriver and Yo grafic card.
For install with IGPU U need:

Clover:Devices.png


Clover:Graphics.png


6. BIOS - search on google for the properly settings for Yo mainboard

Get in touch
 
Status
Not open for further replies.
Top