Contribute
Register

HELP NEEDED!!! - Internal Graphic disabled

Joined
Nov 12, 2014
Messages
8
Motherboard
GA-Z87X-UD5H - Bios v._F8 ID_8A02AG08
CPU
i7-4770K
Graphics
NO EXTERNAL GPU
Mac
iMac
Classic Mac
Mobile Phone
Hello everyone,
I was trying to install mavericks on my first build - a GIGABYTE Z87X-UD5H mothboard +i7 4770K. I followed one of the success reports about this config, that as Bios settings suggests to set Internal Graphics to DISABLED http://www.tonymacx86.com/user-buil...i7-4770k-gtx-660-mavericks-windows-8-1-a.html

I did, but the monitor was totally black.... Since there is no additional GPU on my build, I deduced that the Internal Graphics must be ON to see anything on the monitor, so I proceded to reset Bios to factory defaults: there is a specific pushbutton on the motherboard, but no result; I tried also removing battery for more than one minute, but still no result.

Anyone can help?
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
MacBook Pro
Mobile Phone
iOS, Other
Hello everyone,
I was trying to install mavericks on my first build - a GIGABYTE Z87X-UD5H mothboard +i7 4770K. I followed one of the success reports about this config, that as Bios settings suggests to set Internal Graphics to DISABLED http://www.tonymacx86.com/user-buil...i7-4770k-gtx-660-mavericks-windows-8-1-a.html

I did, but the monitor was totally black.... Since there is no additional GPU on my build, I deduced that the Internal Graphics must be ON to see anything on the monitor, so I proceded to reset Bios to factory defaults: there is a specific pushbutton on the motherboard, but no result; I tried also removing battery for more than one minute, but still no result.

Anyone can help?
Probably not the best guide to follow as the OP is using a discrete card and you have only have the option of integrated graphics. Some questions for you, where are you in the installation stage. As you have mentioned it is mandatory to set your BIOS to IGFX to boot from the Intel on board HD4600. Setting them to factory configuration will set it to PCIE, which is no help to you. Manually enter the BIOS and set it to Init Display First>IGFX. How have you got you system connected to the monitor? what cables? what monitor? Could you fill out your profile as per forum rules. This will help others assist you.
 
Joined
Nov 12, 2014
Messages
8
Motherboard
GA-Z87X-UD5H - Bios v._F8 ID_8A02AG08
CPU
i7-4770K
Graphics
NO EXTERNAL GPU
Mac
iMac
Classic Mac
Mobile Phone
thanks for reply.
profile filled out.
My problem is that now I can't set anything since my monitor remains totally black!!! The monitor is a DVI and is connected to the DVI-I port of the
GA-Z87X-UD5H motherboard. Just after having done the big mistake, that is to set to DISABLED the Internal Graphics on Bios, the video out has gone. Any attempt to reset Bios (button, jumper, removing battery...) gave no results. I've also tried to
temporarily
instal a borrowed external graphic card, but still no video out. I'm getting crazy trying to understand why the Bios reset has no effect on the Internal Graphic Processor.



 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
MacBook Pro
Mobile Phone
iOS, Other
This is very odd indeed. My suggestion would been what you've already tried and that is removing the battery and leave it unplugged for a minute. There is a master reset button on the motherboard, you have to press this with no power on, take a look in your manual. IIRC you should wait more than 5 minutes before adding power and switching it on.
 
Joined
Nov 12, 2014
Messages
8
Motherboard
GA-Z87X-UD5H - Bios v._F8 ID_8A02AG08
CPU
i7-4770K
Graphics
NO EXTERNAL GPU
Mac
iMac
Classic Mac
Mobile Phone
Yes, this issue is very very odd... I'm pretty sure I've done all possible to reset Bios, master reset button, Bios reset button, Bios reset jumper, including removing battery for half an hour....
I'll post any possible solution....
 
Joined
Nov 12, 2014
Messages
8
Motherboard
GA-Z87X-UD5H - Bios v._F8 ID_8A02AG08
CPU
i7-4770K
Graphics
NO EXTERNAL GPU
Mac
iMac
Classic Mac
Mobile Phone
Fixed!!! :) I've realized that the motherboard owns a Dual Bios, and a related switch onboard. So I switched to the backup bios and the video has come back. Just for information, the main Bios still remains blank, impossible to reset, and this is supposed to be anomaly or malfunctioning. Thanks again for support
 

wildwillow

Moderator
Joined
Jun 26, 2012
Messages
4,569
Motherboard
Z170 Deluxe
CPU
i5-6600K
Graphics
GTX 970
Mac
MacBook Pro
Mobile Phone
iOS, Other
Fixed!!! :) I've realized that the motherboard owns a Dual Bios, and a related switch onboard. So I switched to the backup bios and the video has come back. Just for information, the main Bios still remains blank, impossible to reset, and this is supposed to be anomaly or malfunctioning. Thanks again for support
Great news super16. Pleased that it is working for you. Wondering if you flash the BIOS it would repair the blank BIOS. Then again thats a risky choice. Thanks for reporting the solution.
 
Top