Contribute
Register

[HELP] My Switchable Graphics option in BIOS keeps resetting after reboot!

Joined
Mar 29, 2017
Messages
34
Motherboard
Dell Precision M4800 + Clover 4077
CPU
i7 4800MQ + Intel QM87 (Lynx Point) Chipset
Graphics
NVIDIA Quadro K2100M | Intel HD4600 1080p
Mobile Phone
  1. iOS
Maybe is BIOS issue. Do you have the latest?
Also, you could try without the RTC fix patch.
BIOS is latest version. A18. Also happened when I was on A04.

Well it still occured when I had no ACPI patches at all, so also no RTC fix.

Is there no other way to force enable Switchable Graphics on boot or at least force iGPU? Like - any other way to use iGPU even when Switchable Graphics is off?

I don't really want to enable Switchable Graphics every boot.. This can't be a permanent thing without any solutions..
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
BIOS is latest version. A18. Also happened when I was on A04.

Well it still occured when I had no ACPI patches at all, so also no RTC fix.

Is there no other way to force enable Switchable Graphics on boot or at least force iGPU? Like - any other way to use iGPU even when Switchable Graphics is off?

I don't really want to enable Switchable Graphics every boot.. This can't be a permanent thing without any solutions..

No further ideas for that issue. Perhaps you should search for existing threads for same/similar laptop and consult with others that also have the same laptop...
 
Joined
Mar 29, 2017
Messages
34
Motherboard
Dell Precision M4800 + Clover 4077
CPU
i7 4800MQ + Intel QM87 (Lynx Point) Chipset
Graphics
NVIDIA Quadro K2100M | Intel HD4600 1080p
Mobile Phone
  1. iOS
No further ideas for that issue. Perhaps you should search for existing threads for same/similar laptop and consult with others that also have the same laptop...
When you have any info on this, please post here or send me a message, the bug makes my hackintosh pretty unusable :/

Thank you very much for the guides & help!
 
Joined
Mar 29, 2017
Messages
34
Motherboard
Dell Precision M4800 + Clover 4077
CPU
i7 4800MQ + Intel QM87 (Lynx Point) Chipset
Graphics
NVIDIA Quadro K2100M | Intel HD4600 1080p
Mobile Phone
  1. iOS
No further ideas for that issue. Perhaps you should search for existing threads for same/similar laptop and consult with others that also have the same laptop...
This (attached image) is the System Log > Power Events in my BIOS, do they tell you anything? It says Battery removed...??

(I've entered BIOS, cleared the Logs, exited BIOS and booted into MacOS, then I clicked Shutdown in MacOS, booted again (once it fails to boot like I described in my original post), entered BIOS and this is what it says now.)
 

Attachments

  • image.jpeg
    image.jpeg
    4 MB · Views: 208

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
This (attached image) is the System Log > Power Events in my BIOS, do they tell you anything? It says Battery removed...??

(I've entered BIOS, cleared the Logs, exited BIOS and booted into MacOS, then I clicked Shutdown in MacOS, booted again (once it fails to boot like I described in my original post), entered BIOS and this is what it says now.)

No other ideas since post #52.
 
Joined
May 1, 2019
Messages
53
This (attached image) is the System Log > Power Events in my BIOS, do they tell you anything? It says Battery removed...??

(I've entered BIOS, cleared the Logs, exited BIOS and booted into MacOS, then I clicked Shutdown in MacOS, booted again (once it fails to boot like I described in my original post), entered BIOS and this is what it says now.)

Did you solve it ?
If not I have a solution for your issue ;
Share your EFI and I will upload it with fix

Here's the Fix for your issue

https://www.tonymacx86.com/threads/...cision-m6800-workstation.262199/#post-1862990
 
Last edited by a moderator:
Top