Contribute
Register

[help] macOS won't boot (turns into blackscreen)

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,825
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT 1030
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
I use my own EFI and the system is working fine if I boot in VESA graphics mode. I just took the video patch from your EFI and tested them out.



Yeah I just tested the video patch there. My EFI is cleaner than that.

I just went ahead and tested all possible combinations:

All bus id to 0 except con0, set type to HDMI and then tested one by one busid from 1 to 6.
All bus id to 0 except con1, set type to HDMI and then tested one by one busid from 1 to 6.
All bus id to 0 except con2, set type to HDMI and then tested one by one busid from 1 to 6.

View attachment 525154

Never got it to work....... I guess you are right.. Comet Lake UHD 630 will not work in a 500 series board

True, sadly. What's more I checked all connector values too.
 
Joined
May 22, 2011
Messages
401
Motherboard
Lenovo m90q Tiny
CPU
i7-10700
Graphics
UHD 630
Mac
  1. MacBook Pro
True, sadly. What's more I checked all connector values too.

If I was able to get a Gigabyte 5600 XT Windforce 6GB, would I be good to go or I am supposed to stick with 5500 or 5700 only (which are unavailable near me)?
 

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
6,825
Motherboard
Gigabyte Z490i Aorus Ultra - OC 0.6.8
CPU
i5-10600K
Graphics
GT 1030
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. eMac
  2. iBook
Mobile Phone
  1. Android
If I was able to get a Gigabyte 5600 XT Windforce 6GB, would I be good to go or I am supposed to stick with 5500 or 5700 only (which are unavailable near me)?

A quick Site Search shows results are about 50 / 50.

I haven't tried one myself so I would advise you read-up on any possible problems. These GPUs are still a lot of money.
 
Joined
May 11, 2011
Messages
1,978
Motherboard
Gigabyte B550 Vision D
CPU
Ryzen 5900X
Graphics
RX 6800
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac mini
  6. Mac Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. iOS
I use my own EFI and the system is working fine if I boot in VESA graphics mode. I just took the video patch from your EFI and tested them out.

Yeah I just tested the video patch there. My EFI is cleaner than that.

I just went ahead and tested all possible combinations:

All bus id to 0 except con0, set type to HDMI and then tested one by one busid from 1 to 6.
All bus id to 0 except con1, set type to HDMI and then tested one by one busid from 1 to 6.
All bus id to 0 except con2, set type to HDMI and then tested one by one busid from 1 to 6.

View attachment 525154
Never got it to work....... I guess you are right.. Comet Lake UHD 630 will not work in a 500 series board
Have you had a look at Ohchang’s Z590 Comet Lake build? > https://www.tonymacx86.com/threads/ohchangs-build-gigabyte-z590-vision-g-i7-10700k-amd-rx580.310986/
 
Top