Contribute
Register

[Help] HP Pavilion 15 2018 BIOS settings

Status
Not open for further replies.
Joined
Jan 7, 2018
Messages
8
Motherboard
HP 841C (HP Pavilion 15-ck013nl) (Clover)
CPU
Intel Core i5 8250U
Graphics
nVidia 940MX, Intel UHD Graphics 620 1920x1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi everyone!
Today I got High Sierra to install and boot on the new HP Pavilion 15 with a i5-8250U and nVidia MX940. Problem is, the system boots only in safe mode -x. If I try and boot with only verbose on I get stuck on gIOscreenlockstate 3 error.

I already knew from previous hackintoshing experiences that I needed to disable Serial Port IO among the usual stuff like virtualization from the BIOS but this laptop doesn't have any Serial Port settings ANYWHERE in it's already gaunty BIOS (spent a lot of time looking for it but there not a lot of options changable in this BIOS). I'm pretty much sure this is the problem keeping my laptop to boot in normal mode.

Anyone know a way around it?
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi everyone!
Today I got High Sierra to install and boot on the new HP Pavilion 15 with a i5-8250U and nVidia MX940. Problem is, the system boots only in safe mode -x. If I try and boot with only verbose on I get stuck on gIOscreenlockstate 3 error.

I already knew from previous hackintoshing experiences that I needed to disable Serial Port IO among the usual stuff like virtualization from the BIOS but this laptop doesn't have any Serial Port settings ANYWHERE in it's already gaunty BIOS (spent a lot of time looking for it but there not a lot of options changable in this BIOS). I'm pretty much sure this is the problem keeping my laptop to boot in normal mode.

Anyone know a way around it?

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Joined
Jan 7, 2018
Messages
8
Motherboard
HP 841C (HP Pavilion 15-ck013nl) (Clover)
CPU
Intel Core i5 8250U
Graphics
nVidia 940MX, Intel UHD Graphics 620 1920x1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"

Hi Rehabman, thank you very much for your service in the hackintoshing scene! I just updated my system info, sorry for that.

I did follow your guide since I started hackintoshing at the beginning of 2018 to set up the USB bootable with Clover UEFI and everything and in fact it did work, I can get to the installation process with no problems whatsoever. The only options in the BIOS I could change really were secure boot (disabled), virtualization (disabled) and boot from usb (enable). I couldn't disable Serial Port support and set the graphics to iGPU. But the issues come after the initial installation and first reboot: the second stage of the installation can be completed only in safe mode and that's the same for any future boots of the system. Can't get the system to boot in normal mode otherwise I get the gIOscreenlockstate 3 error blinking on my monitor at intervals of 7-10 seconds.

I'm sorry I can't attach all the needed files for problem reporting but I can't run the tool on the laptop as I still can't get any Internet connection on it at all (I'm running an Intel wi-fi I will be swapping for a Broadcom if I can get at least the boot process fixed). I can't get any report from verbose as well because the boot ends in a black screen with the gIOscreenlockstate 3 error blinking. I'm attaching my Clover EFI folder! The config.plist is still pretty much stock tho...
 

Attachments

  • CLOVER.zip
    2 MB · Views: 129

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,935
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi Rehabman, thank you very much for your service in the hackintoshing scene! I just updated my system info, sorry for that.

I did follow your guide since I started hackintoshing at the beginning of 2018 to set up the USB bootable with Clover UEFI and everything and in fact it did work, I can get to the installation process with no problems whatsoever. The only options in the BIOS I could change really were secure boot (disabled), virtualization (disabled) and boot from usb (enable). I couldn't disable Serial Port support and set the graphics to iGPU. But the issues come after the initial installation and first reboot: the second stage of the installation can be completed only in safe mode and that's the same for any future boots of the system. Can't get the system to boot in normal mode otherwise I get the gIOscreenlockstate 3 error blinking on my monitor at intervals of 7-10 seconds.

I'm sorry I can't attach all the needed files for problem reporting but I can't run the tool on the laptop as I still can't get any Internet connection on it at all (I'm running an Intel wi-fi I will be swapping for a Broadcom if I can get at least the boot process fixed). I can't get any report from verbose as well because the boot ends in a black screen with the gIOscreenlockstate 3 error blinking. I'm attaching my Clover EFI folder! The config.plist is still pretty much stock tho...
config.plist is not per guide

OsxAptioFix3Drv-64 is not recommended try AptioMemoryFix

you may want to remove NvidiaGraphicsFixup.kext
 
Joined
Jan 7, 2018
Messages
8
Motherboard
HP 841C (HP Pavilion 15-ck013nl) (Clover)
CPU
Intel Core i5 8250U
Graphics
nVidia 940MX, Intel UHD Graphics 620 1920x1080
Mac
  1. iMac
Mobile Phone
  1. iOS
OsxAptioFix3Drv-64 is not recommended try AptioMemoryFix

Aight sir, going to try that in a minute. Is there any particular reason to prefer Aptio over Osx? Excuse the potentially dumb question!
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,935
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Aight sir, going to try that in a minute. Is there any particular reason to prefer Aptio over Osx? Excuse the potentially dumb question!
Aptiomemoryfix is newer and better, if it works on your system then best to use, i think you only use OsxAptioFix3Drv if aptio doesn't work
 
Joined
Jan 7, 2018
Messages
8
Motherboard
HP 841C (HP Pavilion 15-ck013nl) (Clover)
CPU
Intel Core i5 8250U
Graphics
nVidia 940MX, Intel UHD Graphics 620 1920x1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Aptiomemoryfix is newer and better, if it works on your system then best to use, i think you only use OsxAptioFix3Drv if aptio doesn't work

I see, thanks for the info. I will remove nVidiafixup as well.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,935
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I see, thanks for the info. I will remove nVidiafixup as well.
yes, as there is a chance it is optimus and you will end up disabling the nvidia after installation (battery saver as well)
 
Joined
Jan 7, 2018
Messages
8
Motherboard
HP 841C (HP Pavilion 15-ck013nl) (Clover)
CPU
Intel Core i5 8250U
Graphics
nVidia 940MX, Intel UHD Graphics 620 1920x1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I have a question, something I've never really understood.
When you boot from Clover on a USB (not on the HDD or SSD the system is installed on), does it inject the kexts from the USB drive? I mean, if you have to change kests or modify the config.plist does the system use the files from the USB drive or you have to change them necessarily from the system's EFI partition?

I'm asking this because as I can only boot in safe mode I can't mount EFI partitions.
 

RehabMan

Moderator
Joined
May 2, 2012
Messages
184,103
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have a question, something I've never really understood.
When you boot from Clover on a USB (not on the HDD or SSD the system is installed on), does it inject the kexts from the USB drive? I mean, if you have to change kests or modify the config.plist does the system use the files from the USB drive or you have to change them necessarily from the system's EFI partition?

I'm asking this because as I can only boot in safe mode I can't mount EFI partitions.

Your question regarding kext injection is answered in post #2 of the guide:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Status
Not open for further replies.
Top