Contribute
Register

[HELP] Fujitsu LifeBook AH531/GFO

Joined
Dec 6, 2018
Messages
1
Motherboard
HM65
CPU
i5-2410M
Graphics
HD 3000 + GT 525M
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi Tonys,

I successfully installed Clover 4741 on /EFI (JHFS+ - Root-Patition) by using "High Sierra MBR and Firmware Check Patch 10.13.x." because this Laptop is BIOS MBR only (no GPT!, so also no APFS Support for Boot-Drive :/).
Added these propeties to get a screen without adding a HDMI-Display and also working audio:
PciRoot(0)/Pci(0x1b,0)->hda-gfx0\-onboard-1 && layout-id: 3
PciRoot(0x0)/Pci(0x2,0x0):
AAPL,snb-platform-id, disable-external-gpu,framebuffer-conX-busid,framebuffer-conX-flags,framebuffer-conX-enable,framebuffer-conX-index,framebuffer-conX-pipe,framebuffer-conX-type,framebuffer-memorycount,framebuffer-mobile,framebuffer-patch-enable,framebuffer-pipecount,framebuffer-portcount,hda-gfx.

Boot: nv_disable=1 dart=0 kext-dev-mode=1 -igfxnohdmi darkwake=8 (tried all modes 0,1,2,3,4,8,10)

Dropped tableIDs: ssdt: CpuPm,Cpu0Cst,Cpu0Ist. And generated a new SSDT.aml with "ssdtPRGen.sh" by Piker-Alpha.

Grabbed ACPI with USB-Stick FAT32 Clover (F4) and disassambled it with iasl41. Also added some general patches mentioned by RehabMan to DSDT.aml: "Fix _WAK Arg0 v2", "HPET Fix", "SMBUS Fix", "IRQ Fix", "RTC Fix", "OS Check Fix", "Fix Mutex with non-zero SyncLevel", "Add IMEI".
Also I added his HP 4x30 Battery Patch and the AH512 Battery Patch to it, so the ACPIBattery-kext recognize whether a power cord is plugged in or not. If it's good?! I don't know.

Whats working:
- Display (Rec. ITU-R BT.709-5 - Color-Profile otherwise its too bright)
- Keyboard (PS/2)
- Touchpad (PS/2)
- All USB-Ports, int. Camera, CardReader.
- Wifi (Broadcom BCM9432) + BT
- LAN (Realtek 8111E)
- Audio incl. graphical Apple-Overlay
- HDMI + Audio
- Sleep/Wake by closing/opening the panel.
- Sata + Drive
- Battery + A/C
Neutral stuff:
- Screensaver have to be "force-quit" by CMD + left-mousekey + CMD ?!?
- FN+F6 (Display darker) & FN+F7 (Display brighter), no graphical feedback (Apple-Overlay)
Dont Know:
- VGA -> Not implemented in propeties-config and not tested.
Whats NOT working:
- Sleep -> It seems that one of the USB-Devices is stopping the device for staying in sleep mode. Sleep for 1sec.
- Laptop backlight control using AppleBacklightFixup.kext -> I got the Slider but if I unplug power nothing happens and the slider also have no effect.
- Intel HD 3000 (QE/CI) --> After a longer use I get some graphical glitches like black bars in webbrowser or green bars in videos. Quiet after the first glitches appeared the whole system hang up so that I have to turn it off and on.

Specs:
Intel Core i5-2410M
8GB Corsair RAM 1600MHz
Intel HD3000 + Nvidia GT 525M
PCH: 65HM
SATA: OCZ Vertex2 120GB + Optiarc BD RW BD-5750H
LAN: Realtek 8111E + Wifi Broadcom BCM94352HMB

Kexts:
/L/E:
ACPIBatteryManager.kext
AirportBrcmFixup.kext
AppleALC.kext
AppleBacklightFixup.kext
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext
Lilu.kext
WhateverGreen.kext
/E/C/K/Other:
AppleALC.kext
FakeSMC.kext
Lilu.kext
RealtekRTL8111.kext
USBPorts.kext
VoodooPS2Controller.kext
WhateverGreen.kext

I think I have to optimate the DSDT.aml but I'm very newbie. :/
I would be appreciate any help!

best regardz

realizelol
 

Attachments

  • EFI_CLOVER_ACPI.zip
    2.6 MB · Views: 321
Joined
Feb 23, 2011
Messages
6
Motherboard
Gigabyte P65a-UD3
CPU
i5
Graphics
9800 GT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. Android
  2. iOS
Could you be a little bit more specific on initial steps. Whatever I did nothing made it to boot into Clover successfully
 
Joined
Jan 15, 2020
Messages
7
Motherboard
MSI Z390-A PRO
CPU
i5 9600k
Graphics
XFX RX 590 8Gb
Gonna try this now on a friends Laptop... Yosemite was no problem, but it sucks so it would be super great if it works :)

even read somewhere that someone managed to install and run Catalina on this old p.o.s_it :)
 
Joined
Nov 30, 2019
Messages
2
Motherboard
fujitzu
CPU
intel
Graphics
intel
Hi Tonys,

I successfully installed Clover 4741 on /EFI (JHFS+ - Root-Patition) by using "High Sierra MBR and Firmware Check Patch 10.13.x." because this Laptop is BIOS MBR only (no GPT!, so also no APFS Support for Boot-Drive :/).
Added these propeties to get a screen without adding a HDMI-Display and also working audio:
PciRoot(0)/Pci(0x1b,0)->hda-gfx0\-onboard-1 && layout-id: 3
PciRoot(0x0)/Pci(0x2,0x0):
AAPL,snb-platform-id, disable-external-gpu,framebuffer-conX-busid,framebuffer-conX-flags,framebuffer-conX-enable,framebuffer-conX-index,framebuffer-conX-pipe,framebuffer-conX-type,framebuffer-memorycount,framebuffer-mobile,framebuffer-patch-enable,framebuffer-pipecount,framebuffer-portcount,hda-gfx.

Boot: nv_disable=1 dart=0 kext-dev-mode=1 -igfxnohdmi darkwake=8 (tried all modes 0,1,2,3,4,8,10)

Dropped tableIDs: ssdt: CpuPm,Cpu0Cst,Cpu0Ist. And generated a new SSDT.aml with "ssdtPRGen.sh" by Piker-Alpha.

Grabbed ACPI with USB-Stick FAT32 Clover (F4) and disassambled it with iasl41. Also added some general patches mentioned by RehabMan to DSDT.aml: "Fix _WAK Arg0 v2", "HPET Fix", "SMBUS Fix", "IRQ Fix", "RTC Fix", "OS Check Fix", "Fix Mutex with non-zero SyncLevel", "Add IMEI".
Also I added his HP 4x30 Battery Patch and the AH512 Battery Patch to it, so the ACPIBattery-kext recognize whether a power cord is plugged in or not. If it's good?! I don't know.

Whats working:
- Display (Rec. ITU-R BT.709-5 - Color-Profile otherwise its too bright)
- Keyboard (PS/2)
- Touchpad (PS/2)
- All USB-Ports, int. Camera, CardReader.
- Wifi (Broadcom BCM9432) + BT
- LAN (Realtek 8111E)
- Audio incl. graphical Apple-Overlay
- HDMI + Audio
- Sleep/Wake by closing/opening the panel.
- Sata + Drive
- Battery + A/C
Neutral stuff:
- Screensaver have to be "force-quit" by CMD + left-mousekey + CMD ?!?
- FN+F6 (Display darker) & FN+F7 (Display brighter), no graphical feedback (Apple-Overlay)
Dont Know:
- VGA -> Not implemented in propeties-config and not tested.
Whats NOT working:
- Sleep -> It seems that one of the USB-Devices is stopping the device for staying in sleep mode. Sleep for 1sec.
- Laptop backlight control using AppleBacklightFixup.kext -> I got the Slider but if I unplug power nothing happens and the slider also have no effect.
- Intel HD 3000 (QE/CI) --> After a longer use I get some graphical glitches like black bars in webbrowser or green bars in videos. Quiet after the first glitches appeared the whole system hang up so that I have to turn it off and on.

Specs:
Intel Core i5-2410M
8GB Corsair RAM 1600MHz
Intel HD3000 + Nvidia GT 525M
PCH: 65HM
SATA: OCZ Vertex2 120GB + Optiarc BD RW BD-5750H
LAN: Realtek 8111E + Wifi Broadcom BCM94352HMB

Kexts:
/L/E:
ACPIBatteryManager.kext
AirportBrcmFixup.kext
AppleALC.kext
AppleBacklightFixup.kext
BrcmFirmwareRepo.kext
BrcmPatchRAM2.kext
Lilu.kext
WhateverGreen.kext
/E/C/K/Other:
AppleALC.kext
FakeSMC.kext
Lilu.kext
RealtekRTL8111.kext
USBPorts.kext
VoodooPS2Controller.kext
WhateverGreen.kext

I think I have to optimate the DSDT.aml but I'm very newbie. :/
I would be appreciate any help!

best regardz

realizelol
I don't know what your saying. Can you make a tutorial please i need your help
 
Top