Contribute
Register

Help for Fix the sleep in my build

Joined
Aug 8, 2019
Messages
13
Motherboard
Gigabyte Z390i Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 5700 XT
Hi !

My build is 99% finish, the last thing still boring me is the sleep !

You can check my build thread if it's help :thumbup:

The issue :

Sleep cause instant wake. All screen stay in sleep but the computer wake.

What I try :

pmset -g assertions :
Assertion status system-wide:
BackgroundTask 1
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 0
PreventUserIdleSystemSleep 1
NetworkClientActive 0
InternalPreventSleep 1
Listed by owning process:
pid 137(WindowServer): [0x0000001e000981aa] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:100000f93 name:AppleHIDKeyboardEve product:Magic Keyboard eventType:3"
pid 80(powerd): [0x000003f7000d862b] 00:00:22 InternalPreventSleep named: "com.apple.powermanagement.acwakelinger"
Timeout will fire in 22 secs Action=TimeoutActionRelease
pid 398(sharingd): [0x000004010001863c] 00:00:12 PreventUserIdleSystemSleep named: "Handoff"
pid 354(UserEventAgent): [0x0000002d000b8330] 00:16:45 BackgroundTask named: "com.apple.coreduet.sync.update-source-device-identifiers"
Created for PID: 357.
Kernel Assertions: 0xc=USB,BT-HID
id=543 level=255 0x4=USB creat=03/01/2021 14:06 description=com.apple.usb.externaldevice.14900000 owner=ITE Device(8595)
id=544 level=255 0x4=USB creat=03/01/2021 14:09 description=com.apple.usb.externaldevice.14830000 owner=BRCM20702 Hub
id=546 level=255 0x8=BT-HID creat=03/01/2021 14:09 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleHSBluetoothDevice
id=547 level=255 0x8=BT-HID creat=03/01/2021 14:02 description=com.apple.driver.IOBluetoothHIDDriver owner=AppleHSBluetoothDevice
Idle sleep preventers: IODisplayWrangler


sudo pmset -g :
Currently in use:
standby 0
Sleep On Power Button 1
womp 0
autorestart 0
hibernatefile /var/vm/sleepimage
proximitywake 0
powernap 0
gpuswitch 2
networkoversleep 0
disksleep 10
standbydelayhigh 86400
sleep 0 (sleep prevented by apsd, sharingd)
hibernatemode 0
ttyskeepawake 1
displaysleep 0
tcpkeepalive 1
highstandbythreshold 50
standbydelaylow 86400


Capture d’écran 2021-01-03 à 14.28.52.png


I try to unplug all USB...
In my build I have a NZXT Kraken on external to Internal USB adaptor and the BCM94360CS2 on the true Internal USB. So I try to unplug the NZXT but same

Thanks for any help !

 
Joined
Aug 8, 2019
Messages
13
Motherboard
Gigabyte Z390i Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 5700 XT
Still unsolved
 
Joined
Aug 2, 2013
Messages
847
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Joined
Aug 8, 2019
Messages
13
Motherboard
Gigabyte Z390i Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 5700 XT
Thanks for the reply,

The first time I have done this build I have set the USB with the 15 ports limit. But this morning I find the problem. I use a little adapter shop on Amazon. An internal usb splitter, and it was this one who broke the sleep.

So for now my NZXT water cooling pump is on an adapter to external usb at the rear of the MB. Disable with usb map.
My Broadcom card is working, wifi and Bluetooth set on internal “255”

My build go to sleep but the original trackpad or keyboard doesn’t wake the computer. My Logitech mouse does. And after wake Bluetooth and wifi work.

So first problem fix, new problem
 
Joined
Aug 2, 2013
Messages
847
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Can you post a copy of your USBPorts.kext or SSDT for your USB configuration, just to check that it looks as expected.

Posting a screenshot of the Hackintool USB tab would also be helpful.

As an example I have attached a screenshot of the USB tab on my iMac 1 system, which also uses an Internal USB port splitter (HS07 & HS08) that connects a number of devices including the case USB2 card reader, USB2 case ports etc.

Screenshot 2021-01-17 at 20.57.33.png
 
Joined
Aug 2, 2013
Messages
847
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
Have you disabled the CNVi connector on the motherboard, this also has a USB port connection, which you should not be using. The use of the CNVi port can cause some issues in macOS.

I have attached an SSDT-No-CNVW.aml for you to use, see if adding this to your /OC/ACPI & config.plist or /CLOVER/ACPI/patched folder.

Check which USB port is connected to the CNVI connector, for the intel Bluetooth module that came with your motherboard. Ensure it is not among the 15 ports you have activated.
 

Attachments

  • SSDT-NO-CNVW.aml.zip
    715 bytes · Views: 3
Joined
Aug 8, 2019
Messages
13
Motherboard
Gigabyte Z390i Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 5700 XT
I have unplug the intel module, the CNVi port can cause issues even with noting plug in ?

The only port were I'm not sure is the ITE Device port, every else is identified.

I was so close to the "No issue Build" :lol:
 
Joined
Aug 2, 2013
Messages
847
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
HD 4600 / RX 580
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Mobile Phone
  1. iOS
As far as I know the CNVi port on Z390 boards needs to be disabled in macOS, so try adding the SSDT provided in post #7 to your system.

Yes, the ITE device port has me a bit confused too. I was going to ask what is connected to the USB2 HS13 port. Do you know which port on the motherboard this refers to? Do you have a Webcam/mouse/keyboard or other external USB2 device plugged in to one of your rear I/O ports? It could be the USB port connected to the CNVi connector, for the original Intel Bluetooth connection.
 
Joined
Aug 8, 2019
Messages
13
Motherboard
Gigabyte Z390i Aorus Pro WIFI
CPU
i7-9700K
Graphics
RX 5700 XT
So I try with the SSDT, same result.
HS13 is really just a ITE device. I don't remember why I let it in my USB map. I will try to disable it this week-end if I have time.

But one thing I found strange and could be useful is even on Windows 10 the keyboard and the trackpad doesn't wake the computer. I have install the official BCM94360CS2 driver from apple for windows, work great. But don't wake the computer.

So I start to think that was a MB issue, but as far I search, there I no "wake on bluetooth" on this motherboard bios.

If I have to do it again, I will buy another motherboard :rolleyes:
Simple wifi card replacement and it will be done.

If you have an idea, do not hesitate.
Thanks for helping me :thumbup:
 
Top