Contribute
Register

Help enabling Thunderbolt 3 port on ASRock Z490 Phantom Gaming ITX/TB3

Joined
Jan 27, 2014
Messages
375
Motherboard
ASRock Z490 phantom gaming ITX/TB3
CPU
I9 10850k
Graphics
RX 5500 XT/UHD 630
Mobile Phone
  1. iOS
@CaseySJ

Hi there,

I have been trying to enable the Thunderbolt port on my motherboard, but I haven't managed yet and I hope you can help.
On HackinDROM there is a Thunderbolt controller for ASRock's Z490 ITX/ac which has the proper port configured (RP21).
I have tried using this file in my EFI folder and enabling Thunderbolt in BIOS but so far I cannot see Thunderbolt under System report/PCI which is where it should show up if I understood correctly.

I do not have a Thunderbolt device to test so it makes things a bit hard but Windows reports the port as working

Is there any other file I should get, generate besides the Thunderbolt controller? I have seen other users with this board who managed to enable the port without the need for flashing the firmware.

Hope you can help on this one :)

Thanks a lot
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
@CaseySJ

Hi there,

I have been trying to enable the Thunderbolt port on my motherboard, but I haven't managed yet and I hope you can help.
On HackinDROM there is a Thunderbolt controller for ASRock's Z490 ITX/ac which has the proper port configured (RP21).
I have tried using this file in my EFI folder and enabling Thunderbolt in BIOS but so far I cannot see Thunderbolt under System report/PCI which is where it should show up if I understood correctly.

I do not have a Thunderbolt device to test so it makes things a bit hard but Windows reports the port as working

Is there any other file I should get, generate besides the Thunderbolt controller? I have seen other users with this board who managed to enable the port without the need for flashing the firmware.

Hope you can help on this one :)

Thanks a lot
Please download and run IORegistryExplorer, then scroll (avoid using the search bar) device tree on left side until you get to RP21, and post a screenshot.
 
Joined
Jan 27, 2014
Messages
375
Motherboard
ASRock Z490 phantom gaming ITX/TB3
CPU
I9 10850k
Graphics
RX 5500 XT/UHD 630
Mobile Phone
  1. iOS
There you go, thanks for looking into this :)
Screen Shot 2021-08-12 at 14.29.50.png
 
Joined
Jan 27, 2014
Messages
375
Motherboard
ASRock Z490 phantom gaming ITX/TB3
CPU
I9 10850k
Graphics
RX 5500 XT/UHD 630
Mobile Phone
  1. iOS
wow just like that? Using the SSDT-TB3-HackinDROM.aml for Z490 ITX/ac and enabling TB# in BIOS? Amazing, thanks for confirming. Now I need to find a TB3 device to test.

Thanks a lot!
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
wow just like that? Using the SSDT-TB3-HackinDROM.aml for Z490 ITX/ac and enabling TB# in BIOS? Amazing, thanks for confirming. Now I need to find a TB3 device to test.

Thanks a lot!
IORegistryExplorer is a really helpful app.
 
Joined
Oct 3, 2015
Messages
13
Motherboard
ASRock Z490 Phantom Gaming-ITX/TB3
CPU
i9 10900K
Graphics
RX 550
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Bully for elgipsy! I have the same board and the same issue (hackinDROM only offers for the other Asrock Z490), and my IORegistryExplorer is not showing correct configurations. Also, OC logs show an ACPI table mismatch for both SSDT-DTPG.aml and SSDT-Z490-TB3HP.aml. I did just update the firmware on my mobo, so this may be related. Any pointers, @CaseySJ ? I really appreciate your wisdom.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Bully for elgipsy! I have the same board and the same issue (hackinDROM only offers for the other Asrock Z490), and my IORegistryExplorer is not showing correct configurations. Also, OC logs show an ACPI table mismatch for both SSDT-DTPG.aml and SSDT-Z490-TB3HP.aml. I did just update the firmware on my mobo, so this may be related. Any pointers, @CaseySJ ? I really appreciate your wisdom.
@TeaCake, can you please describe the problem and provide supporting screenshots?
 
Joined
Oct 3, 2015
Messages
13
Motherboard
ASRock Z490 Phantom Gaming-ITX/TB3
CPU
i9 10900K
Graphics
RX 550
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Hey @CaseySJ, I've tried to respond a couple of times now. Not sure if my posts are still pending or what. Said they needed mod approval, perhaps because of the pictures? Anyway, thanks for the quick response. Sorry mine's so slow.
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
20,495
Motherboard
Asus ProArt Z690-Creator
CPU
i7-12700K
Graphics
RX 6800 XT
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Hey @CaseySJ, I've tried to respond a couple of times now. Not sure if my posts are still pending or what. Said they needed mod approval, perhaps because of the pictures? Anyway, thanks for the quick response. Sorry mine's so slow.
Hello @TeaCake,

You may have mentioned a website that has shady practices and is therefore not mentionable here. So if you can describe your problem and provide relevant screenshots without any reference to that site, your post will be allowed.
 
Top