Contribute
Register

Help disabling unused framebuffer ports

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,225
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello @RehabMan, I wish you could guide me to disable the unused frame buffer ports on my Z50-70 since I'm having that annoying lag...

I use ig-platform-id=0x0a2e0008; and all your GitHub repos use 0x0a260006 so I don't know what I should really do.

I also use port 0105 for my HDMI audio port.

Here is my config.plist
 

Attachments

  • config.plist
    8.2 KB · Views: 71

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello @RehabMan, I wish you could guide me to disable the unused frame buffer ports on my Z50-70 since I'm having that annoying lag...

I use ig-platform-id=0x0a2e0008; and all your GitHub repos use 0x0a260006 so I don't know what I should really do.

I also use port 0105 for my HDMI audio port.

Here is my config.plist

Look at the y50 repo. It uses 0105...
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,225
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Look at the y50 repo. It uses 0105...

I did some stuff and I think I got my unused port disabled, but I'm not sure if I did it correctly. I'm attaching my IOReg and config.plist for you to check.
 

Attachments

  • RehabMan.zip
    563.5 KB · Views: 38

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I did some stuff and I think I got my unused port disabled, but I'm not sure if I did it correctly. I'm attaching my IOReg and config.plist for you to check.

It is working. You could do another patch to "erase" the 0204 port, but it is not strictly necessary...
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,225
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
It is working. You could do another patch to "erase" the 0204 port, but it is not strictly necessary...
I would be thankful if you point out to how I could do that...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,247
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I would be thankful if you point out to how I could do that...

The 0204 connector in 0x0a2e0008 is as follows (10.12.4):
02040A00 00040000 07010000

So...
Find: <02040A00 00040000 07010000>
Replace: <ff000000 01000000 40000000>
 

the-braveknight

Moderator
Joined
Nov 24, 2015
Messages
1,225
Motherboard
Lenovo Legion Y520 (Clover)
CPU
i7-7700HQ
Graphics
HD 630 (1920x1080) + Nvidia GTX 1060
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The 0204 connector in 0x0a2e0008 is as follows (10.12.4):
02040A00 00040000 07010000

So...
Find: <02040A00 00040000 07010000>
Replace: <ff000000 01000000 40000000>
Thanks. I'll add these patches to my GitHub repo...
 
Top