Contribute
Register

(Help) Dell Latitude 5580 reboot automatically after some loading at Apple Boot logo.

Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Hello guys, I am trying to install macOS High Sierra in a dual boot configuration with Windows 10. Sadly, I am unable to find any guides for this model and hence seeking help regarding issue that my laptop reboots automatically when macOS is loading (at Apple logo screen).

Here are the main specs of the said model according to CPU-Z:

Intel Core i7-7600U @ 2.8GHz
Ram: 16GB
Intel HD 620 + Nvidia GTX 930MX (2GB)
Screen Resolution: 1366x768

I have followed this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/ for creating a bootable USB for High Sierra.
For config.plist, I have download one for Intel HD 620. Then I changed the resolution from 1920x1080 to 1366x768 (as my laptop supports that), keeping everything unchanged.
I have attached a screenshots of driver64UEFI, Other and install_osx and my config.plist.

Img_2.png
Note that I have used OsxAptioFix2Drv-64.efi instead of OsxAptioFixDrv-64.efi. It also lacks the file OsxFatBinaryDrv-64.efi (as these files are shown in screenshots but not mentioned in instructions). I omitted BaseBinarier clone method as it is stated that it is not supported in High Sierra .

Img_3.png

Img_1.png

Please someone, help me regarding the aforementioned issue. Personally I think this is a minor issue (correct me please if I am wrong).
I have tried to be as comprehensive as possible, but if any information is required please let me know.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,134
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello guys, I am trying to install macOS High Sierra in a dual boot configuration with Windows 10. Sadly, I am unable to find any guides for this model and hence seeking help regarding issue that my laptop reboots automatically when macOS is loading (at Apple logo screen).

Here are the main specs of the said model according to CPU-Z:

Intel Core i7-7600U @ 2.8GHz
Ram: 16GB
Intel HD 620 + Nvidia GTX 930MX (2GB)
Screen Resolution: 1366x768

I have followed this guide https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/ for creating a bootable USB for High Sierra.
For config.plist, I have download one for Intel HD 620. Then I changed the resolution from 1920x1080 to 1366x768 (as my laptop supports that), keeping everything unchanged.
I have attached a screenshots of driver64UEFI, Other and install_osx and my config.plist.

View attachment 334655
Note that I have used OsxAptioFix2Drv-64.efi instead of OsxAptioFixDrv-64.efi. It also lacks the file OsxFatBinaryDrv-64.efi (as these files are shown in screenshots but not mentioned in instructions). I omitted BaseBinarier clone method as it is stated that it is not supported in High Sierra .

View attachment 334656

View attachment 334654

Please someone, help me regarding the aforementioned issue. Personally I think this is a minor issue (correct me please if I am wrong).
I have tried to be as comprehensive as possible, but if any information is required please let me know.
Read guide regarding DVMT-prealloc:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
 
Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,134
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thanks @RehabMan. I had read it. The problem is that I had used one of the config.plist that are linked with that guide. As per that guide those plists already had the specified patch applied. So I think there is no need to do that from my side.
Is there something I had missed?
For the installer, you must use an invalid ig-platform-id (usually).
 
Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
For the installer, you must use an invalid ig-platform-id (usually).
Oh I see.
I am currently disabling Bitlocker as it is having problem when secure boot is off. So will check it once the process finishes.
So will 0x12345678 be alright? Should I check Inject EDID as well?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,134
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Oh I see.
I am currently disabling Bitlocker as it is having problem when secure boot is off. So will check it once the process finishes.
So will 0x12345678 be alright? Should I check Inject EDID as well?
Any invalid ig-platform-id works to disable the graphics kexts. I typically use 0x1, but 0x12345678 is a bit more clear on the intention.
 
Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
Any invalid ig-platform-id works to disable the graphics kexts. I typically use 0x1, but 0x12345678 is a bit more clear on the intention.
Thank You. I will try as soon as decryption finishes. I don’t know 0x1 exists. Thanks for the information though
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,134
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank You. I will try as soon as decryption finishes. I don’t know 0x1 exists. Thanks for the information though
ig-platform-id is a 32-bit integer. Range is 0-0xFFFFFFFF.
There are only a few values recognized by the kexts, most are invalid/not recognized.
 
Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
ig-platform-id is a 32-bit integer. Range is 0-0xFFFFFFFF.
There are only a few values recognized by the kexts, most are invalid/not recognized.
I see...
Thank You
 
Joined
Jul 17, 2015
Messages
135
Motherboard
HP Pavilion 15 dk0xxx-Clover
CPU
i7-9750H
Graphics
UHD 630 + GTX 1650, 1920x1080
Mac
MacBook Air, MacBook Pro
Mobile Phone
iOS
ig-platform-id is a 32-bit integer. Range is 0-0xFFFFFFFF.
There are only a few values recognized by the kexts, most are invalid/not recognized.
Got past the screen. Now installing macOS
 
Last edited:
Top