Contribute
Register

Help Creating DSDT for Gigabyte "GA-Q77M-D2H"

Status
Not open for further replies.
Joined
Oct 17, 2012
Messages
15
Motherboard
Gigabyte GA-Q77M-D2H
CPU
corei5
Graphics
geforce 640
Mac
  1. MacBook
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
This just took a really bad turn. I reinstalled Unibeast to my flash drive, popped it in, and when boot up my "hackintosh," this is what I get:

Boot0: GPT
boot0: test
boot0: test
boot0: test
boot0: test
boot0: test
Boot0: GPT
boot0: test
boot0: test
boot0: test
boot0: test
boot0: test
boot0: error

This never happened before when trying to install unibeast

So, I reboot, press F12, select my usb stick, and I'm brought to the Chameleon screen.
I select USB, and the system restarts, select -v, system restarts... happens for all of them.

Here's a link to some pics of my BIOS settings. I must be doing something wrong there.

https://www.icloud.com/photostream/#ABG4TcsmZqOlK;D0C8DCB2-0E9E-4BBB-8B8A-5C0894F2A06A

Would someone please help me? I'm doing this computer as a favor for someone, and I fear that I may end up having to spend my own money to remedy the situation. I'm well outside any kind of return/credit/exchange time with NewEgg, so I MUST figure this thing out...unfortunately, nothing is working. Even worse, by somehow repeating the same process over and over, I'm not not even able to install ML. PLEEEEEAAAAASE help me
 
Joined
Nov 6, 2011
Messages
19
Motherboard
Intel NUC 6i5SYH
CPU
i5-6260U
Graphics
Integrated
Mac
  1. MacBook Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
I cant see the pics u linked to. I followed this guide:
http://www.tonymacx86.com/99-quick-guide-configuring-uefi-gigabyte-s-7-series-lga-1155-boards.html

I also am using the HD 4000 graphics so if u are trying to mirror me you will need to take out your graphics card. I bet once things are working you can probably just pop it back in and it will work.

This is from memory but here were my steps in BIOS:
1. Reset to Optimized defaults
2. Switch IDE to AHCI (for this mobo IDE is default)
3. xHCI Mode: Auto
4. Display First: IGFX
5. Wake on LAN: off
6. EIST: enabled
7. Turbo Boost: enabled
9. VT-d: DISABLED <- this is the setting that was messing me up originally, It was not mentioned in the above guide
8. Make sure boot drive is not UEFI, should have somthing like "P1: DRIVENAME"

after I did this I was able to boot off the USB and launch the installer with no options required.

Multibeast Options:
UserDSDT or DSDT-Free Installation
Disk > Trim Enabler (only if you have an SSD)
Audio > Realtek ALC8xx > Without DSDT > ALC887/888b > vXXXX Current
Network > Kext hnak’s AppleIntelE1000e Ethernet

Are you creating the ML installer USB with the latest version of ML?

that was it!
 
Joined
Mar 23, 2011
Messages
42
Motherboard
Gigabyte Z390 Master
CPU
i9-9900K OC@5.2GHz
Graphics
Vega 56
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi,

You don't need a DSDT! Besides that if you did a search for Q77M enough things would have popped up to help you out. Like what the right Multibeast settings are!

That said. Go into BIOS and disable VD-T and you should be up and running in no time.


I've searched and searched the motherboard settings but can't find VD-T anywhere,
What page is it hiding in? I know I'm being thick but for the life of me I can't find it anywhere!
 
Joined
Nov 6, 2011
Messages
19
Motherboard
Intel NUC 6i5SYH
CPU
i5-6260U
Graphics
Integrated
Mac
  1. MacBook Pro
Classic Mac
  1. eMac
Mobile Phone
  1. iOS
Its under "BIOS Features":
Intel Virtualization Technology: Enabled
VT-d: Disabled <---------------------
Network Stack: Disabled

If you have a K series process you might not have the option because K series do not support VT-d.
 
Joined
May 28, 2013
Messages
2
Motherboard
Gigabyte GA-Q77M-D2H
CPU
3.4 Ghz i5 3570k
Graphics
HD 4000
Mac
  1. iMac
Mobile Phone
  1. iOS
i noticed you are using the on board graphics too. I have the same parts as you do, except 3570k instead of 3770. Do you have any issues with videos? Youtube is not working for me, as well as VLC and other players, and I cannot seem to find a clear solution for it. Can you please tell me how you did it? Thanks!
 
Status
Not open for further replies.
Top