Contribute
Register

Help configuring OpenCore for Gigabyte Z390 + i9-9900k

Joined
Feb 9, 2011
Messages
57
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Hi @jdapolo and @Covalt, I also have the Gigabyte Z390 Aorus Xtreme with the i9-9900K and a Radeon VII, and I was wondering if either or both of you have fully working OpenCore config. @jdapolo , it sounded like you had to make some changes--would you be willing to share your EFI? Do you have a pointer to the Dortania tutorial you referenced?
 
Joined
Dec 21, 2017
Messages
223
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Hi @jdapolo and @Covalt, I also have the Gigabyte Z390 Aorus Xtreme with the i9-9900K and a Radeon VII, and I was wondering if either or both of you have fully working OpenCore config. @jdapolo , it sounded like you had to make some changes--would you be willing to share your EFI? Do you have a pointer to the Dortania tutorial you referenced?

Yeah, I'm fully working here, using OpenCore. I got A LOT of help from users on this forum.
 
Joined
Feb 9, 2011
Messages
57
Motherboard
Gigabyte Designare Z390
CPU
i9-9900K
Graphics
Radeon 5700 XT
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Mobile Phone
  1. iOS
Yeah, I'm fully working here, using OpenCore. I got A LOT of help from users on this forum.
Does the EFI you posted earlier on this thread represent the best working setup, or are there other fixes you've identified and applied after you posted the EFI. If you've made other changes/fixes, is it possible to get an updated EFI, or some tips about what pitfalls you ran into and how they were addressed? That would be a huge help to anyone following in your footsteps.
 
Joined
Nov 23, 2010
Messages
70
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
Core i9-9900K
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hey man, sorry for the late reply. Busy with work. Anyway, here's my EFI that I originally got from @Covalt but had to re-do the config.plist from scratch since I upgraded to OC 0.5.9. Let me know if it works for you. (Also, I removed the MLB, Serial and UUID, just fill it in with your own)


Hi @jdapolo and @Covalt, I also have the Gigabyte Z390 Aorus Xtreme with the i9-9900K and a Radeon VII, and I was wondering if either or both of you have fully working OpenCore config. @jdapolo , it sounded like you had to make some changes--would you be willing to share your EFI? Do you have a pointer to the Dortania tutorial you referenced?
 

Attachments

  • EFI.zip
    4.6 MB · Views: 113
Joined
Dec 21, 2017
Messages
223
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
hi @pastrychef ! It's been a while. Wondered what your thoughts are around Big Sur. I've been running 10.15.7 smoothly with OC 0.5.8 for quite some time and wondered if installing Big Sur would pretty much wreck my system if I just did a simple install. I haven't looked into it much yet, but was curious what you'd say.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,903
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
hi @pastrychef ! It's been a while. Wondered what your thoughts are around Big Sur. I've been running 10.15.7 smoothly with OC 0.5.8 for quite some time and wondered if installing Big Sur would pretty much wreck my system if I just did a simple install. I haven't looked into it much yet, but was curious what you'd say.

I haven't updated yet. I'm having trouble downloading the update... Apple's servers are probably being hit hard.

I don't anticipate any problems. Update to latest OpenCore first. I'll report back after updating.
 
Joined
Dec 21, 2017
Messages
223
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
I haven't updated yet. I'm having trouble downloading the update... Apple's servers are probably being hit hard.

I don't anticipate any problems. Update to latest OpenCore first. I'll report back after updating.
Heh yeah I haven't been able to download it on my MBP either..

Thanks for offering to report back after you've updated - hope it goes smoothly!
 
Joined
Feb 17, 2011
Messages
20
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
Intel i9-9900K
Graphics
Radeon RX 5700 XT
Hello Covalt.
What is the last efi you are using?
I'm having problem...
 
Joined
Dec 21, 2017
Messages
223
Motherboard
Gigabyte Z390 Aorus Xtreme
CPU
i9-9900K
Graphics
Radeon VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Hello Covalt.
What is the last efi you are using?
I'm having problem...
In post #319. I haven't made any changes to my EFI in a long time since I've been running smoothly.
macOS 10.15.7. Would like to upgrade to Big Sur, but don't have the time right now to get the Hackintosh running smoothly if it's not a simple install.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
16,903
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
I haven't updated yet. I'm having trouble downloading the update... Apple's servers are probably being hit hard.

I don't anticipate any problems. Update to latest OpenCore first. I'll report back after updating.


Oops... Forgot to reply here. I updated fine to Big Sur on latest OpenCore.
 
Top