Contribute
Register

[Help] Clover boot from HDD

Joined
Sep 4, 2011
Messages
31
Motherboard
Inspiron 7558
CPU
i7-5500U
Graphics
HD 5500
Mobile Phone
iOS
Hey guys,

So I've finally got Yosemite installed & booting on my Aspire V3-472P-51JB. It runs good but I am having issues with getting the Clover boot loader to work from my HDD. I've installed it to the main OS X partition & replaced the config file, as well as added the kexts & other necessary files as described in the guide. My problem is once I boot without my USB drive in it boots straight to windows. I've tried booting to the boot menu but I only get the option to boot to windows. My BIOS is set to UEFI boot & it has secure boot disabled, I've also tried booting in legacy mode but it crashes instantly.

If anyone has any idea as to why I'm not even getting the option to boot into the boot loader from the HDD it would be greatly appreciated if you could help me because I'm lost! OS X boots fine using the boot loader installed on the USB drive.

Something else I would like to throw in here as well is an issue I'm having with my trackpad. I have an ELAN touchpad and used the ApplePS2ElanTouchpad.kext from here: http://forum.osxlatitude.com/index....and-synaptics-smart-touchpad-driver-mac-os-x/

I am able to configure the "Trackpad" settings in PrefPane, and I seen on the site that you are supposed to adjust the scrolling speed in order for it to work, but I've tried that and as soon as I go to scroll with two fingers the mouse freezes in the spot it's in, I can right click and click, but I cannot move the cursor or scroll the page. If I plug my USB mouse in it works fine through that, but the trackpad is still unresponsive until I restart the computer.

Help with these issues would be greatly appreciated & I thank you in advanced.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hey guys,

So I've finally got Yosemite installed & booting on my Aspire V3-472P-51JB. It runs good but I am having issues with getting the Clover boot loader to work from my HDD. I've installed it to the main OS X partition & replaced the config file, as well as added the kexts & other necessary files as described in the guide. My problem is once I boot without my USB drive in it boots straight to windows. I've tried booting to the boot menu but I only get the option to boot to windows. My BIOS is set to UEFI boot & it has secure boot disabled, I've also tried booting in legacy mode but it crashes instantly.
See guide for instaling Clover to EFI: http://www.tonymacx86.com/yosemite-...oting-os-x-installer-laptops-clover-uefi.html
 
Joined
Sep 4, 2011
Messages
31
Motherboard
Inspiron 7558
CPU
i7-5500U
Graphics
HD 5500
Mobile Phone
iOS
This is the guide I used, but instead of installing on a separate partition I've installed it directly to the "Mac OSX" partition I have containing Yosemite OS X. I've done everything the same as I did when I installed it on the USB except for the couple of things you mentioned to do different when installing on HDD. After all was said & done I was still not able to boot using the HDD.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
This is the guide I used, but instead of installing on a separate partition I've installed it directly to the "Mac OSX" partition I have containing Yosemite OS X. I've done everything the same as I did when I installed it on the USB except for the couple of things you mentioned to do different when installing on HDD. After all was said & done I was still not able to boot using the HDD.
You need to install for UEFI. Clover will go to EFI partition.
 
Joined
Sep 4, 2011
Messages
31
Motherboard
Inspiron 7558
CPU
i7-5500U
Graphics
HD 5500
Mobile Phone
iOS
You need to install for UEFI. Clover will go to EFI partition.
I am dual booting on the HDD I am using, I've had windows 8.1 on the HDD all along & just made a second partition and installed OSX. Could this be a potential problem? I've seen people talking about installing OSX before windows on other forums.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,974
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I am dual booting on the HDD I am using, I've had windows 8.1 on the HDD all along & just made a second partition and installed OSX. Could this be a potential problem? I've seen people talking about installing OSX before windows on other forums.
Perhaps you're booting directly into Windows because you didn't rename \EFI\Microsoft\Boot\bootmgfw.efi to bootmgfw-orig.efi?
 
Top