Contribute
Register

[HELP]ATI Mobility Radeon HD4570 & High Sierra 10.13.1

Status
Not open for further replies.
Joined
Mar 13, 2011
Messages
17
Motherboard
Gigabyte GA-Z77X-UD5H-WB
CPU
E3-1245 V2
Graphics
P4000 + RX 570X
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Hi all,
it's possibile to enalbe this graphic card?
i've an old TOSHIBA L650-108 with i3-330M & HD5140 (which is really 4570) (0x95531002); Clover installation.
The installation goes ok, but when sistem reboot i have a KP ->ATIRadeonX2000.kext

I tried with this option:
FAKEID: 0x94981002 (ATIRadeon 4650) -> System go up but no resolution and no card recog.
FAKEID + InjectATI -> System go up, no resolution but name card recog (olny 3MB VRAM)
FAKEID + InjectATI + LoadBIOS -> System go up, no resolution but name card recog (only 4MB VRAM)
FAKEID + InjectATI + LoadBIOS + PatchBIOS -> System go up, right resolution (but i can't choose any other), right name but only 4 MB VRAM
FAKEID + InjectATI + LoadBIOS + PatchBIOS + many FB -> same result than before....

Any ideas?

Tnx
 
Joined
Aug 31, 2014
Messages
264
Motherboard
Asus T300LA-DH51T
CPU
Intel Core i5 4200U
Graphics
Intel HD Graphics 4400
Mobile Phone
  1. Android
you only have 3 FB to choose from Gliff and Shrike are both LVDS. So one of those then patch the FB connectors to match yours just like desktop graphics

Hi all,
it's possibile to enalbe this graphic card?
i've an old TOSHIBA L650-108 with i3-330M & HD5140 (which is really 4570) (0x95531002); Clover installation.
The installation goes ok, but when sistem reboot i have a KP ->ATIRadeonX2000.kext

I tried with this option:
FAKEID: 0x94981002 (ATIRadeon 4650) -> System go up but no resolution and no card recog.
FAKEID + InjectATI -> System go up, no resolution but name card recog (olny 3MB VRAM)
FAKEID + InjectATI + LoadBIOS -> System go up, no resolution but name card recog (only 4MB VRAM)
FAKEID + InjectATI + LoadBIOS + PatchBIOS -> System go up, right resolution (but i can't choose any other), right name but only 4 MB VRAM
FAKEID + InjectATI + LoadBIOS + PatchBIOS + many FB -> same result than before....

Any ideas?

Tnx
 
Joined
Mar 13, 2011
Messages
17
Motherboard
Gigabyte GA-Z77X-UD5H-WB
CPU
E3-1245 V2
Graphics
P4000 + RX 570X
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
you only have 3 FB to choose from Gliff and Shrike are both LVDS. So one of those then patch the FB connectors to match yours just like desktop graphics
can you help me?
i followed this link https://www.tonymacx86.com/threads/help-for-qe-ci-enabled-on-ati-45xx-and-dsdt-patch.179684/ but the result are the same....

i've notice that if I inject the ID (0x95531002) both on ATIRadeonX2000 & ATI4600Controller system reboot after *DEVICE IN SLOT: SLOT-1* -> if i remember right the card is fully recog when showed that line..
 
Joined
Mar 13, 2011
Messages
17
Motherboard
Gigabyte GA-Z77X-UD5H-WB
CPU
E3-1245 V2
Graphics
P4000 + RX 570X
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
i patched shrike FB with this line:

10000000 10000000 00010200 0 00100105 0 LVDS->VGA
02000000 40000000 08010100 0 12040207 0 LVDS->LVDS
00080000 00020000 00010300 0 10000301 0 DISPLAYPORT->HDMI

And i put them on clover/kexttopatch

amd4600controller - old FB extracted - My FB patched (wrote as you can see up)

but nothing has changed.... now AMD4600controller.kext load but AtiRadeonX2000.kext no.

when i forced to load atix2000 the system reboot after *DEVICE IN SLOT: SLOT-1*

Any ideas?
 
Joined
Dec 13, 2013
Messages
1
Motherboard
gigabyte z390
CPU
intel i7
Graphics
geforce gtx 1080
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
Classic Mac
  1. Classic
  2. Quadra
Mobile Phone
  1. Android
hier is the kext of ati mobile radeon 4570 for high Sierra
 

Attachments

  • AMD4600Controller.kext.zip
    853.9 KB · Views: 209
  • ATIRadeonX2000.kext.zip
    1 MB · Views: 191
  • ATY_Init.kext.zip
    246.8 KB · Views: 208
Status
Not open for further replies.
Top