Contribute
Register

[Help] Asus ROG GL553VD - High Sierra 10.13.4

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,867
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,867
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Sep 30, 2013
Messages
10
Motherboard
Z370 Prime-P
CPU
8600k
Graphics
Gigabyte Vega 56 (ref)
Mac
  1. MacBook Pro
Classic Mac
  1. Power Mac
  2. PowerBook
Mobile Phone
  1. Android
  2. iOS
Why can't we just have a complete /EFI/ shared to us?
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
19,062
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Joined
Jun 26, 2014
Messages
5
Motherboard
Asus ROG GL553VD
CPU
i7-7700HQ
Graphics
HD 630
Mobile Phone
  1. Android
Hello, I have the same laptop that you, the Asus ROG GL553VD (with the i7-7700HQ processor). Can I ask you guys a couple of questions? I installed Mojave some days ago:
  • What is your idle processor freq? Mine is over 1.4 Ghz and I think its not ok
  • How did you make Fn keys to work? (I specially want to turn off/control keyboard backlight)
  • How can I know if Nvidia GPU is off? I know I can't use it with Hackintosh but maybe it's using some power, I don't know really.
  • Also, anytime I connect a 3.0 device I have to plug it in the 2.0 port otherwise I can't access.

I'm a little newbie but learning lots, sorry if Im asking a lot haha, hope you can help me!

Thanks!!
 
Joined
Dec 26, 2013
Messages
49
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel i7 7700
Graphics
Amd RX 580 8 GB
Mac
  1. Mac mini
Mobile Phone
  1. Android
I also have the Gl553VD and have everything working, but the trackpad. I read on that German forum that you just need the VoodooI2C kexts installed with this laptop now, but it does not work.
 

mnq

Joined
Apr 22, 2020
Messages
2
Motherboard
Gigabyte > need model # > See Rules!
CPU
i7-7700HQ
Graphics
GTX 1050
Hi, I am hackintoshing for the first time!

Here is the summary of the laptop (and I am attaching the exports from CPU-Z too):
- Model: Asus ROG GL553VD
- CPU: Intel i7-7700HQ
- Chipset: Intel HM175
- Graphics: Intel HD630 + Nvidia Geforce GTX 1050 Optimus, 1920x1080
- Memory: DDR4-2400 16GB x 2
- Storage: SSD 500GB NVMe + HD 1000GB (2.5")

These are the links I have already read:
- https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
- https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
- https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/
- https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
- https://www.tonymacx86.com/threads/guide-disabling-discrete-graphics-in-dual-gpu-laptops.163772/
- https://github.com/fidele007/Asus-ROG-GL552VW-Hackintosh

I tried to install Mac Sierra 10.13.4. First, I tried to use Clover on making a bootable USB drive but failed to configure it correctly as the machine always freezes upon booting. Then, I tried using UniBeast and successfully installed the OS into the laptop. The laptop monitor is showing up with the right resolution. I am able to boot into Mac and use it with USB mouse and keyboard, but the following items are obviously not working:
- HDMI video (and sound) output to external monitor (no effect when plugging an HDMI monitor into the port, even when it's plugged before the system boots up)
- Laptop keyboard and touchpad

These are the most important items I am seeking advice:
1. How do I get the HDMI output port working?
2. Do I have to disable the Nvidia graphic card by patching the ACPI for the HD630 to work?
3. How do I decompile the ACPI files successfully? I tried to decompile using "iasl -da -dl DSDT.aml SSDT-*.aml" but I am getting "ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog". I also tried to decompile using windows iasl on an Windows 10 machine but the same errors come out. If a `refs.txt` is required, how do I create the right `refs.txt`?

These are less urgent but I would like to get them working eventually:
4. Keyboard
5. Touchpad
6. Brightness
7. Battery patch

Can anybody point me to the right direction please? I am attaching the CPU-Z spec, my current config.plist and the origin AML files here. Thank you very much.
Hey coul you tell me how did it work on yours? I tried unibeast also in the same spec as yours but still stuck upon booting? Thanks
 
Top