Contribute
Register

[Help] Asus ROG GL553VD - High Sierra 10.13.4

Joined
Apr 23, 2018
Messages
71
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
HD630, 1920x1080
Mac
MacBook
Mobile Phone
Android, iOS
Hi, I am hackintoshing for the first time!

Here is the summary of the laptop (and I am attaching the exports from CPU-Z too):
- Model: Asus ROG GL553VD
- CPU: Intel i7-7700HQ
- Chipset: Intel HM175
- Graphics: Intel HD630 + Nvidia Geforce GTX 1050 Optimus, 1920x1080
- Memory: DDR4-2400 16GB x 2
- Storage: SSD 500GB NVMe + HD 1000GB (2.5")

These are the links I have already read:
- https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
- https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
- https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/
- https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
- https://www.tonymacx86.com/threads/guide-disabling-discrete-graphics-in-dual-gpu-laptops.163772/
- https://github.com/fidele007/Asus-ROG-GL552VW-Hackintosh

I tried to install Mac Sierra 10.13.4. First, I tried to use Clover on making a bootable USB drive but failed to configure it correctly as the machine always freezes upon booting. Then, I tried using UniBeast and successfully installed the OS into the laptop. The laptop monitor is showing up with the right resolution. I am able to boot into Mac and use it with USB mouse and keyboard, but the following items are obviously not working:
- HDMI video (and sound) output to external monitor (no effect when plugging an HDMI monitor into the port, even when it's plugged before the system boots up)
- Laptop keyboard and touchpad

These are the most important items I am seeking advice:
1. How do I get the HDMI output port working?
2. Do I have to disable the Nvidia graphic card by patching the ACPI for the HD630 to work?
3. How do I decompile the ACPI files successfully? I tried to decompile using "iasl -da -dl DSDT.aml SSDT-*.aml" but I am getting "ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog". I also tried to decompile using windows iasl on an Windows 10 machine but the same errors come out. If a `refs.txt` is required, how do I create the right `refs.txt`?

These are less urgent but I would like to get them working eventually:
4. Keyboard
5. Touchpad
6. Brightness
7. Battery patch

Can anybody point me to the right direction please? I am attaching the CPU-Z spec, my current config.plist and the origin AML files here. Thank you very much.
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,360
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi, I am hackintoshing for the first time!

Here is the summary of the laptop (and I am attaching the exports from CPU-Z too):
- Model: Asus ROG GL553VD
- CPU: Intel i7-7700HQ
- Chipset: Intel HM175
- Graphics: Intel HD630 + Nvidia Geforce GTX 1050 Optimus, 1920x1080
- Memory: DDR4-2400 16GB x 2
- Storage: SSD 500GB NVMe + HD 1000GB (2.5")

These are the links I have already read:
- https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/
- https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
- https://www.tonymacx86.com/threads/readme-common-problems-in-10-13-high-sierra.233582/
- https://www.tonymacx86.com/threads/...-only-ran-for-0-seconds-with-dual-gpu.233092/
- https://www.tonymacx86.com/threads/guide-disabling-discrete-graphics-in-dual-gpu-laptops.163772/
- https://github.com/fidele007/Asus-ROG-GL552VW-Hackintosh

I tried to install Mac Sierra 10.13.4. First, I tried to use Clover on making a bootable USB drive but failed to configure it correctly as the machine always freezes upon booting. Then, I tried using UniBeast and successfully installed the OS into the laptop. The laptop monitor is showing up with the right resolution. I am able to boot into Mac and use it with USB mouse and keyboard, but the following items are obviously not working:
- HDMI video (and sound) output to external monitor (no effect when plugging an HDMI monitor into the port, even when it's plugged before the system boots up)
- Laptop keyboard and touchpad

These are the most important items I am seeking advice:
1. How do I get the HDMI output port working?
2. Do I have to disable the Nvidia graphic card by patching the ACPI for the HD630 to work?
3. How do I decompile the ACPI files successfully? I tried to decompile using "iasl -da -dl DSDT.aml SSDT-*.aml" but I am getting "ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog". I also tried to decompile using windows iasl on an Windows 10 machine but the same errors come out. If a `refs.txt` is required, how do I create the right `refs.txt`?

These are less urgent but I would like to get them working eventually:
4. Keyboard
5. Touchpad
6. Brightness
7. Battery patch

Can anybody point me to the right direction please? I am attaching the CPU-Z spec, my current config.plist and the origin AML files here. Thank you very much.
the clover (laptop guide) mentions about using VoodooPS2Controller for the keyboard

your Asus is most likely to use I2C, more info here:
https://www.tonymacx86.com/threads/voodooi2c-help-and-support.243378/
but you will have to verify that one

brightness and battery patch can be found here:
https://www.tonymacx86.com/forums/high-sierra-laptop-support.192/
 
Joined
Apr 23, 2018
Messages
71
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
HD630, 1920x1080
Mac
MacBook
Mobile Phone
Android, iOS
Joined
Apr 23, 2018
Messages
71
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
HD630, 1920x1080
Mac
MacBook
Mobile Phone
Android, iOS

Feartech

Moderator
Joined
Aug 3, 2013
Messages
17,360
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I am not able to boot using Clover. Verbose mode gives me error related to "gtx" something.
boot verbose and take a picture and upload it here along with your problem reporting files
 
Joined
Apr 23, 2018
Messages
71
Motherboard
ASUS Prime H370M-Plus/CSM
CPU
i7-8700
Graphics
HD630, 1920x1080
Mac
MacBook
Mobile Phone
Android, iOS
boot verbose and take a picture and upload it here along with your problem reporting files
Feartech, while waiting for the turnaround, would you also guide me in decompiling the AML files please? I will have to patch them eventually anyway.
 
Top