Contribute
Register

[Help] AppleALC Kernel Panic after Catalina update

Joined
Jun 15, 2015
Messages
50
Motherboard
Fujitsu Lifebook E744 HM86
CPU
i5-4300M
Graphics
HD 4600, 1600x900
Mac
Mac Pro
I confirm that with 1.2.8 both sound and sleep work well :headbang:

UPDATE: I just tested 1.3.0 and it's not working, so you may be right.
I still keep wondering though, why do recent releases work on Mojave?
Probably it's something to do with how Catalina manages audio, or sleep, I don't know, but we should track this bug.
 
Joined
Apr 11, 2011
Messages
3
Mac
Classic Mac
Mobile Phone
Confirmed that is fix reboot wake after sleep with 1.2.8 -alcbeta on Catalina 19A583.
Disappeared HDAU@3 AppleHDAHDMI_DPDriver


GA-Z97X-UD7TH Core i7-4770S with IGPU only
Connected through HDMI
 
Last edited:
Joined
Jun 3, 2016
Messages
10
Motherboard
ASRock z97e/itx-ac
CPU
i5-4460
Graphics
HD 4600
Mobile Phone
iOS
Confirmed that is fix reboot wake after sleep with 1.2.8 -alcbeta on Catalina 19A583.
Disappeared HDAU@3 AppleHDAHDMI_DPDriver


GA-Z97X-UD7TH Core i7-4770S with IGPU only
Connected through HDML
Confirmed 1.2.8 works. -alcbeta was important. Without it, no sound no matter what layout-id I chose.
 
Joined
Jun 3, 2016
Messages
10
Motherboard
ASRock z97e/itx-ac
CPU
i5-4460
Graphics
HD 4600
Mobile Phone
iOS
Confirmed 1.2.8 works. -alcbeta was important. Without it, no sound no matter what layout-id I chose.
No sound after walking up from sleep. Hitting another problem...
 
Joined
Jun 15, 2015
Messages
50
Motherboard
Fujitsu Lifebook E744 HM86
CPU
i5-4300M
Graphics
HD 4600, 1600x900
Mac
Mac Pro
No sound after walking up from sleep. Hitting another problem...
I'm encountering this issues too, tomorrow I'll further investigate if I find some spare time
 
Last edited:
Joined
Jun 15, 2015
Messages
50
Motherboard
Fujitsu Lifebook E744 HM86
CPU
i5-4300M
Graphics
HD 4600, 1600x900
Mac
Mac Pro
Anyway the bug in the current release is that IF the hdmi/dp cable is disconnected then the system wakes then KP. It's not totally broken
 
Joined
Jun 15, 2015
Messages
50
Motherboard
Fujitsu Lifebook E744 HM86
CPU
i5-4300M
Graphics
HD 4600, 1600x900
Mac
Mac Pro
No sound after walking up from sleep. Hitting another problem...
Can you please try all the layouts for your codec? See if it happens with all layouts, because with another layout(in my case 27) it seems to work normally.

Just pls remember that this is a workaround and when fixed the update to the new AppleAlc would be ideal
 
Joined
Jun 3, 2016
Messages
10
Motherboard
ASRock z97e/itx-ac
CPU
i5-4460
Graphics
HD 4600
Mobile Phone
iOS
Can you please try all the layouts for your codec? See if it happens with all layouts, because with another layout(in my case 27) it seems to work normally.

Just pls remember that this is a workaround and when fixed the update to the new AppleAlc would be ideal
Yeah, for my ALC1150, layout-id 3 is working fine. Sleep and audio works. Thanks!
No luck. Tried all layout ids, but it appears that the problem (no audio after sleep) is still there. Thanks, anyway!
 
Last edited:
Joined
Jun 15, 2015
Messages
50
Motherboard
Fujitsu Lifebook E744 HM86
CPU
i5-4300M
Graphics
HD 4600, 1600x900
Mac
Mac Pro
Yeah, for my ALC1150, layout-id 3 is working fine. Sleep and audio works. Thanks!
No luck. Tried all layout ids, but it appears that the problem (no audio after sleep) is still there. Thanks, anyway!
Sorry to hear that, hope for a fix soon. Did someone write an issues on GitHub?
 
Joined
Nov 6, 2017
Messages
43
Motherboard
Asus PRIME Z370-A
CPU
i7-8700K
Graphics
UHD 630
Mobile Phone
iOS
Sorry to hear that, hope for a fix soon. Did someone write an issues on GitHub?
I'm having the same problem as well and I opened an issue on Github. Hopefully it'll be resolved soon.
 
Top