Contribute
Register

[Help] Alps trackpad not working with the latest voodoops2controller kext but keyboard is working well

Status
Not open for further replies.
Joined
Oct 29, 2016
Messages
61
Motherboard
HP Envy 15t-j100 (Clover)
CPU
i7 4700MQ
Graphics
HD 4600, 1920x1080
Mobile Phone
  1. Android
Hello everyone!
I have successfully installed mac os x catalina on my hp envy n haswell laptop but there are still some problems.
With the use of the latest voodoops2controller kext my keyboard works very well including the brightness keys but the alps touchpad doesn't work. So i found a voodoops2controller.kext which i have attached it and through which my alps trackpad works good but the keyboard doesn't work natively like brightness keys doesn't work.
I tried to merge these both kexts but couldn't succeeded.
Also I am using an external usb speaker for my laptop and while i am listening to songs on catalina, after about 3 minutes the sound gets bad like usb speaker is damaged and for it i have to unplug and replug the usb each after 3 minutes but however on windows and other laptops it is working well, also sometimes catalina hangs while on lid close and on shutdown.
Any help would be appreciable
Thank you in advance

Regards
 

Attachments

  • Problem Reporting.zip
    4.1 MB · Views: 81
  • VoodooPS2Controller.kext.zip
    89.7 KB · Views: 131
Joined
Aug 20, 2019
Messages
7
Motherboard
Fujitsu lifebook A555
CPU
i3-5005U
Graphics
HD 5500
Mac
  1. MacBook
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Same Issue Here, ALPS Touchpad not Working.
were you able to make it work.
 
Joined
Mar 2, 2013
Messages
30
Motherboard
Elitebook 1040 G3 (Clover)
CPU
i7-6600
Graphics
HD 520
Mac
  1. MacBook Pro
  2. Mac Pro
Classic Mac
  1. iBook
Mobile Phone
  1. Android
I switched from clover to OC this week. I was using this kext for my ALPS touchpad and it worked fine in Mojave.

During the installation of Catalina with OC, using that kext, the trackpad works fine. IE, tap to click, double-tap-drag, 2 finger scroll. And also in recovery it works fine. Booting up normally I lose tap to click and double tap drag. 2 finger scroll still works, but I can't drag at all, holding the physical button and trying to drag does strange things.

I tried to see if installing the kext to L/E would change anything, so I rebooted to recovery (working fine), disable SIP (csrutil disable), reboot, enter password (worked fine)... then both keyboard and trackpad totally stopped working. Using a usb keyboard and mouse I installed the kext to L/E, rebooted into recovery, enabled SIP, rebooted again.

After all that Im back where I started, same limited funcionality of the trackpad. Keyboard works fine, with fn keys working properly too.

I've tried other voodoops2controller.kext I've found around the place with slightly different results. The most updated one from acidanthera here fixes tap to click but loses 2 finger scroll...


I'm really confused as to why it works properly in recovery but not in the full os.. Anyone have any ideas?
 
Status
Not open for further replies.
Top