Contribute
Register

<< Solved >> HDMI Out not working on HP Elitebook 850 G6 with Intel UHD 620

Joined
Oct 9, 2022
Messages
5
Motherboard
HP EliteBook 850 G6
CPU
i5-8365U
Graphics
UHD 620
Hello together,

I managed to get (except of bluetooth) the basic parts working, but I am struggling with getting the HDMI out to work. When I plug in the HDMI cable, the notebook screen goes black for 1 few seconds and comes back. The OS doesn't regocnize the external monitor. This "flickering" only appears with the boot flag agdpmod=vit9696. Without nothing happens at all.

I testet several configurations and with the current AAPL,ig-platform-id und device-id I got full-screen resolution and graphics acceleration working (according to the VDADecoderChecker). I watched several videos, read guides and still no success after many hours.

I uploaded my EFI and hope you can help me. This fails are very devastating at the moment :(
 

Attachments

  • EFI.zip
    18.8 MB · Views: 14

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,035
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hello together,

I managed to get (except of bluetooth) the basic parts working, but I am struggling with getting the HDMI out to work. When I plug in the HDMI cable, the notebook screen goes black for 1 few seconds and comes back. The OS doesn't regocnize the external monitor. This "flickering" only appears with the boot flag agdpmod=vit9696. Without nothing happens at all.

I testet several configurations and with the current AAPL,ig-platform-id und device-id I got full-screen resolution and graphics acceleration working (according to the VDADecoderChecker). I watched several videos, read guides and still no success after many hours.

I uploaded my EFI and hope you can help me. This fails are very devastating at the moment :(

agdpmod=vit9696 is for desktop system

"and" does not belong in boot arguments

igfxonln=1 my help

igfxdump
igfxfbdump
can both be removed
 
Joined
Oct 9, 2022
Messages
5
Motherboard
HP EliteBook 850 G6
CPU
i5-8365U
Graphics
UHD 620
Thank you. I've done your changes, but still no HDMI out. I mapped my USB ports and tried different AAPL,ig-platform-id, here are my results


https://github.com/acidanthera…/Manual/FAQ.IntelHD.en.md

and

https://dortania.github.io/Ope…patching/#getting-started


converted Big Endian to Little Endian


3E A5 00 09
0900A53E
internal Display works, no HDMI


3E 92 00 09
0900923E
internal Display works, no HDMI


3E 9B 00 09
09009B3E
internal Display works, no HDMI


3E A5 00 00
0000A53E
internal Display works, no HDMI


3E 92 00 00
0000923E
internal Display works, no HDMI


3E 00 00 00
0000003E
internal Display works, no HDMI


3E 9B 00 00
00009B3E
internal Display works, no HDMI


3E A5 00 04
0400A53E
internal Display does not work, no HDMI


3E A5 00 05
0500A53E
internal Display does not work, no HDMI


3E A6 00 05
0500A63E
internal Display does not work, no HDMI


3E 9B 00 06
06009B3E
internal Display does not work, no HDMI

3E 9B 00 08
08009B3E
internal Display works, no HDMI


With IORegistryExplorer I can see that framebuffer 1 und 2 are activated and the connector-type of both is set to the hexkey for HDMI. I just have not enough experience to figure it out myself.

Here is my current zipped EFI (deleted AirportItlwm.kext in the zip file to make it a bit smaller for uploading).
 

Attachments

  • Bildschirmfoto 2022-10-10 um 11.16.44.png
    Bildschirmfoto 2022-10-10 um 11.16.44.png
    591.2 KB · Views: 9
  • Bildschirmfoto 2022-10-10 um 11.17.18.png
    Bildschirmfoto 2022-10-10 um 11.17.18.png
    548.8 KB · Views: 10
  • Bildschirmfoto 2022-10-10 um 11.17.26.png
    Bildschirmfoto 2022-10-10 um 11.17.26.png
    550.8 KB · Views: 12
  • EFI.zip
    25.5 MB · Views: 16

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,035
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thank you. I've done your changes, but still no HDMI out. I mapped my USB ports and tried different AAPL,ig-platform-id, here are my results


https://github.com/acidanthera…/Manual/FAQ.IntelHD.en.md

and

https://dortania.github.io/Ope…patching/#getting-started


converted Big Endian to Little Endian


3E A5 00 09
0900A53E
internal Display works, no HDMI


3E 92 00 09
0900923E
internal Display works, no HDMI


3E 9B 00 09
09009B3E
internal Display works, no HDMI


3E A5 00 00
0000A53E
internal Display works, no HDMI


3E 92 00 00
0000923E
internal Display works, no HDMI


3E 00 00 00
0000003E
internal Display works, no HDMI


3E 9B 00 00
00009B3E
internal Display works, no HDMI


3E A5 00 04
0400A53E
internal Display does not work, no HDMI


3E A5 00 05
0500A53E
internal Display does not work, no HDMI


3E A6 00 05
0500A63E
internal Display does not work, no HDMI


3E 9B 00 06
06009B3E
internal Display does not work, no HDMI

3E 9B 00 08
08009B3E
internal Display works, no HDMI


With IORegistryExplorer I can see that framebuffer 1 und 2 are activated and the connector-type of both is set to the hexkey for HDMI. I just have not enough experience to figure it out myself.

Here is my current zipped EFI (deleted AirportItlwm.kext in the zip file to make it a bit smaller for uploading).
you could also try the different SMBIOS as per:
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
29,035
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Any recommendations which alternative SMBIOS I could try?
try all those from the link

also then test each ig-platform
 
Joined
Oct 9, 2022
Messages
5
Motherboard
HP EliteBook 850 G6
CPU
i5-8365U
Graphics
UHD 620
try all those from the link

also then test each ig-platform
Everything else I have set up is correct then?

Edit: No luck so far. I testet my HP G5 USB Dockingstation with both only 1 Displayport or HDMI connected. Power and USB are working. Installed Displaylink Drivers for testing. USB Port is mapped as "typeC+SW". No Display output aswell, maybe the problem is somewhere else?
 
Last edited:
Joined
Mar 6, 2011
Messages
289
Motherboard
Asus TUF Z690 Plus D4
CPU
i9-12900K
Graphics
RX 6900 XTXH (spoofed)
Mobile Phone
  1. Android
  2. iOS
Everything else I have set up is correct then?

Edit: No luck so far. I testet my HP G5 USB Dockingstation with both only 1 Displayport or HDMI connected. Power and USB are working. Installed Displaylink Drivers for testing. USB Port is mapped as "typeC+SW". No Display output aswell, maybe the problem is somewhere else?
try this config changed device properties
 

Attachments

  • config.plist.zip
    6.5 KB · Views: 27
Joined
Oct 9, 2022
Messages
5
Motherboard
HP EliteBook 850 G6
CPU
i5-8365U
Graphics
UHD 620
WoW you are a genius!! HDMI is working now, thank you so much!

Please tell me, there are several numbers at framebuffer-con1-alldata=01010900 00080000 C7010000 02020A00 00040000 C7010000

What do they mean and do?
 
Joined
Mar 6, 2011
Messages
289
Motherboard
Asus TUF Z690 Plus D4
CPU
i9-12900K
Graphics
RX 6900 XTXH (spoofed)
Mobile Phone
  1. Android
  2. iOS
WoW you are a genius!! HDMI is working now, thank you so much!

Please tell me, there are several numbers at framebuffer-con1-alldata=01010900 00080000 C7010000 02020A00 00040000 C7010000

What do they mean and do?
Because con1 can't be recognised with the usual frame buffer it as to be changed with alldata=.I had the same problem with my HP Laptop. now I use thunderbolt with a Apple thunderbolt to HDMI work great plus I get High Dynamic Range.
 
Top