Contribute
Register

HDMI not working on Intel HD4600 Mobile laptop 10.12.6

Joined
Apr 27, 2014
Messages
72
Motherboard
Intel HM87 Chipset
CPU
i7 4810MQ
Graphics
Intel hd 4600 + Nvidia gtx870m 3GB
Hi all!

I have a MSI Dominator GT60 2PC laptop, running Sierra 10.12.6.
Full specs:
Msi GT60 Dominator 2PC
i7 4810MQ
Intel HD 4600
GTX 870M 3GB
16GB Ram
700GB 2 SSD.
Intel HM87 Chipset


I have everything working on it, except HDMI output. I tried to disable the Nvidia discrete GPU but its too hard for me. ( Check https://www.tonymacx86.com/threads/any-problem-after-installed-sierra-in-asus-n550lf.208451/post-1430482 )

Now, i got a monitor and i want to use this laptop with Dual Screen, but the HDMI output its not working. I tried everything from this forum and from insanely mac, and still no luck. In windows the HDMI is recognised on the Nvidia Board, its that a problem?

I will put my EFI files here, and IOREG.

Thanks!

Late Edit: I also have 2 MiniDisplay Ports. Its any difference between HDMI and MiniDisplay port?
 

Attachments

Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
9,081
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
Hi all!

I have a MSI Dominator GT60 2PC laptop, running Sierra 10.12.6.
Full specs:
Msi GT60 Dominator 2PC
i7 4810MQ
Intel HD 4600
GTX 870M 3GB
16GB Ram
700GB 2 SSD.
Intel HM87 Chipset


I have everything working on it, except HDMI output. I tried to disable the Nvidia discrete GPU but its too hard for me. ( Check https://www.tonymacx86.com/threads/any-problem-after-installed-sierra-in-asus-n550lf.208451/post-1430482 )

Now, i got a monitor and i want to use this laptop with Dual Screen, but the HDMI output its not working. I tried everything from this forum and from insanely mac, and still no luck. In windows the HDMI is recognised on the Nvidia Board, its that a problem?

I will put my EFI files here, and IOREG.

Thanks!
i have moved your post to laptop support
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
192,090
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi all!

I have a MSI Dominator GT60 2PC laptop, running Sierra 10.12.6.
Full specs:
Msi GT60 Dominator 2PC
i7 4810MQ
Intel HD 4600
GTX 870M 3GB
16GB Ram
700GB 2 SSD.
Intel HM87 Chipset


I have everything working on it, except HDMI output. I tried to disable the Nvidia discrete GPU but its too hard for me. ( Check https://www.tonymacx86.com/threads/any-problem-after-installed-sierra-in-asus-n550lf.208451/post-1430482 )

Now, i got a monitor and i want to use this laptop with Dual Screen, but the HDMI output its not working. I tried everything from this forum and from insanely mac, and still no luck. In windows the HDMI is recognised on the Nvidia Board, its that a problem?

I will put my EFI files here, and IOREG.

Thanks!

Late Edit: I also have 2 MiniDisplay Ports. Its any difference between HDMI and MiniDisplay port?
It is likely your HDMI port is connected to the Nvidia.
Check in Windows.
 
Top