Contribute
Register

HDMI Audio working with AppleALC & Catalina, but it removes the MAC PRO Soundcard? - HELP!

Joined
Sep 28, 2020
Messages
29
Motherboard
CPU
CPU
Intel
Graphics
GeForce
Hi, just to mention I'm not using Clover.

I'm on Catalina 10.15.7 on a MAC PRO 2008 3.1, with a Geforce GTX 680, plus a factory GFX card (so i can also see boot options etc). I was trying to add some kexts to make the HDMI of the GTX680 work, and so I stumbled on AppleALC, WateverGreen & Lilu kexts.

With kext utility and some Terminal commands, I've managed to get all three to load up, and the HDMI to work. However, the internal mac sound card i/outputs have now vanished!

The system i think recognises both cards now. But only on Hackintool - not on the Audio pane of the system report.

Id like to carry on without using Clover, as I'm not too familiar.

Anyway to make this work?

Btw, the internal soundcard of the MAC PRO DOES comes back alive if i remove the kexts from System/Library/Extensions and i use kext utility to recache and repair permissions etc. Although this of course gets rid of the HDMI output as well.

Somehow AppleALC.kext seems to makes the internal soundcard disappear and leaves me with only the HDMI usable.

WhateverGreen & Lilu don't do seem to do anything, and i guess i just need AppleALC.kext only. But will leave all 3 installed for now, until i can be told better :)

According to hackintool my internal sound card is a 0x8086269A Device, 0x00000000 Sub Device, 0x10EC0885 Codec, 0x000 Revision, Realtek ALC885

and a HDMI one for a 0x10DE0E0A Device, 0x38420969 Sub Device, 0x10DE0040 Codec, 0x0000 Revision, Nvidia GTX680 HDMI
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi, just to mention I'm not using Clover.

I'm on Catalina 10.15.7 on a MAC PRO 2008 3.1, with a Geforce GTX 680, plus a factory GFX card (so i can also see boot options etc). I was trying to add some kexts to make the HDMI of the GTX680 work, and so I stumbled on AppleALC, WateverGreen & Lilu kexts.

With kext utility and some Terminal commands, I've managed to get all three to load up, and the HDMI to work. However, the internal mac sound card i/outputs have now vanished!

The system i think recognises both cards now. But only on Hackintool - not on the Audio pane of the system report.

Id like to carry on without using Clover, as I'm not too familiar.

Anyway to make this work?

Btw, the internal soundcard of the MAC PRO DOES comes back alive if i remove the kexts from System/Library/Extensions and i use kext utility to recache and repair permissions etc. Although this of course gets rid of the HDMI output as well.

Somehow AppleALC.kext seems to makes the internal soundcard disappear and leaves me with only the HDMI usable.

WhateverGreen & Lilu don't do seem to do anything, and i guess i just need AppleALC.kext only. But will leave all 3 installed for now, until i can be told better :)

According to hackintool my internal sound card is a 0x8086269A Device, 0x00000000 Sub Device, 0x10EC0885 Codec, 0x000 Revision, Realtek ALC885

and a HDMI one for a 0x10DE0E0A Device, 0x38420969 Sub Device, 0x10DE0040 Codec, 0x0000 Revision, Nvidia GTX680 HDMI
Clover is not for real mac's

and the kexts you are trying to use are not required on a real mac either
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,335
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
the kexts you are trying to use are not required on a real mac either
May be time for the OP to upgrade to something newer than a 2008 MP. Trying to run an OS it was never designed for with kexts from 3rd party sources is a recipe for disaster or at least failure.
 
Joined
Sep 28, 2020
Messages
29
Motherboard
CPU
CPU
Intel
Graphics
GeForce
the kexts you are trying to use are not required on a real mac eithe

Well, they seem to be required as otherwise no way of getting HDMI audio out of my GTX680!

May be time for the OP to upgrade to something newer than a 2008 MP. Trying to run an OS it was never designed for with kexts from 3rd party sources is a recipe for disaster or at least failure.

I wish the money was there to do so, alas.. but at the same time, the recipe for disaster is only if i'll lose data, which rest assured all is well and backed up. And by the way, I'm not the only one required to do so, and worst, such as installing thunderbolt 3 on a MAC PRO 3.1/5.1 etc.

Plenty of life left in the MAC as well with a Sonnet Tempo dual SSD config (though not using this for Catalina just yet)

Can you give an insight to help to make it work instead, please?
 
Joined
Sep 28, 2020
Messages
29
Motherboard
CPU
CPU
Intel
Graphics
GeForce
Clover is not for real mac's

and the kexts you are trying to use are not required on a real mac either

In addition, on Sierra I used the HDMIAudio.kext (v 1.1) to make the HDMI audio working, but unfortunately this kext no longer works in Catalina. Which is why I resorted to using the AppleALC one, as at least I could get it to work with that - even though this seems to disable the internal soundcard of the mac as well.

If there are better kexts to use to achieve what i'm after, please also feel free to comment.
Thanks!
 
Joined
Sep 28, 2020
Messages
29
Motherboard
CPU
CPU
Intel
Graphics
GeForce
Clover is not for real mac's

and the kexts you are trying to use are not required on a real mac either

By the way, any reason you moved my post from the HDMI audio section of the forum?

I think my question is more relevant to making the HDMI Audio work alongside my other internal soundcard.

I think it will get better exposure there.

Can you move it back, please?

As it is also placed under Infinite Loop, and this is not correct... I'm not stuck in infinite loop upon boot.
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,335
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
but at the same time, the recipe for disaster is only if i'll lose data, which rest assured all is well and backed up.
There are many documented cases of people using Clover on Mac systems that have completely bricked them, that's why I used the word disaster. You might not lose data but could lose your 2008 Mac Pro.

If you have to have working HDMI audio I'd say your best chance is to use a newer supported AMD or Nvidia card than what you currently have. Try a low cost GT 710 or an AMD RX 460 or other Polaris based AMD card. I'm not saying it's guaranteed to work but certainly worth trying.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
23,354
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
In addition, on Sierra I used the HDMIAudio.kext (v 1.1) to make the HDMI audio working, but unfortunately this kext no longer works in Catalina. Which is why I resorted to using the AppleALC one, as at least I could get it to work with that - even though this seems to disable the internal soundcard of the mac as well.

If there are better kexts to use to achieve what i'm after, please also feel free to comment.
Thanks!
wouldn't have thought any hackintosh kexts would be needed on a real mac.......
 

trs96

Moderator
Joined
Jul 31, 2012
Messages
20,335
Motherboard
GA-Z97X-UD3H-BK
CPU
i5-4690K
Graphics
HD4600 / RX 570
Mac
  1. MacBook Pro
  2. Mac mini
Mobile Phone
  1. Android
We don't support those that have used the dosdude1 patcher on real Macs to run unsupported macOS versions. It's probably best that you seek help from that community rather than here.
 
Joined
Sep 28, 2020
Messages
29
Motherboard
CPU
CPU
Intel
Graphics
GeForce
There are many documented cases of people using Clover on Mac systems that have completely bricked them, that's why I used the word disaster. You might not lose data but could lose your 2008 Mac Pro.

If you have to have working HDMI audio I'd say your best chance is to use a newer supported AMD or Nvidia card than what you currently have. Try a low cost GT 710 or an AMD RX 460 or other Polaris based AMD card. I'm not saying it's guaranteed to work but certainly worth trying.

I insist, no money to spend on a perfectly working machine, otherwise. It just seems a question of injecting or configuring the right software or drivers (kext) to make it all work, as this used to be the case with Sierra & HDMIAudio.kext

But also, as I already upgraded the GFX card to the most compatible for a MACPRO 3.1, namely the flashed EVGA GTX680, as recommended elsewhere.
 
Top