Contribute
Register

HDMI Audio with volume control

Status
Not open for further replies.
Joined
Oct 18, 2011
Messages
12
Motherboard
GA-Z77N-Wifi
CPU
i5 3570k @ 4.2
Graphics
Zotaz GTX 660
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
Hi there fellow hackintoshers, just to keep it short here.

I'm using HDMI Audio output on my new samsung monitor, for my headset, because the electronical noise i my front audio ports on my fractal is LOUD!

But as you know, you can't control the volume on HDMI.

Installed the software "Soundflower" (clearly outdated) but that thing is just so shaky in Yosemite, sometimes youtube videos can't play at all, and sometimes you have to re-asign sound flower to HDMI output after just one hour, or on every boot.

Was getting tired of this.

SO TADAAAAA!! found this software "Sound Siphon" and its up-to-date!!

Just download the FREE DEMO
Install.
Restart (the app automatically sets Sound Siphon as standard sound output).
Then open the application.
click CANCEL to License code.
go to the top bar.
Press "sound Siphon".
Press "Preferences".
and chose HDMI under "Pass through device".

And your good to GO!!
 
Joined
Jul 29, 2011
Messages
182
Motherboard
Gigabyte Z490 UD AC
CPU
i7 10700k
Graphics
RX 5500 XT
Mac
  1. MacBook Pro
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
I worked very well, I have been dreaming about that, but the only problem with me it losses the DTS & Dolby I have to change the audio output source overtime I need DTS or Dolby, but as far as now fair enough.

Thanks
 
Joined
Sep 12, 2013
Messages
2
Motherboard
Gigabyte H77n-Wifi
CPU
core i7-3770
Graphics
GeForce GTX660
Mac
Classic Mac
Mobile Phone
Hi,
Work well,
but when Sound Siphon is ENABLED,
then Sleep and deep-sleep, even screensaver don't work at all.
Look at that :

WITH Sound Siphon Enabled :

pmset -g
Active Profiles:
AC Power -1*
Currently in use:
hibernatemode 0
womp 0
networkoversleep 0
sleep 2 (sleep prevented by coreaudiod, coreaudiod)
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 1 (display sleep prevented by coreaudiod)

With Sound Siphon Disabled :
pmset -g
Active Profiles:
AC Power -1*
Currently in use:
hibernatemode 0
womp 0
networkoversleep 0
sleep 2
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 1​

So not really solved.
Hope this help.
Regards
Zavatar69,
 
Joined
Jan 17, 2014
Messages
36
Motherboard
MSI Z87-GD65
CPU
i7-4770k
Graphics
NVIDIA GeForce RTX 2080
Thanks, it worked for me, great solution! :thumbup:
 
Joined
Feb 12, 2016
Messages
32
Motherboard
GA Z97M D3H
CPU
i5 4690
Graphics
intel HD 4600
Mac
Classic Mac
  1. iMac
Mobile Phone
Hi,
Work well,
but when Sound Siphon is ENABLED,
then Sleep and deep-sleep, even screensaver don't work at all.
Look at that :

WITH Sound Siphon Enabled :

pmset -g
Active Profiles:
AC Power -1*
Currently in use:
hibernatemode 0
womp 0
networkoversleep 0
sleep 2 (sleep prevented by coreaudiod, coreaudiod)
Sleep On Power Button 1
ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 1 (display sleep prevented by coreaudiod)

With Sound Siphon Disabled :
pmset -g
Active Profiles:
AC Power -1*
Currently in use:
hibernatemode 0
womp 0
networkoversleep 0
sleep 2
Sleep On Power Button 1

ttyskeepawake 1
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 1​

So not really solved.
Hope this help.
Regards
Zavatar69,


actually I'm using sound control (a lite version of sound siphon). It's nice to manage the volume from my keyboard, but I have the same problem: the hackintosh doesn't go to sleep.

with sound control on:
$ pmset -g assertions | grep PreventUserIdleDisplaySleep
PreventUserIdleDisplaySleep 1
pid 209(coreaudiod): [0x0000557d00050208] 00:04:16 PreventUserIdleDisplaySleep named: "com.apple.audio.AppleHDAEngineOutputDP:3,0,1,0:0:{6904-23E1-000032D3}.context.preventuseridledisplaysleep"

$ pmset -g | grep sleep
networkoversleep 0
sleep 10 (sleep prevented by coreaudiod, coreaudiod)
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 10 (display sleep prevented by coreaudiod)

with sound control off:
$ pmset -g assertions | grep PreventUserIdleDisplaySleep
PreventUserIdleDisplaySleep 0

$ pmset -g | grep sleep
networkoversleep 0
sleep 10
hibernatefile /var/vm/sleepimage
disksleep 10
displaysleep 10

I have no idea to fix this.
 
Joined
May 19, 2016
Messages
11
Motherboard
MSI H97 GAMING 3
CPU
i7-4790K
Graphics
GTX 960
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
worked like a charm using this method

- Search and download for: Soundflower-1.6.6b.dmg;
- Install then click customize,tick "install soundflowerbed.app" only;
- Now, download and install Soundflower-2.0b2.dmg;
- Click on sound icon (topbar) and enable: Soundflower (2ch);
- Open Soundflower app and set "HDMI" under "Soundflower (2ch);
- Go to your Login Items then add Soundflowerbed.app on your Users

Enjoy!
 
Status
Not open for further replies.
Top