Contribute
Register

HDMI audio iGPU OpenCore (Easy) Solution

Joined
Feb 5, 2011
Messages
55
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
UHD 630
Mobile Phone
  1. Android
layout-id should be the same you use as boot args. Also, If you have an Hasswel (older) CPU you cannot spoof an Skylake (newer) Audio ID. Used device-id is specific for UHD 630 graphics, will not work with other iGPU's
 
Joined
Feb 5, 2011
Messages
55
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
UHD 630
Mobile Phone
  1. Android
I updated my iMac20,1 hackintosh to Monterey and I had to give-up to FakePCIID method for DP / HDMI Audio out via Intel UHD 630.

FakePCIID method still worked with Monterey, but it causes random restarts and, to solve the problem, I had to remove the kexts, as advised here:

Now, in order to get DP / HDMI Audio out working via Intel UHD 630 i reverted to VoodooHDA OC method, that I manage to get it working using this guide:

Necessary files to be used with above mentioned guide:
  1. VoodooHDA OC 2.9.2 installer: https://github.com/chris1111/VoodooHDA-OC
  2. VoodooHDA 2.9.7 kext update: check first post from https://www.insanelymac.com/forum/topic/314406-voodoohda-297/
 

Attachments

  • Intel_UHD630_HDMI_Audio.png
    Intel_UHD630_HDMI_Audio.png
    207.6 KB · Views: 97
Joined
Jan 20, 2022
Messages
1
Motherboard
asus maximus hero viii
CPU
intel i7 6700k
Graphics
intel hd 530
using this i had solved my Hdmi issue... now internal HDMI is working on my Skylake Intel 530 system using HACKINTOOL.

using no fakepciid or Voodoo anyother extra kext, JUST Applealc kext. And after 1 week i was able to find the solution
mainly changing DP to HDMI solves my problem.
 
Joined
Feb 7, 2022
Messages
10
Motherboard
hp-15 AB21ATX
CPU
i5 5500u
Graphics
HD 5500
Hi, someone could help with HDMI settings. I've tried a lot but it doesn't work. Intel i5 5200u Cpu HD 5500 Broadwell Graphics. BigSur 11.5.2 Hp 15 ac10nh laptop.
 
Joined
Feb 7, 2022
Messages
10
Motherboard
hp-15 AB21ATX
CPU
i5 5500u
Graphics
HD 5500
Hi, someone could help with HDMI settings. I've tried a lot but it doesn't work. Intel i5 5200u Cpu HD 5500 Broadwell Graphics. BigSur 11.5.2 Hp 15 ac10nh laptop.
 

Attachments

  • IMG_0160.jpeg
    IMG_0160.jpeg
    4.2 MB · Views: 42
  • IMG_0159.jpeg
    IMG_0159.jpeg
    3.8 MB · Views: 43
  • IMG_0158.jpeg
    IMG_0158.jpeg
    7.4 MB · Views: 42
Joined
Feb 7, 2022
Messages
10
Motherboard
hp-15 AB21ATX
CPU
i5 5500u
Graphics
HD 5500
it's pretty interesting what I got. I tried the existing total solution to make the HDMI audio output work. Se a Hackintool se Voodoo hda. i also try the framebuffer settings, nothing. There was no picture sound. Then I tried an old method with the AppleHDA patch, which finally brought the solution. Generates a DummyHDA kext that just needs to be inserted into the kext folder
 
Top