Contribute
Register

HDMI audio iGPU OpenCore (Easy) Solution

Joined
Dec 3, 2016
Messages
9
Motherboard
GA-Z170X-UD3
CPU
i7 << need model # >> See Forum Rules !!
Graphics
GT 740
I prefer ProperTree for editing config.plist files. It is easy to use and it has good features for auto-editing. ProperTree can open multiple plist files at the same time for copying and pasting across files. You may download it here:
Thanks for the answer! But I really didn't understand how it works. Where do I place the code generated by Hackintools? In the proper tree there is no terminal window to enter the code.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,018
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks for the answer! But I really didn't understand how it works. Where do I place the code generated by Hackintools? In the proper tree there is no terminal window to enter the code.
hackintool can copy the info into your config.plist for you

click file - export and choose your config.plist
 
Joined
Dec 3, 2016
Messages
9
Motherboard
GA-Z170X-UD3
CPU
i7 << need model # >> See Forum Rules !!
Graphics
GT 740
hackintool can copy the info into your config.plist for you

click file - export and choose your config.plist
Thanks for the tip! I thought I did everything right ... the code was added, but it didn't work for me. I still do not have AUDIO HDMI on the two systems "Sierra" and Catalina ", before installing Catalina, HDMI audio worked on Sierra. :\
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
26,018
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Thanks for the tip! I thought I did everything right ... the code was added, but it didn't work for me. I still do not have AUDIO HDMI on the two systems "Sierra" and Catalina ", before installing Catalina, HDMI audio worked on Sierra. :\
not sure

but sometimes adding FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext can help
 
Joined
Dec 3, 2016
Messages
9
Motherboard
GA-Z170X-UD3
CPU
i7 << need model # >> See Forum Rules !!
Graphics
GT 740
Joined
Aug 5, 2016
Messages
30
Motherboard
Gigabyte Z690i Aorus Ultra DDR4
CPU
i5-12400
Graphics
RX560
Mac
  1. iMac
not sure

but sometimes adding FakePCIID.kext and FakePCIID_Intel_HDMI_Audio.kext can help
If you are using Lilu and AppleALC as your audio engine on Big Sur or Catalina, you should not use FakePCIID_Intel_HDMI_Audio.kext as it doesn't work with AppleALC and it interferes with Lilu audio support. Check your library and delete any other competing audio drivers such as VoodooHDA. Then try the method I mentioned on Posting 1. For the technical information on getting HDMI audio work, see here:
(PS, I've been trying to keep this how-to simple and avoid in-depth technical discussion:)).
 
Last edited:
Joined
Dec 3, 2016
Messages
9
Motherboard
GA-Z170X-UD3
CPU
i7 << need model # >> See Forum Rules !!
Graphics
GT 740
Did not work! And it was giving error in the BOOT "Could not get SMCProvide". It was a torment to get in again. But thanks!
 
Joined
Aug 5, 2016
Messages
30
Motherboard
Gigabyte Z690i Aorus Ultra DDR4
CPU
i5-12400
Graphics
RX560
Mac
  1. iMac
Did not work! And it was giving error in the BOOT "Could not get SMCProvide". It was a torment to get in again. But thanks!
For trouble shooting your problem, could you post your config.plist file? Of course, please delete/mask your system ID's in the Platforminfo section (i.e., MLB, SystemUUID, SystemSerialNumber).
 
Joined
Feb 5, 2011
Messages
55
Motherboard
Gigabyte Z490M Gaming X
CPU
i7-10700K
Graphics
UHD 630
Mobile Phone
  1. Android
I solved my problem with DisplayPort audio out by switching from AppleALC to chris1111's VoodooHDA-OC.

Details in this post.
 
Joined
Mar 27, 2021
Messages
1
Motherboard
Gigabyte Z490 UD
CPU
i7 10700K
Graphics
Intel UHD 630
I recently built a new Hack rig with Asus z490i gaming MB and i7-10700 by using OpenCore boot loader. I use Intel's built-in GPU as the sole display driver and I don't have a dedicated video card. I use a Samsung 27 inch TV as my monitor and connect my rig to it with an HDMI cable. The installation with OpenCore went fairly smooth. However, the audio via HDMI didn't work. I spent several days reading hack sites and hoped to find an easy (non-tech) solution, in vain. Not wanting to give up, I kept testing and finally figured out an easy solution to get HDMI audio work. After I got my z490i gaming rig HDMI audio work, I converted my z370N/i5-8400 from Clover to OpenCore. Using the same simple solution, HDMI audio on my z370N/i5-8400 also worked. My z490i gaming/i7-10700 is running on Big Sur 11.1 and my z370N/i5-8400 is running on Catalina 10.15.7 (19H114). I'd like to share my HDMI audio solution so that others in a similar situation can quickly get their iGPU HDMI audio work. Below are the steps I took to get iGPU's HDMI audio work:

1. Find the device ID for your iGPU on Intel website (https://ark.intel.com). For example, for my i7-10700, its iGPU graphics device id is 0x9BC5. For my i5-8400, its iGPU graphics device id is 0x3E92. Note: In OpenCore lingo, device id is expressed in hex. In my case, my i7-10700's iGPU device id in OpenCore config.list is C59B0000, and my i5-8400's iGPU device id is 923E0000 in OpenCore config.plist.

2. Use Headkaze's Hackintool (https://github.com/headkaze/Hackintool) to generate the audio and video definitions of DeviceProperties by specifying device-ID (e.g., i7-10700 device id =0x9BC5). In my case, below are audio and video definitions for my z490i gaming MB automatically generated by Hackintool:


View attachment 502551


View attachment 502552

3. Copy and paste the above DeviceProperties definitions generated by Hackintool into OpenCore config.plist. My iGPU HDMI audio now works. Your device properties will be different from mine, depending on the model of your motherboard. However, the concept and method will be the same to get your HMDI audio work.

I've been trying this method with no luck. any chance you could post your config.plist?
I have similar HW - GA Z490 UD, i7 10700K, Intel UHD 630
 
Last edited:
Top