Contribute
Register

HDMI audio doesn't work with intel HD graphics 630 in Catalina 10.15.4

Joined
Jun 16, 2019
Messages
9
Motherboard
Gigabyte GA-H110M-S2H
CPU
i3-7100
Graphics
Intel HD Graphics 630 7 MB
Mac
Mac mini, Mac Pro
Mobile Phone
Android, iOS
this is my low cost build:
CPU: Intel Core i3-7100 3.9GHz 3MB
MB: Gigabyte GA-H110M-S2H
Internal GPU: Intel HD Graphics 630 7 MB
NO dedicated GPU

i instal macOS Catalina 10.15.4 and everything work (maybe).
But I connect a samsung monitor (I use HDMI-HDMi cable) and the computer doesn't see the HDMI monitor, so I can't use HDMI audio.
What can I do for this problem?
what can I change (in config.plist and in kext) to make the computer work better?

I added all the necessary files (I hope): config.plist, screenshot of kext, and the entire EFI folder.
 

Attachments

Last edited:

UtterDisbelief

Moderator
Joined
Feb 13, 2012
Messages
4,419
Motherboard
Gigabyte Z390M Gaming
CPU
i5-9600K
Graphics
RX 570
Mac
iMac, Mac mini
Classic Mac
eMac, iBook
Mobile Phone
iOS
this is my low cost build:
CPU: Intel Core i3-7100 3.9GHz 3MB
MB: Gigabyte GA-H110M-S2H
NO GPU

i instal macOS Catalina 10.15.4 and everything work (maybe).
But I connect a samsung monitor and the computer doesn't see the HDMI monitor, so I can't use HDMI audio.
What can I do for this problem?
what can I change (in config.plist and in kext) to make the computer work better?
Hi there,

Please complete your hardware profile. I believe your CPU has an HD630 Intel iGPU. Without being able to see this information other readers will not he able to help you :thumbup:

How are you connecting your monitor to give you output for that screengrab?

Which kexts do you have installed in the EFI folder and L/E ?

:)
 
Joined
Jun 16, 2019
Messages
9
Motherboard
Gigabyte GA-H110M-S2H
CPU
i3-7100
Graphics
Intel HD Graphics 630 7 MB
Mac
Mac mini, Mac Pro
Mobile Phone
Android, iOS
Hi there,

Please complete your hardware profile. I believe your CPU has an HD630 Intel iGPU. Without being able to see this information other readers will not he able to help you :thumbup:

How are you connecting your monitor to give you output for that screengrab?

Which kexts do you have installed in the EFI folder and L/E ?

:)
I made the changes, I hope I've put everything necessary to be helped
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,556
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
Please try this EFI.
 

Attachments

Joined
Jun 16, 2019
Messages
9
Motherboard
Gigabyte GA-H110M-S2H
CPU
i3-7100
Graphics
Intel HD Graphics 630 7 MB
Mac
Mac mini, Mac Pro
Mobile Phone
Android, iOS
Please try this EFI.
with clover configurator I deleted my efi, and I put your efi.. and this is the result... (screen)
computer stop with the apple logo and some white words..
how I can solve this problem? how can I reuse the computer normally? the computer doesn't turn on so I can't change the efi again...
 

Attachments

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,556
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
with clover configurator I deleted my efi, and I put your efi.. and this is the result... (screen)
computer stop with the apple logo and some white words..
how I can solve this problem? how can I reuse the computer normally? the computer doesn't turn on so I can't change the efi again...
Please try this one.
 

Attachments

Joined
Jun 16, 2019
Messages
9
Motherboard
Gigabyte GA-H110M-S2H
CPU
i3-7100
Graphics
Intel HD Graphics 630 7 MB
Mac
Mac mini, Mac Pro
Mobile Phone
Android, iOS
I tried the new efi, but same problem
apple logo blocked with some white words...
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,556
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
how? the computer doesn't turn on. without the computer on I can't change efi
Put it on the EFI partition of a USB flash drive and boot from the USB flash drive.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
14,556
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.1GHz
Graphics
Radeon VII
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I tried the new efi, but same problem
apple logo blocked with some white words...
The text is exactly the same as the one you posted on post #5?
 
Top