Contribute
Register

HD530 + Nvidia card to support both Mojave and Windows. Anyone?

Status
Not open for further replies.
Joined
Mar 4, 2011
Messages
32
Motherboard
Gigabyte GA-Z170X-Gaming 5
CPU
i7 6700K
Graphics
GTX 980 Ti
Mobile Phone
  1. iOS
Hello guys, it's a couple of weeks that I'm struggling to let my internal HD530 to works correctly alongside my nVidia card.

The actual situation

My build is based on a Skylake 6700k, on a Gigabyte GA-Z170X-Gaming 5, a Zotac 980Ti AMP extreme, 3 different SSD with High Sierra, Mojave, Windows on board.
I recently upgrade my rig with a 21:9 monitor (3440x1440 144hz) so, for gaming purposes, I'm planning to upgrade also the GPU.
On the MacOS partition I basically use Logic Pro X and Lightroom, so ther is no real needs for an high performance GPU, and to fully support Mojave the integrated GPU would be enough, and this will let me free to purchase an RTX to use with Windows partition.

The goal

The goal is to let OSX use only HD530 and windows only the discrete GPU (by disabling in devices hd530).
To have a decent display refresh on osx, I have to use the integrated DP (instead of HDMI) of my mobo, and here starts the problems.

The issues

By setting in the bios IGPU on and giving boot priority to it, I'm able to boot on both HS and Mojave, but only with Intel injection, platform id 19128086 and nv_disable=1 on clover.
This would be fine, but only the HDMI connector is working in that configuration: the DP port is black and I have no response on it.
I would like to avoid integrated HDMI, due my refresh is limited to 50hz.
If i change platform ID to 19120001, the connector works, but I have no acceleration and only 7MB of vram shown.
I also tried to use lilu + whatevergreen, but in that case I'm not able to boot (black screen/freeze).

Does anyone have succeded in a similar scenario?
 
Status
Not open for further replies.
Top