Contribute
Register

HD4600 Tearing Problems

Joined
Feb 4, 2014
Messages
113
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 780 Ti
To get straight to the problem: This is what happens when I scroll a site or use the active corners on my desktop:





Here are my system specs:

MB: GA Z87M-D3H
CPU: Intel i7 4770K
GPU: 4770K's 4600 HD IGFX
RAM: Kingston Hyper X Black 2 x 4 GB @ 1600 MHz
SSD: Crucial MX100 512GB optimized with Chameleon SSD optimizer

I had no problems with 10.9.5, but now that I'm on Yosemite, I get these graphical problems rather often, usually when I'm exploring websites.

Any advice on what I should do? If I need to provide any other files so that you're able to help me, please tell me.
 
Joined
Feb 4, 2014
Messages
113
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 780 Ti
Not sure if it helps, but here are my ioregistry and boot.plist files:

View attachment system.ioreg

View attachment org.chameleon.Boot.plist

BTW, I'm using the HDMI out on my motherboard into the HDMI input on my Asus Full HD Monitor. The HDMI cable quality is nothing special, but it worked for 10.9.5 flawlessly.

Also, this is what I find under system information:Intel HD Graphics 4600 1536 MB

Seems like the mackintosh is recognizing the HD4600 GPU correctly, if 1536MB is the standard vram value.

Is this tearing issue maybe related to QE/CI failures?
 
Joined
Dec 17, 2012
Messages
179
Motherboard
GA-Z87-HD3
CPU
i5-4670
Graphics
Intel 4600
Mac
MacBook Pro
Mobile Phone
iOS
I believe a test is to open Chess. If you can and the game works properly, QE/CI is working. Someone correct me if I'm wrong.

I can't say anything to the effect of Chimera with Yosemite as I switched to clover with 10.9.5. I'm using clover with id-injection for HD 4600 if you decide to switch. HD4600 works perfectly for me on 10.10.
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,576
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
I think the OPs experiencing an issue where is Intel HD graphics have not loaded. The first thing is to try to change the command GraphicsEnabler=Yes to GraphicsEnabler=No.

There are things that can be done to remedy the problem. Glad that Clover is working fine for you though.
 
Joined
Feb 4, 2014
Messages
113
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 780 Ti
Can you change GraphicsEnabler=Yes to No in your org.chameleon.plist then reboot and report back.
I changed the GraphicsEnabler from Yes to No and I've added the dart=0 kernel flag option as well (the vt-d option in the BIOS was a greyed out yes, so that's why I wanted to make 100% sure that it's turned off now).

I've rebooted the Hackintosh a couple of times and the obvious screen tears don't seem to appear. However, what I've still noticed is the blur quality of the login screen and the background representation of the desktop once I use some of the hot corners. The blur quality on my other system with a dedicated Nvidia GPU (780 Ti) is much better. On the problem case hackintosh, the quality is comparable to geographical height maps like this:



The differences between the color transitions are not really smooth, but rather distinct.

I've also tried the chess application and I could play a game without problems, once I start to rotate the chess board horizontally some lag is occurring. All in all, I feel the graphical part of the system is just not operating as smoothly as it did before.

Is there anything else I could try?
 
Joined
Aug 21, 2014
Messages
7
Motherboard
Gigabyte GA-Z97X-UD3H
CPU
Intel Core i5 4690K
Graphics
Intel HD4600
Mac
Classic Mac
Mobile Phone
Same problem here, with my GA-Z97X-UD3H motherboard (9 series).

I have a dual monitor setup: 1 on HDMI, 1 on DVI. The issue only seems to happen with the HDMI monitor, with Chrome (doesn't seem to happen on Safari) and with the Launchpad. I haven't seen the tearing issue on other apps (quite hard to be sure, as it seems to appear randomly).

Here's a video showing the tearing on Chrome browser, when I move the mouse over many links on a Facebook page.
First the DVI monitor (on the right), then the HDMI one (on the left), and back then to the DVI one :



Have full QE/CI support. I'm using Clover v2953 (the last one), with Graphics / Inject Intel / true. I tried to set the ig-platform-id attribute to 0x0D220003, no change at all. I also tried to inject EDID, but still no change.

I've had no issue at all with Mavericks.
 
Joined
Feb 4, 2014
Messages
113
Motherboard
Gigabyte Z390 Designare
CPU
i9-9900K
Graphics
GTX 780 Ti
There is a bug that may be causing this. Updated UniBeast and MultiBeast will soon be available. If you are in a hurry to fix this then suggest that you look at Chameleon Wizard for setting your Intel HD graphics.
Once then new unibeast and multibeast are released, will I need to reinstall Yosemite or would i merely need to change some settings with the new multibeast?

About the chameleon wizard: What settings could i specifically try in chameleon wizard to fix this problem?
 

Adrian B

Moderator
Joined
Mar 18, 2012
Messages
7,576
Motherboard
Gigabyte GA-B75M-HD3
CPU
i7-3770
Graphics
HD 5570
Mac
iMac, MacBook Pro
Mobile Phone
Other
Once then new unibeast and multibeast are released, will I need to reinstall Yosemite or would i merely need to change some settings with the new multibeast?
It would probably just mean updating the Chimera Bootloader. Chimera 4.0 was built with some particular items to boot Yosemite - so an older version will not fix the issue. Details would be confirmed on release.

About the chameleon wizard: What settings could i specifically try in chameleon wizard to fix this problem?
It might be better to do a complete load of all the settings for the org.chameleon.Boot.plist that you need and the boot loader as these two apps do integrated graphics very differently. You are using Intel HD4600 which would be the 'Intel Azul FB' option under graphics. You do not need to update the SMBios settings. I will repeat you must also remember to use the Chameleon Bootloader as well.
 
Top