Contribute
Register

[HD 530] Not responding applications after sleep

Joined
May 17, 2012
Messages
22
Motherboard
ASUS Z170-Deluxe
CPU
i7-6700K
Graphics
HD 530 & RX 5700
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
Hi!
I'm facing a problem on my notebook.
I have:
Acer Aspire V 15 V5-591G-55TU
Skylake-H PC-H
i5-6300HQ - HD 530 - Skylake
4+4 GB DDR4
optimus GTX 950M (disabled)
BRCM94352Z wifi
Windows 8.1 & High Sierra 10.13.3

Natively sleep isn't working, there is a blank screen after sleep, so I used custom EDID Inject to get it working.
Before sleep, everything is working fine, but after sleep, I couldn't open videos(on youtube or anywhere higher than 240p), pictures, FaceTime.
This is a hardware decode problem, so I opened terminal and typed this:
Code:
defaults write com.apple.coremedia hardwareVideoDecoder disable
After this, Safari and video players could open HD or any videos after sleep, but Chrome not responding (Chrome forced hardware acceleration, and good after disabled that in advanced settings), FaceTime, Preview also not responding, and the pictures on hdd just loading too, nothing happens. Problem exist on all HS versions (13.0 - 13.3). On Sierra 10.12.6 this problem not exists. Here I'll attach informations (ioreg, CLOVER, screenshot). Kext using at boot for skylake: Lilu, IntelGraphicsDVMTFixup, IntelGraphicsFixup.
I'll appreciate any help.
 

Attachments

Joined
May 17, 2012
Messages
22
Motherboard
ASUS Z170-Deluxe
CPU
i7-6700K
Graphics
HD 530 & RX 5700
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS
Can't edit the first post because it says "spam"... So I attaching all the files here. (CLOVER, ioreg, terminal outputs, ssdt-dsdts)
EDIT: ioreg attached
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,976
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi!
I'm facing a problem on my notebook.
I have:
Acer Aspire V 15 V5-591G-55TU
Skylake-H PC-H
i5-6300HQ - HD 530 - Skylake
4+4 GB DDR4
optimus GTX 950M (disabled)
BRCM94352Z wifi
Windows 8.1 & High Sierra 10.13.3

Natively sleep isn't working, there is a blank screen after sleep, so I used custom EDID Inject to get it working.
Before sleep, everything is working fine, but after sleep, I couldn't open videos(on youtube or anywhere higher than 240p), pictures, FaceTime.
This is a hardware decode problem, so I opened terminal and typed this:
Code:
defaults write com.apple.coremedia hardwareVideoDecoder disable
After this, Safari and video players could open HD or any videos after sleep, but Chrome not responding (Chrome forced hardware acceleration, and good after disabled that in advanced settings), FaceTime, Preview also not responding, and the pictures on hdd just loading too, nothing happens. Problem exist on all HS versions (13.0 - 13.3). On Sierra 10.12.6 this problem not exists. Here I'll attach informations (ioreg, CLOVER, screenshot). Kext using at boot for skylake: Lilu, IntelGraphicsDVMTFixup, IntelGraphicsFixup.
I'll appreciate any help.
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
May 17, 2012
Messages
22
Motherboard
ASUS Z170-Deluxe
CPU
i7-6700K
Graphics
HD 530 & RX 5700
Mac
iMac, MacBook Pro
Mobile Phone
Android, iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,976
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,976
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Fixed not responding by adding these fixes to my config.plist:
Also I wrote hardwarevideodecode back to enabled, no problem after sleep so far
Code:
HECI to IMEI
48454349
494d4549

EC0 to EC
4543305f
45435f5f
HECI->IMEI rename is default in the guide plists:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Renaming EC0->EC may not be safe... Depends on whether you have an ECDT in ACPI.
Details here:
https://www.tonymacx86.com/threads/guide-usb-power-property-injection-for-sierra-and-later.222266/
 
Top