Contribute
Register

HD 3000 + GTX 560 Ti - can't get both working

toleda

Moderator
Joined
May 20, 2010
Messages
24,260
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
Still getting KP on boot screen with GraphicEnabler/PCIRootUID tricks when display plugged on the HD3000, and not changing the fact that it is not listed when using the 560Ti.
I was getting the KPs with HD3000 and GTX570 HD. mrbubbles PCIRootUID=0 solved the problem the problem for me. I still get the same error as you do, however, no more KP.

bdmesg:
Using PCI-Root-UID value: 0
nVidia GeForce GTX 570 -4095MB NV1ff [10de:1086] :: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0)
ERROR: dcbtable_version is 0x3
ERROR: nVidia ROM Patching Failed!

It appears you have a HD3000 issue. If it makes sense, remove the 560, set init graphics to onboard and boot HD3000 only. If it won't boot, suggest changing graphics memory to 64MB (OS X ignores this setting anyway).
Screen Shot 2012-09-03 at 4.42.50 PM.png
 
Joined
Sep 17, 2011
Messages
23
Motherboard
GA-Z68MA-D2H-B3
CPU
i7 2600
Graphics
GIGABYTE GTX 560 Ti
Mac
Classic Mac
Mobile Phone
remove the 560, set init graphics to onboard and boot HD3000 only. If it won't boot, suggest changing graphics memory to 64MB (OS X ignores this setting anyway).
View attachment 30446
I'm gonna try that.
If it works what do I need to do next, put the 560 back (and keep PCIRootUID=0) and the system will keep it recognized?
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,260
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
512K, LC, Power Mac
Mobile Phone
iOS
I'm gonna try that.
If it works what do I need to do next, put the 560 back (and keep PCIRootUID=0) and the system will keep it recognized?
In the BIOS, set internal graphics to always enable. You will see GFX0 in IOReg even when a display is not connect. That gives you AirPlay mirroring as well.
 
Joined
May 4, 2012
Messages
57
Motherboard
GA-Z68A-D3H-B3 (UEFI bios, Clover legacy)
CPU
i5-2500k/Z68
Graphics
HD 3000 (2 monitors) + GTX 580 (1 monitor)
Mac
Classic Mac
Mobile Phone
In the BIOS, set internal graphics to always enable. You will see GFX0 in IOReg even when a display is not connect. That gives you AirPlay mirroring as well.
This setting is what had it working for me, no DSDT required at all. I get the occasional graphic artifact (some black lines in the margins of TextEdit and some pretty bad "static"/visual noise rectangles in Safari, but a reboot takes care of them quickly. They take a couples hours to come back, if they do at all.

Overall I'd say HD3000 + GTX 5xx works pretty well.
 
Top