Contribute
Register

Haswell-E + X99 Motherboard Temporary Guide - OS X 10.10

Joined
Feb 11, 2014
Messages
10
Motherboard
Yosemite 10.10.4
CPU
i7 5820k
Graphics
Gigabyte R9 280X
Mac
Classic Mac
Mobile Phone
My Build:

Fatal1ty AsRock x99x Killer.

Gigabyte R9 280x
Intel i7-5820k
16GB Crucial DDR4 RAM.
120GB SSD

followed the guilde here http://www.tonymacx86.com/yosemite-...80-i7-5820k-update-10-10-2-a.html#post1058333 except the video card related steps since my r9 280x works out of box.

most things work pretty well. Audio is fine, video card works out of box, no additional driver/ktex was needed. Single-Core 3094 and multi around 17000. I wanted to know if that's the score to expect for stock frequency.

View attachment 142135

One issue I am currently facing is, whenever the computer goes to sleep. It takes about 1-2 minutes to wake, also the shutdown is slow, about 1 minute for computer to completely shuts off.


Lastly, anyone thinks I should overclock my cpu, cause i saw much higher score after overclocking.

And thanks to everyone who contributes to bring hackintosh to 5820k.
 
Joined
Jul 25, 2013
Messages
423
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
most things work pretty well. Audio is fine, video card works out of box, no additional driver/ktex was needed. Single-Core 3094 and multi around 17000. I wanted to know if that's the score to expect for stock frequency.

I've been able to push it to just above 18000 with XHCI disabled, NullCPUPowerManagement, and Man1c's SSDT.

http://browser.primatelabs.com/geekbench3/2728247
 
Joined
Feb 11, 2014
Messages
10
Motherboard
Yosemite 10.10.4
CPU
i7 5820k
Graphics
Gigabyte R9 280X
Mac
Classic Mac
Mobile Phone
this is at stock frequency right? and i've have search all over the bios setting for my asrock x99 killer board, nowhere i find xhci setting...maybe it has a different name in my motherbard. do you have a link where i can download the ssdt u mentioned?



nvm, i found the link to the ssdt http://www.tonymacx86.com/attachmen...y-guide-os-x-10-9-4-10-9-5-ssdt_haswell-e.zip


i wanted to oc my 5820k, do i use ssdt_5820K_OC.aml in the zip file then? and with that ssdt, what frequency i can overclock my cpu to?

thanks.
 
Joined
Jul 25, 2013
Messages
423
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
this is at stock frequency right? and i've have search all over the bios setting for my asrock x99 killer board, nowhere i find xhci setting...maybe it has a different name in my motherbard. do you have a link where i can download the ssdt u mentioned?



nvm, i found the link to the ssdt http://www.tonymacx86.com/attachmen...y-guide-os-x-10-9-4-10-9-5-ssdt_haswell-e.zip


i wanted to oc my 5820k, do i use ssdt_5820K_OC.aml in the zip file then? and with that ssdt, what frequency i can overclock my cpu to?

thanks.


Yes, my benchmarks are at stock. I'm not sure about where your XHCI settings are - I have a Gigabyte board. Yes, if you wanted to overclock, you should use the OC SSDT. How far can you overclock? It depends on your cooler and how patient you are with setting voltages and clock speeds. A very popular overclock on the 5820K is 4.3GHz which can bump your multi core Geekbench up to the 26000 range.

The MAXIMUM you can OC to with that specific SSDT is 5GHz, if I remember the originally post correctly.
 
Joined
Feb 11, 2014
Messages
10
Motherboard
Yosemite 10.10.4
CPU
i7 5820k
Graphics
Gigabyte R9 280X
Mac
Classic Mac
Mobile Phone
i copy the sdst.aml to my Extra folder, and set dropdsdt to yes in boot config. However, trying to restart but get the error "AppleACPIPlatformExpert::start failed ...Unable to find driver for this platform..IOPlatformExpert.cpp:1590"...

update: so i removed sdst.aml and revert back to the original boot config. the problem now is in intel power gadget, the frequency stays at 3.30GHz and power stays at 87 watt. there used to be speedstepping before with nullpowermanagement...pls help


update: got the stepping issue fixed with nullpowermanagement kext. turned out i cannot just copy back the kext in /S/L/E, need to change permission and owner on that file as well.
 
Joined
Feb 11, 2014
Messages
10
Motherboard
Yosemite 10.10.4
CPU
i7 5820k
Graphics
Gigabyte R9 280X
Mac
Classic Mac
Mobile Phone
i updated to 10.10.4. things works fine except you need to re-apply following kext as far as my build goes

1. audio
2. ssd trim
 
Joined
Jul 25, 2013
Messages
423
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
i copy the sdst.aml to my Extra folder, and set dropdsdt to yes in boot config. However, trying to restart but get the error "AppleACPIPlatformExpert::start failed ...Unable to find driver for this platform..IOPlatformExpert.cpp:1590"...

update: so i removed sdst.aml and revert back to the original boot config. the problem now is in intel power gadget, the frequency stays at 3.30GHz and power stays at 87 watt. there used to be speedstepping before with nullpowermanagement...pls help


update: got the stepping issue fixed with nullpowermanagement kext. turned out i cannot just copy back the kext in /S/L/E, need to change permission and owner on that file as well.

It sounds to me like it's an XHCI issue. Again, I'm unfamiliar with your board, so it may be called "USB 3.0 Controller" or something similar. However, if you're satisfied with your performance (knowing that power management really doesn't function) then I would call it a day. I stopped messing with my config a little while ago, and would rather deal with a few things than break everything.
 
Joined
Jul 25, 2013
Messages
423
Motherboard
Asus X99 Deluxe
CPU
E5-2697v3
Graphics
RX 580
Mac
  1. iMac
  2. MacBook
  3. MacBook Air
  4. MacBook Pro
  5. Mac Pro
Classic Mac
  1. iMac
  2. Power Mac
  3. Xserve
Mobile Phone
  1. Android
  2. iOS
I am having a rather large issue - when I try to update to 10.10.4, whether I do the combo update or the delta update via App Store, my system freezes on the restart. All screens go back with just the cursor, forced to hard reset, boots back into 10.10.3 with some fiddling. Next step is to run the combo update from my backup onto a target drive, but I don't know if that works...
 
Joined
Jun 30, 2015
Messages
1
Motherboard
Asus X99-A
CPU
Intel 5930K
Graphics
Titan-X
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. iOS
Maybe I can get some help, I have a ASUS X99-A, Intel 5930k, 32GB Gskill DDR4 2133MHz RAM, OWC 240GB SSD, and a Titan-X, and I have a couple of issues. Everything seems to boot with the flags "npci=0x2000" and the Kext Dev Mode flag. I also have "nvda_drv=1" but I cannot seem to get it to notice the Titan-X at all. Multibeast is set up as in the image and now web drivers give the error that the computer is not supported. Anyone have any advice? Along with this the CPU says 3.5 GHz Unknown, RAM says 0Mhz speed, and Graphics say 3MB in system info. Thanks in advance!
IMG_4213.jpg

EDIT:
Did more research, added "UseMemDetect=No" to the boot flags, RAM now works, changed the identifier to 5,1 and now all the graphics work, did the ALC1150 patch listed on this site and audio works. Now just have to get iMessages done!
 
Top