Contribute
Register

Handoff not working with airport extreme + mini PCIe adapter

Status
Not open for further replies.
Joined
Oct 14, 2015
Messages
64
Motherboard
GA-Z170MX-Gaming-5
CPU
i7-6700K
Graphics
GeForce GT730
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I have followed this guide and purchased an airport extreme + adapter combo. Both WiFi and BT seem to be working. However I'm still not able to hand off to my iPhone. I'm running El Capitan 10.11.1. Build info is in the signature.

1. My BT is working with a keyboard. I also tried a Thinkpad running Ubuntu.

2. Hand-off is enabled in OS X:

3. Bluetooth in System Information looks fine:

4. I successfully ran Continuity Activation Tool without enabling kext-dev-mode in Clover Configurator (could this be the problem?). When I realized, I enabled it in Clover Configurator and rebooted. However, Continuity Activation Tool seems to think kext-dev-mode is still not enabled, although Clover Configurator says otherwise.


5. When I try to re-run CAT, it thinks everything is fine and nothing needs to be done.

6. I can see my iPhone in the BT device list from the Hackintosh. However, when I try to connect it, it'd briefly appear as connected for half a second, and become disconnected:

It also took my many tries to pair with the iPhone. The dialog with a number would appear and disappear immediately. It finally stayed though. But I guess I don't need to pair the Hackintosh with the iPhone, right? My MacBook is not paired with my iPhone and they can hand off each other just fine.

Any help would be greatly appreciated. Thanks.
 
Last edited by a moderator:
Joined
Nov 12, 2011
Messages
130
Motherboard
ASUS P8Z77-V PRO/Thunderbolt
CPU
Core i7 3770K @4.20GHz
Graphics
ASUS GT640-2GD3
Mac
  1. Mac Pro
Classic Mac
Mobile Phone
  1. iOS
kext-dev-mode does nothing in El Capitan 10.11.1

You must use Rt-Variables CsrActiveConfig=0x3 or 0x67

Clover.jpg
 
Joined
Oct 14, 2015
Messages
64
Motherboard
GA-Z170MX-Gaming-5
CPU
i7-6700K
Graphics
GeForce GT730
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
OK, I already set CsrActiveConfig to 0x67 to disable SIP and ran CAT. It looks like AirDrop is working. I assume that means CAT has done its job and Bluetooth is functioning, right? It's strange that handoff is still not working. I have tried to log out from iCloud and log back in a few times and that didn't solve the problem.

kext-dev-mode does nothing in El Capitan 10.11.1

You must use Rt-Variables CsrActiveConfig=0x3 or 0x67

View attachment 160982
 
Joined
Oct 14, 2015
Messages
64
Motherboard
GA-Z170MX-Gaming-5
CPU
i7-6700K
Graphics
GeForce GT730
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. iOS
I was about to logout from all my devices today, which could be a pain (I have an iPhone and 3 Macs including the hack). And it magically started working. And I did absolutely nothing :). Well, I'm not complaining. Thanks!

Have you done the steps that i recommended you in the other post that you opened before?
 
Joined
May 4, 2014
Messages
65
Motherboard
Dell VOSTRO 3478
CPU
I5-8250u
Graphics
HD 620, Radeon HD 520
Mac
  1. MacBook Air
  2. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Status
Not open for further replies.
Top