Contribute
Register

[HALF-SUCCESS] iTunes 12.7 constantly crashing (random messages)

Status
Not open for further replies.
Joined
May 9, 2017
Messages
66
Motherboard
Dell Inspiron 15 5567
CPU
i3-6006U
Graphics
HD 520 (1920 x 1080)
Mobile Phone
  1. Android
@geekomancer Upgrading from Sierra to High Sierra? And did the iTunes problem start after upgrading to High Sierra?
 
Joined
May 27, 2013
Messages
168
Motherboard
GA-Z390 AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
  1. MacBook
  2. MacBook Pro
Mobile Phone
  1. iOS
Hey guys, Not sure if I should be in a separate thread.... I'm using none of those kexts, and for me iTunes 12.7 crashes right at opening — I can't even get to the main window to click on a song. It either crashes on the EULA "Agree" screen, or crashes on "updating library". I get the beach ball, and then have to Force Quit. I tried downgrading to 12.5.5, and re-installing 12.7. I also tried logging in as a new user. Same result. Can't even open iTunes. I have read through this thread, and Apple Discussions. Any suggestions are appreciated, in case I'm missing something obvious. Thanks!

Hi, are you using the iMac.kext or something that enables the Intel Quick Sync feature?
Have you executed VDADecoderChecker? Which results do you see?
 
Joined
Jul 23, 2012
Messages
89
Motherboard
Gigabyte GA-Z77X-UP5-TH
CPU
Intel Core i7-3770K
Graphics
NVidia GeForce GTX 750 Ti (EVGA)
Mac
  1. iMac
I'm on Sierra 10.12.6. I think the problem started after updating iTunes to 12.7.

I am not using any special kexts, just the basics that are included MultiBeast. I am using the Nvidia drivers, so I turned off Inject Intel in Clover Configurator, which had no effect.

I ran VDADecoderCheck, and it gave me error -12473:
2017-10-08 12:57:57.407661-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 0, IOVARendererID property not found

2017-10-08 12:57:57.407888-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 1, IOVARendererID property not found

2017-10-08 12:57:57.407983-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 2, IOVARendererID property not found

2017-10-08 12:57:57.408093-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 3, IOVARendererID property not found

2017-10-08 12:57:57.408169-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 4, IOVARendererID property not found

2017-10-08 12:57:57.408261-0700 VDADecoderChecker[1863:62591] GVA error: IORegistryEntryCreateCFProperty failed for display number 0, IOVARendererID property not found

VDADecoderCreate failed. err: -12473

An error was returned by the decoder layer. This may happen for example because of bitstream/data errors during a decode operation. This error may also be returned from VDADecoderCreate when hardware decoder resources are available on the system but currently in use by another process.

VDADecoderCreate failed. err: -12473

Program ended with exit code: 0
 
Joined
Nov 28, 2012
Messages
34
Motherboard
Dell 5570
CPU
i5-8250U
Graphics
UHD620
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I had the same issue and AppleALC.kext was the cockpit on macOS 10.13.0 (17A405) & iTunes 12.7.0.66.

The kexts in /EFI/CLOVER/kexts/10.13/ are
Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, AppleALC.kext, RealtekRTL8111.kext, USBInjectAll.kext
Few Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, RealtekRTL8111.kext, USBInjectAll.kext

I'm ok since I'm using USB headset and doesn't really need the AppleALC.kext.

Edit) No, it became much stable but it still crashes sometimes.
 
Last edited:
Joined
Nov 14, 2015
Messages
51
Motherboard
Intel C220 Series
CPU
Xeon E3 1246v3
Graphics
Intel HD P4600 + Nvidia GeForce GT 1030 2GB
Mac
  1. iMac
I'm on Sierra 10.12.6. I think the problem started after updating iTunes to 12.7.

I am not using any special kexts, just the basics that are included MultiBeast. I am using the Nvidia drivers, so I turned off Inject Intel in Clover Configurator, which had no effect.

I ran VDADecoderCheck, and it gave me error -12473:

You need Lilu+NvidiaGraphicsFixup to enable offline video decoding (with Intel HD Graphics).
 
Joined
Nov 14, 2015
Messages
51
Motherboard
Intel C220 Series
CPU
Xeon E3 1246v3
Graphics
Intel HD P4600 + Nvidia GeForce GT 1030 2GB
Mac
  1. iMac
I had the same issue and AppleALC.kext was the cockpit on macOS 10.13.0 (17A405) & iTunes 12.7.0.66.

The kexts in /EFI/CLOVER/kexts/10.13/ are
Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, AppleALC.kext, RealtekRTL8111.kext, USBInjectAll.kext
Few Crash) FakeSMC.kext, Lilu.kext, IntelGraphicsFixup.kext, RealtekRTL8111.kext, USBInjectAll.kext

I'm ok since I'm using USB headset and doesn't really need the AppleALC.kext.

Edit) No, it became much stable but it still crashes sometimes.

For me, VoodooHDA seems to be the problem. I switched to AppleALC and now iTunes hasn't crashed yet.
 
Joined
Jul 23, 2012
Messages
89
Motherboard
Gigabyte GA-Z77X-UP5-TH
CPU
Intel Core i7-3770K
Graphics
NVidia GeForce GTX 750 Ti (EVGA)
Mac
  1. iMac
Update: After clearing my kernel caches, I tried re-installing iTunes 12.7 (previously, it failed to install) — and this time it worked! Seems to be running as expected.

FYI, I was also having issues with MultiBeast. Has anyone else experienced issues with MultiBeast failing to install, while also getting the iTunes crashes?

Here's what I did:
  • Deleted all the FakeSMC stuff, and used KextBeast to install the latest FakeSMC from here: https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek/downloads/
  • Re-installed everything with Multi-Beast, and copied the new FakeSMC into my /EFI/Clover/Kexts/Other/
  • Installed NvidiaGraphicsFixup + Lilu (thanks Tamgya).
  • Rebuilt my kernel cache:
    Code:
    sudo touch /System/Library/Extensions && sudo kextcache -u /
  • Re-installed iTunes.
In a couple days I'm going to test removing the NvidiaGraphicsFixup & Lilu, to see if it runs without them. (Seems like I should be able to do without....)

I hope this helps someone!
 
Last edited:
Joined
May 9, 2017
Messages
66
Motherboard
Dell Inspiron 15 5567
CPU
i3-6006U
Graphics
HD 520 (1920 x 1080)
Mobile Phone
  1. Android
I think there's something wrong with how iTunes tries to connect to iTunes Store. The same javascript.dll that someone posted a few days ago. Hopefully this gets fixed. Gonna downgrade to Sierra 10.12.6 for now. I give up. Avenge me, brothers.
 
Last edited:
Status
Not open for further replies.
Top