Contribute
Register

Hackintosh, Universal Audio - Static Noise Problem

Joined
Oct 27, 2019
Messages
34
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Hey guys!

A bit of a funny story.

So on my previous system, the noise has disappeared in idle state once I set my VCORE to 1.28. Noise was present majorly with GPU activity.

However, I've just built a new Hackintosh with brand new different components, and the noise is back there! I am also using a newer Apollo X8 with TB3.

Everything is new apart from the power supply. I upgraded a PSU in my old system with, again, no effect on the noise, hence I reused this current one.

Anyways, this is interesting and bothersome. What is even more interesting - I can't get rid of this idle noise on the new system. Fixed VCORE doesn't help either.

Interested to discuss!
 
Joined
Sep 9, 2010
Messages
398
Motherboard
Asrock Z490m pro-4
CPU
i9 10850K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey guys!

A bit of a funny story.

So on my previous system, the noise has disappeared in idle state once I set my VCORE to 1.28. Noise was present majorly with GPU activity.

However, I've just built a new Hackintosh with brand new different components, and the noise is back there! I am also using a newer Apollo X8 with TB3.

Everything is new apart from the power supply. I upgraded a PSU in my old system with, again, no effect on the noise, hence I reused this current one.

Anyways, this is interesting and bothersome. What is even more interesting - I can't get rid of this idle noise on the new system. Fixed VCORE doesn't help either.

Interested to discuss!
in my experience, it has little to do with the interface, and more to do with the amplification. I had the issue that seemed to be from the graphics. Scrolling and moving windows around would trigger the noise. I broke off the ground from a power strip and plugged the powered monitors into it and the noise is 100% gone. There are more safe ways to isolate grounds, but if this works, you'll know you have a ground loop to deal with.
 
Joined
Oct 27, 2019
Messages
34
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
It feels that this is the case here, too.

I've done a test. One power socket on the wall. One power strip connected to that socket. My PC, Apollo, Screen, Power Amplifier for my Amphions are connected to the strip, nothing else.

The noise is there, when there is GPU activity. If I disconnect Thunderbolt cable from my PC, the noise is gone. If I disconnect the speaker outputs from Apollo, the noise is gone. If I switch the cables from my Apollo into an amp, the noise is intact.

There is not much to cause a ground loop here - apart from the amplifier then? Yet, everything is connected to the same power strip...
 
Joined
Sep 9, 2010
Messages
398
Motherboard
Asrock Z490m pro-4
CPU
i9 10850K
Graphics
Vega 64
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
It feels that this is the case here, too.

I've done a test. One power socket on the wall. One power strip connected to that socket. My PC, Apollo, Screen, Power Amplifier for my Amphions are connected to the strip, nothing else.

The noise is there, when there is GPU activity. If I disconnect Thunderbolt cable from my PC, the noise is gone. If I disconnect the speaker outputs from Apollo, the noise is gone. If I switch the cables from my Apollo into an amp, the noise is intact.

There is not much to cause a ground loop here - apart from the amplifier then? Yet, everything is connected to the same power strip...
yeah, sometimes making sure all of your power cords are the same length and plugged into the same outlet can minimize the noise, but the only sure fire way to eliminate ground loop hum is to make sure your setup only has one ground. That means eliminating all but 1 ground, or isolating the ground in the audio signal cable.
 
Joined
Oct 27, 2019
Messages
34
Motherboard
Asus TUF B550-Plus
CPU
Ryzen 5 5600
Graphics
RX 580
Mac
  1. iMac
Mobile Phone
  1. Android
Problem solved by using a power socket for PC only in different room. Weird, but this works. Dead silent. Thanks

antieatingactivist for the help!!​

 
Joined
Aug 25, 2019
Messages
78
Motherboard
ASUS ROG X MAXIMUS HERO (WIFI AC)
CPU
I7-8700K
Graphics
560
Mac
  1. iMac
Mobile Phone
  1. iOS
Problem solved by using a power socket for PC only in different room. Weird, but this works. Dead silent. Thanks

antieatingactivist for the help!!​

Hi all, i am having the same problem, in most regards, however more so. Let me explain, i have tried pluggin my pc into an outlet in another room, and still ran into the constant static. additionally, while trying to utilize the microphone ports on the hackintosh, i have found that the front has a different kind of constant static, and the back signal is very quiet, and terrible quality.
i’m posting this as a last resort. i don’t know what i’m doing with the audio side of it, and i’m almost tempted to fresh install and see if i messed up somewhere in downloading the proper audio drivers/kexts.
an additional question i have is, if i downloaded AppleAlc, and it works, will there be a different layout-I’d that affects the quality of the ports, or is it more that if it works thats the best it’s going to get?

Any response at all would be appreciated!

Edit: SOLVED; i had a pair of light strips in the studio that were interfering with the mic signal.

Figured it out right after i pressed send, but i can’t delete a comment so i figured I would keep this up so other people can see what i did. Heres a list of things that i tried that eventually fixed it

1: Check all your cords. Especially that they are plugged in all the way, as clean connections are everything.
2: replace necessary cord if you can. meaning try changing out aux cords, and the sorts to see if it’s a cord problem.
3: plug your pc in in a different rooms outlet, in order to check for magnetic interference
4: and finally check system settings. Something i came across was that if i turn the input gain in system preferences to 100, there would be noise, yet at 75 it would go away. I have personally left mine at 75, and adjusted gain on my audio interface to bring it back up, and it works just fine.
5 (optional): check headphones and the equipment itself.
it is possible that you blew a speaker or that simply your headphones are giving out due to one reason or another. IF you have spares, try and change them. if not, don’t stress out and buy all new equipment. A quote that i found while looking for a solution was this “audio engineers have spent thousands of dollars on new equipment to try and get rid of static, but often times the solution is simple”. Just recheck everything, and you’ll be fine.



I don’t know if this will help anybody as i said previously i’m not that well versed in the audio side of things, but i haven’t seen any straight forward guides to try and fix this problem, so i figured i would through this out there. cheers, and Happy New Year.
 
Last edited:
Top