Contribute
Register

Hackintosh shuts off but usb ports are left with power

Joined
Aug 28, 2015
Messages
15
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel I7700 Kaby lake
Graphics
Nvidia GT 740
Mac
iMac
Mobile Phone
Android
Hello friends.

I'm new to the topic hackintosh. I just put together a computer with the following hardware:

Processor Intel I7700.

Mother Gigabyte GA-270-Gaming 3

I installed Sierra following the instructions of Tonymac and everything worked perfectly, except the shutdown which, instead of shutting down, rebooted.

I could solve this by activating FixShutdown_0004 in Clover Configurator.

Now the computer shuts off but the usb ports are left with power as the keyboard is on and the audio card (Presonus Audiobox 22 VSL) as well.

I have activated ErP in the mother bios.

Thank you very much for your help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello friends.

I'm new to the topic hackintosh. I just put together a computer with the following hardware:

Processor Intel I7700.

Mother Gigabyte GA-270-Gaming 3

I installed Sierra following the instructions of Tonymac and everything worked perfectly, except the shutdown which, instead of shutting down, rebooted.

I could solve this by activating FixShutdown_0004 in Clover Configurator.

Now the computer shuts off but the usb ports are left with power as the keyboard is on and the audio card (Presonus Audiobox 22 VSL) as well.

I have activated ErP in the mother bios.

Thank you very much for your help.
Best to avoid FixShutdown_0004.
You can fix your "automatic restart after shutdown" by setting XHC.PMEE=0 in _PTS (DSDT) when Arg0==5.
 
Joined
Aug 28, 2015
Messages
15
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel I7700 Kaby lake
Graphics
Nvidia GT 740
Mac
iMac
Mobile Phone
Android
Thank you very much for your answer

Two questions:

1) I am new to the topic, how do I make that configuration? Could you pass me some tutorial online?

2) Does this have anything to do with usb that do not go off?

Thank you very much for your help.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,134
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you very much for your answer

Two questions:

1) I am new to the topic, how do I make that configuration? Could you pass me some tutorial online?
I have some examples where I have done it.
Look at my NUC repo on github, for example.

2) Does this have anything to do with usb that do not go off?
I think so. It seems quite likely that _PTS plays a part in shutting things down, and by using FixShutdown_0004, you're preventing the code in _PTS from running.
 
Joined
Aug 28, 2015
Messages
15
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel I7700 Kaby lake
Graphics
Nvidia GT 740
Mac
iMac
Mobile Phone
Android
Hi.

I found the following code in your repository:




// _PTS override to fix "auto restart after shutdown"

//DefinitionBlock ("", "SSDT", 2, "hack", "hack", 0)
//{
// In DSDT, native _PTS is renamed ZPTS
// As a result, calls to these methods land here.
External(ZPTS, MethodObj)
External(_SB.PCI0.XHC.PMEE, FieldUnitObj)
Method(_PTS, 1)
{
ZPTS(Arg0)
If (5 == Arg0)
{
// avoid "auto restart" after shutdown
\_SB.PCI0.XHC.PMEE = 0
}
}
//}
//EOF



Where should I place it?

As I told you, I'm new and I'm just handling the Clover Configurator.

Thank you very much.
 
Joined
Aug 28, 2015
Messages
15
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel I7700 Kaby lake
Graphics
Nvidia GT 740
Mac
iMac
Mobile Phone
Android
Upgrade.

I finally got the usb ports to shut down when the computer was turned off.

What I did was connect the mouse, the keyboard and the USB audio card (Presonus Audiobox) to the USB 3.1 ports, and with this everything turns off perfectly.

The sleep mode was the other problem I had, because when I activated the dream, the machine would turn on again.

Well, after switching the mouse, keyboard and audio card to USB 3.1 ports, the computer goes into sleep mode, but upon "wake up" the computer, the audio card is turned off and I have to disconnect and reconnect the cable to work again.

I am a newbie in hackintosh so I will thank you for all the help with which you can guide me.
 
Joined
Sep 13, 2012
Messages
34
Motherboard
Gigabyte Z97X-UD5H
CPU
i7-4790K
Graphics
EVGA Geforce GTX 960 SSC ACX 2.0
Mac
Mac Pro
Classic Mac
Mobile Phone
Upgrade.

I finally got the usb ports to shut down when the computer was turned off.

What I did was connect the mouse, the keyboard and the USB audio card (Presonus Audiobox) to the USB 3.1 ports, and with this everything turns off perfectly.

The sleep mode was the other problem I had, because when I activated the dream, the machine would turn on again.

Well, after switching the mouse, keyboard and audio card to USB 3.1 ports, the computer goes into sleep mode, but upon "wake up" the computer, the audio card is turned off and I have to disconnect and reconnect the cable to work again.

I am a newbie in hackintosh so I will thank you for all the help with which you can guide me.
Please, can you tell us how did you do it?
 
Joined
Aug 28, 2015
Messages
15
Motherboard
Gigabyte GA-H270-Gaming 3
CPU
Intel I7700 Kaby lake
Graphics
Nvidia GT 740
Mac
iMac
Mobile Phone
Android
The mouse, keyboard, and audio card were connected to the motherboard's rear USB 2.0 ports.

What I did was change them from port: mouse and keyboard were connected to the USB 3.1 ports and the audio card was connected to a USB 3.0 compatible USB 2.0 port.

With this, the equipment already exits normally.

I know that the problem is not solved at all, but at least the computer manages to shut down.

Undoubtedly there is a problem between Sierra and USB ports.

Greetings.
 
Joined
Jul 23, 2011
Messages
7
Motherboard
GA-Z270MX-Gaming 5
CPU
i7-7700k
Graphics
Nvidia GTX 1070 SC Black
Hey Rehabman..sorry to revive this thread..but I saw this while researching for a solution to my problem. I just finished my High Sierra build and everything works well except when I use the two rear USB3.1 & Type-C ports. When something is plugged in those ports..my shutdown just reboots. I also get the 'Disk Not Ejected properly' error when I use sleep with those ports.

It only happens with those two USB ports. I'm currently using the 'fixshutdown' on clover configurator..but I think your solution might work except I'm new to this and don't know exactly how to do the following:
Best to avoid FixShutdown_0004.
You can fix your "automatic restart after shutdown" by setting XHC.PMEE=0 in _PTS (DSDT) when Arg0==5.
 

Top