Contribute
Register

Solved > Hackintosh not recognizing Ethernet

Joined
Jun 8, 2020
Messages
4
Motherboard
MSI H310M PRO-M2 PLUS
CPU
Intel Core i5 9400F
Graphics
AMD Radeon RX580
I've just finished building a Hackintosh mainly for content creation and a little gaming on the side. The specs are as follows:

CPU: Intel i5 9400F
Mobo: MSI H310M PRO-M2 PLUS
RAM: G.Skill Ripjaws 3000Mhz 8GB x2
GPU: Radeon RX580
PSU: Corsair CV550
(No Wifi or Bluetooth cards installed at this time)

I installed the OS using UniBeast and everything seems to be running fine, however my Ethernet connection is not recognized by the Hackintosh. after doing a few google searches i found that my mother board comes equipped with Realteks RTL8111H Gigabit Ethernet Controller, so naturally I downloaded the corresponding kext file for the Ethernet. first i downloaded the newest version i could find which was RealtekRTL8111-v2.2.2 but that didnt seem to work, so i tried other versions which also didn't work (tbh i have no clue if they worked or not but there was no Ethernet options on the network config so i assumed they didn't work). I've also tried checking in the BIOS to see if there actually is a connection or not and it turns out there is (although sometimes it would show as disconnected after a reboot). I jut want to know how i can solve this issue and whether or not other people have faced the same issue. Help is much appreciated!
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,799
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
after doing a few google searches i found that my mother board comes equipped with Realteks RTL8111H Gigabit Ethernet Controller

Intel.png
 
Joined
Jun 8, 2020
Messages
4
Motherboard
MSI H310M PRO-M2 PLUS
CPU
Intel Core i5 9400F
Graphics
AMD Radeon RX580
guess i was wrong, thx for the help. will get back to you if i have more issues (Solved: Found and downloaded the correct kext and is working properly now, thx for the help)
 
Last edited:
Joined
Jun 16, 2012
Messages
33
Motherboard
Asus Maximus VI Hero Z390
CPU
i7-9700K
Graphics
Vega 64
Hey mate, I am having the same issue, my motherboard has the same intel ethernet driver, did you end up fixing it?
 
Joined
Jun 23, 2015
Messages
16
Motherboard
ASRock X99 Extreme6 - Clover
CPU
i7-6850K
Graphics
GT 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello! Try this.
 

Attachments

  • IntelMausi.kext.zip
    57.7 KB · Views: 179
Top