Contribute
Register

Hackintosh Maverick VPCSA - black screen

Joined
Nov 18, 2013
Messages
16
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GTX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hackintosh (Mavericks) VPCSA - stuck before installation

Hello


I saw here a guide for hackintosh 10.9 on vaio laptops and wanted to give it a try.

A problem occured and I've hoped that u might help me.

I'm using an VPCSA3X9E VAIO with 13,3 Zoll, 1600 x 900 Pixeln, SSD, 8GB RAM, Intel Core i7 2640M and AMD Radeon HD 6630M. I unlocked the BIOS, changed neccesary values and removed the AppleIntelCPUPowerManagment from the installation device because I got a panic error from it. I added the DSDT for my resolution and tried several flags -

but I still get, before installation menu shows up after the apple logo, a complete black screen - even with -v.

Just the combination of GraphicsEnabler=No IGPEnabler=No -x resulted in a panic for the driver AppleIntelSNBGraphicsFB(8.1.8)

Does somebody have an idea what might help me? I tried searching through this and many other forums but it was either not exactly my problem or it did not changed anything
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hello


I saw here a guide for hackintosh 10.9 on vaio laptops and wanted to give it a try.

A problem occured and I've hoped that u might help me.

I'm using an VPCSA3X9E VAIO with 13,3 Zoll, 1600 x 900 Pixeln, SSD, 8GB RAM, Intel Core i7 2640M and AMD Radeon HD 6630M. I unlocked the BIOS, changed neccesary values and removed the AppleIntelCPUPowerManagment from the installation device because I got a panic error from it. I added the DSDT for my resolution and tried several flags -

but I still get, before installation menu shows up after the apple logo, a complete black screen - even with -v.
You don't want to remove AppleIntelCPUPowerManagement. See: http://www.tonymacx86.com/mavericks-laptop-support/111243-power-management-sandy-bridge-ivy-bridge-laptops.html

Just the combination of GraphicsEnabler=No IGPEnabler=No -x resulted in a panic for the driver AppleIntelSNBGraphicsFB(8.1.8)

Does somebody have an idea what might help me? I tried searching through this and many other forums but it was either not exactly my problem or it did not changed anything
Mavericks AppleIntelSNBGraphicsFB is v8.18.27. What DSDT patches did you apply. Post your DSDT from /Extra/dsdt.aml.
 
Joined
Nov 18, 2013
Messages
16
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GTX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
Hackintosh (Mavericks) VPCSA - black screen

First of all thank you for your quick reply.

Here is my DSDT: http://filebin.net/osfjetw1qo/DSDT.txt

edit: Normally I get a black screen after the first apple logo, but I recreated the package with the dsdt above and now I'm stuck for like 45mins at the second the one with a colourful loading icon :beachball: in the top left corner ( sometimes even at the first apple logo screen (with and without spinning wheel) )



My Specs
I'm using an VPCSA3X9E VAIO with 13,3 Zoll, 1600 x 900 Pixeln, SSD, 8GB RAM, Intel Core i7 2640M and AMD Radeon HD 6630M. I unlocked the BIOS and. changed neccesary values.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
First of all thank you for your quick reply.

Here is my DSDT: http://filebin.net/osfjetw1qo/DSDT.txt

edit: Normally I get a black screen after the first apple logo, but I recreated the package with the dsdt above and now I'm stuck for like 20mins at the second the one with a colourful loading icon :beachball: in the top left corner ( sometimes even at the first apple logo screen (with and without spinning wheel) )



My Specs
DSDT looks ok, assuming the EDID data is valid for your display. Did you collect it yourself from Windows MonInfo?
 
Joined
Nov 18, 2013
Messages
16
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GTX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
DSDT looks ok, assuming the EDID data is valid for your display. Did you collect it yourself from Windows MonInfo?
No I took it from a prepared package made by CyberWalrus for VPC SA/SB/SE/... made for my resolution

I just have no idea what might be the reason why I'm stuck at this loading screen:

screen.jpg
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
No I took it from a prepared package made by CyberWalrus for VPC SA/SB/SE/... made for my resolution

I just have no idea what might be the reason why I'm stuck at this loading screen:

It is never a good idea to use EDID data from another computer. You should collect your own. Displays vary between computers even with the exact same model#.

And you should always boot "-v" to diagnose boot issues.
 
Joined
Nov 18, 2013
Messages
16
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GTX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
I've set several flags and got to the installation menu :) seems that it was enough for the moment...

...so I installed Mac OS X successfully and installed most of the recommended kext.


But after my first restart I'm again stuck at the loading screen with an error for IOBluetoothHCIController.

When Bluetooth is turned off I get [SearchForTransportEventTimeOutHandler] - Missing Bluetooth Controller Transport!
and if I turn it on during start chimera promts [protectedBluetoothHCIControllerTransportShowsUp] - Connect to the transport successfully -- 0x6d80 -- 0x4000 -- 0x0c00 ... BluetoothHostControllerUSBTransport... did not get the commandWakeup()...Resetting IOCatalogue
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I've set several flags and got to the installation menu :) seems that it was enough for the moment...

...so I installed Mac OS X successfully and installed most of the recommended kext.


But after my first restart I'm again stuck at the loading screen with an error for IOBluetoothHCIController.

When Bluetooth is turned off I get [SearchForTransportEventTimeOutHandler] - Missing Bluetooth Controller Transport!
and if I turn it on during start chimera promts [protectedBluetoothHCIControllerTransportShowsUp] - Connect to the transport successfully -- 0x6d80 -- 0x4000 -- 0x0c00 ... BluetoothHostControllerUSBTransport... did not get the commandWakeup()...Resetting IOCatalogue
It is a graphics issue. Try booting with IGPlatformID=01660004
 
Joined
Nov 18, 2013
Messages
16
Motherboard
Asus P8Z77-V LX
CPU
i7-3770K
Graphics
GTX 570
Mac
MacBook Pro
Mobile Phone
Android, iOS
It is a graphics issue. Try booting with IGPlatformID=01660004
sadly it did not work - also 00301000 didn't fix it.

But thanks for your amazing support!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,691
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
sadly it did not work - also 00301000 didn't fix it.

But thanks for your amazing support!
Post your detailed specs. And be sure to update your profile with the same information.

Also, boot "-v" and post a quality photo of the entire screen.
 
Top