Contribute
Register

HACKINTOSH? HP ELITEDESK 800 G3 MINI

Joined
Apr 11, 2020
Messages
3
Motherboard
HP Elitedesk 800 G3 Mini
CPU
i5-7500
Graphics
Intel HD Graphics 630
Mobile Phone
  1. Android
I purchased this wifi+bluetooth card (BCM943224PCIEBT2) and it arrived today.
I installed it on my Elitedesk 800 g3, the wifi worked out of the box, but unfortunately the bluetooth does not work. Here is the screenshot of hackintools PCI and I also attached my working EFI (only bluetooth is not working)

I am looking for fix for the bluetooth I tried some of the methods on how to fix the problem but none of them worked, I think I am not doing it correct way. Can anyone help me with this?
I need to make bluetooth work since I am using a bluetooth keyboard and mouse. Right now I am using a old kb and mouse :D

Thank you!

Edit: 12/15/2020
If I install Catalina on this, do you think bluetooth would work fine or I will be having the same issue?
 

Attachments

  • EFI.zip
    20 MB · Views: 83
  • Screen Shot 2020-12-14 at 4.45.57 PM.png
    Screen Shot 2020-12-14 at 4.45.57 PM.png
    975.9 KB · Views: 63
Last edited:
Joined
Apr 16, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 Mini 35W
CPU
Intel Core i5-7500T
Graphics
iGPU HD Graphic 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Someone has customized AppleALC.kext to fix the microphone problem. We should be seeing a working microphone for Conexant CX20632 in a future AppleALC.kext release.
Hi, I had worked on getting AppleALC work with both audio output and one input. Unfortunately the input was working as audio in and not as a microphone. When plugging non amplified sources (like a mic) the audio in was extremely faint. I did not manage to patch AppleALC again after updating my kext (my knowledge of Xcode is practically 0 and I managed the ALC hack without a clue of what I was doing) and had no time to go through the process again. If someone is savvy of Xcode and willing to take over what I did, I am willing to share.


On another note. Has anybody managed to install Big Sur? I tried many times, both upgrading and blank install, but never managed to pass the first reboot (stage two on installation).
 
Top