Contribute
Register

HACKINTOSH? HP ELITEDESK 800 G3 MINI

Joined
Nov 27, 2019
Messages
2
Motherboard
HP EliteDesk 800 G2
CPU
i5 6700 t
Graphics
intel hd 530
Here is my EFI. I managed to get Mojave working on my EliteDesk 800 G3 Mini. It's a Skylake i5 6500 with Intel Graphics 530. My HDD is a Toshiba nvme KXG50ZNV256G I formatted in APFS.
Everything is working except intel wifi/bluetooth (but it's normal) and sleep/wake is also not working (normal again). I haven't checked hdmi audio (my monitor doesn't have audio but the speaker and the 2 headphones of the front panel are working fine.
For the installation I had to add Input FakeID : 0x19120000. It's not in the config.plist of the EFI I uploaded because once installed you can remove the FakeID from the config.plist

How did you manage to start from a USB drive? I have tried several options in the BIOS, but it doesn't work
 
Joined
Jan 15, 2020
Messages
7
Motherboard
Fujitsu ESPRIMO G558
CPU
i7-9700
Graphics
UHD 630
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Unibeast 9.3.0 installs a higher Clover Version 51XX on the stick. Do I have to change to
Clover r4701.RM (Build by RehabMan)? And if yes, how can I do that? Can I exchange the CLOVER folder on the stick?
The installation finished, but booting from HDD causes a restart after 20sec.
 

yop

Joined
Feb 13, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 DM 35W
CPU
Intel i5-6500T
Graphics
Intel® HD Graphics 530
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hi everyone,

I am trying to install Mojave on my HP EliteDesk 800 G3 DM with an i5-6500T and Intel HD 530.
I boot with 2.4K rev clover 4798 without any problem, install Mojave on the SSD but once I reboot into clover and select the drive where Mojave has been installed, I see Mojave's boot info on the screen then the screen goes black and goes to sleep mode.
I am using the VGA port.

Did someone managed to make the VGA port working? Or it is definitely un-suppported.

Thanks a lot in advance for your help,

Yop
 

yop

Joined
Feb 13, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 DM 35W
CPU
Intel i5-6500T
Graphics
Intel® HD Graphics 530
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
Hi everyone,

I am trying to install Mojave on my HP EliteDesk 800 G3 DM with an i5-6500T and Intel HD 530.
I boot with 2.4K rev clover 4798 without any problem, install Mojave on the SSD but once I reboot into clover and select the drive where Mojave has been installed, I see Mojave's boot info on the screen then the screen goes black and goes to sleep mode.
I am using the VGA port.

Did someone managed to make the VGA port working? Or it is definitely un-supported.

Thanks a lot in advance for your help,

Yop

I figured this out by myself :)

VGA is not supported... Ta daaa

Anyway, used DP and it is working like a charm.

Bottom line I did manage to run macOS 10.14.1 running on HP EliteDesk 800 G3 DM.

What is working:
  • CPU power management (had to create a custom SSDT)
  • Bluetooth / WiFi is working
    I bought an NGFF M.2 wifi + bluetooth card (OLVINS BCM943224PCIEBT2 WiFi Bluetooth Airport Wireless Network Card) and an adapter (Cablecc BCM94360CS2 BCM943224PCIEBT2 Wireless Card to NGFF M.2 Key A/E Adapter) to put inside
  • Intel Graphic HD 530 working
  • Network (LAN)
  • Sound
  • USB 3 (had to create a custom SSDT)
What is not working:
  • Hibernation (and it bothers me....:banghead:) (went through the forum posts here but did not managed to make it work)
Remarks: do not use VGA :D

Questions:
  • Should I update to the latest version ? Always?:think:
  • Should i update always my kext?:think:

Thanks.
 
Last edited:

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,993
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
I figured this out by myself :)

VGA is not supported... Ta daaa

Anyway, used DP and it is working like a charm.

No I have another question about Clover. As I am using rev 4798, should I update to the latest version ? Always?

Thanks.
VGA hasn't really been supported on mac's for around 10 years or

updating clover.... up to you but don't fix something that isn't broken :)
 

yop

Joined
Feb 13, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 DM 35W
CPU
Intel i5-6500T
Graphics
Intel® HD Graphics 530
Mac
  1. MacBook
  2. MacBook Pro
Classic Mac
  1. Apple
Mobile Phone
  1. iOS
VGA hasn't really been supported on mac's for around 10 years or

updating clover.... up to you but don't fix something that isn't broken :)

Hi Feartech,

Thanks for the reply.

Well I was thinking the same thing in fact, "if it is working why fix it".

Good advice, I'll stick to it ;-)
 
Joined
Aug 10, 2019
Messages
50
Motherboard
HP Elitedesk G3 800 -
CPU
i5-6500
Graphics
HD 530
Mobile Phone
  1. iOS
Catalina 10.15.4 works great ;)
 
Last edited:
Joined
Apr 16, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 Mini 35W
CPU
Intel Core i5-7500T
Graphics
iGPU HD Graphic 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Hi all. I just installed Catalina with Opencore on this machine and it works quite well so far. EVERYTHING (that I have tested so far) WORKS! Also sleep!

I am planning to create a thread with EFI and guide but I want to finish fine-tuning the hack. This morning I de-bloated my SSDT's and I want go through all the post-install properly. Although the machine works perfectly.
In the meantime I can share my little (it was my first hackintosh ever!) knowledge about it if needed.

The only very annoying issue I have is CMOS reset at each boot. It seems a pretty common issue with OSX15.4 but I haven't managed to fix the issue yet. Any help with that would be very much appreciated.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
25,993
Motherboard
Asus N752VX-OpenCore
CPU
i7-6700HQ / HM170
Graphics
HD 530 1920 x 1080
Mac
  1. iMac
Mobile Phone
  1. iOS
Hi all. I just installed Catalina with Opencore on this machine and it works quite well so far. EVERYTHING (that I have tested so far) WORKS! Also sleep!

I am planning to create a thread with EFI and guide but I want to finish fine-tuning the hack. This morning I de-bloated my SSDT's and I want go through all the post-install properly. Although the machine works perfectly.
In the meantime I can share my little (it was my first hackintosh ever!) knowledge about it if needed.

The only very annoying issue I have is CMOS reset at each boot. It seems a pretty common issue with OSX15.4 but I haven't managed to fix the issue yet. Any help with that would be very much appreciated.
please read the rules regarding hardware profile:
 
Joined
Apr 16, 2020
Messages
9
Motherboard
HP EliteDesk 800 G3 Mini 35W
CPU
Intel Core i5-7500T
Graphics
iGPU HD Graphic 630
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
Sorry, I did this very first hack just yesterday. I have updated my profile.
 
Top